PDA

View Full Version : Re: SB still disconnecting from SN



rocket j squirrel
2006-03-20, 16:03
(Brought over from the General forum, as Dean suggested.)

I didn't change the MAC address. There is no predicting when SN will lose connection with my SB.

Backgound: As I described on the original thread over on the General forum, SN will suddenly, without any reason that I can see, announce that my SB is not connected.

But my SB /is/ connected, and it will continue to play SN streams, like Pandora, and my Favorites. With the remote, I can change streams. But SN continues to say it is not connected. Refreshing the browser doesn't fix anything. My solution, so far, has been to cycle the power to the SB. Today, as a highly scientific test, I just let the SB play. For hours it played. For hours, SN denied it was connected. I went out to lunch a little bit ago. Came back, and SN now cheerfully says that the SB is connected.

What is cool, is that andyg is working on this. I don't mind finding bugs, as long as there is a sense that someone is hammering away at them! Thanks, folks!

andyg
2006-03-20, 16:23
Before Friday's update, there was a bad race condition where if your
player disconnected from one SN instance and reconnected to a
different one, after 5 minutes it would get marked as disconnected.
I fixed that one, but there is still another race condition between
the time the 'client disconnect' message is sent on the old instance
and your player connects to the new instance. If your player
reconnects too fast (or the old instance is slow/loaded), the
disconnect message would hit after the reconnect and change the
status to disconnected. The solution is simple, don't mark the
status disconnected if another instance has already marked it
connected. I'll fix this up and it will be in the next update. For
now unfortunately you'll have to sign off/on when this occurs.

rocket j squirrel
2006-03-20, 16:47
And now, one hour later, my SB is playing a Pandora stream, but for reasons unknown, SN now says that it is not connected. And during that period of time, I did nothing but let it play in the background while I went about my business here in Frostbite Falls.

nicketynick
2006-03-21, 07:17
So its the old SB firmware vs. wireless AP compatibility problem in another manifestation then? ie. my SMC WBR14g is buggy with SlimServer 6.2.1 (f/w 28), and probably the same compatibility problems cause the disconnections that result in multiple SN instances? I guess I really need to get brave and try 6.2.2 or 6.5, but there are so many other bugs...... Has anybody tested/had success with the above AP and the newer SlimServer/firmware combinations?

rocket j squirrel
2006-03-28, 13:37
How we coming on this bug? My SB is still disconnecting from SN, as described above.