PDA

View Full Version : SB2 no longer connecting to wireless network!



oli
2006-03-18, 12:41
After resetting the MAC of my player, on the advice of slim support due to a bug with Squeeze Network, my player is no longer connecting to my network. I think it is a problem with it's DHCP function as when it obtains an IP address it is totally unlike that of the other devices on my network. I contacted Slim support about this on Friday morning but have yet to receive a response. Please help, as now, on the basis of advise from Slim support I can no longer use my player!

Cheers!

Oli

Mark Lanctot
2006-03-18, 13:59
If it obtains an IP address unlike the rest of your network (i.e. 168.xxx) then can't access your wireless network at all. It has nothing to do with DHCP, it can't communicate with your router.

Do you have MAC address filtering activated in your router?

You haven't changed wireless passphrases have you? Resetting the SB would have reset its passphrase, and you may have re-entered it incorrectly. Look for mistakes as well as trailing spaces.

oli
2006-03-18, 14:39
I have disabled MAC filtering (called Access Control on my Netgear DG834GT)to no avail, (the SB2 had worked with this turned on before anyway)and also entered the reset MAC address into the access control list, agian to no avail. The SB connects to the router when I disable all security settings, but I am not prepared to go without WPA security, and the SB2 has been working fine with it all up until the MAC reset I did on Thursday. I've also checked the WPA passphrase on the player corresponds to the router's. What's going on?

Cheers

Oli

oli
2006-03-19, 10:44
Having checked things further, the problem appears to be that the SB2 will not connect to the network when WPA-PSK is enabled on my router (an IP address is assigned but it is completely different from any of the other devices on the network, see below). Once this is disabled, the SB connects to the network and is assigned an IP address matching the other devices on the network, i.e 192.168...instead of the strange one assigned when WPA is activated, e.g. 169.254.228.49.
This is bizarre because, as I've already said, my SB2 worked flawlessly with WPA-PSK activated on my router for months. The problem has only arisen since resetting the SB2's MAC, on the advice of Slim support, to match that printed on its' base. Please help guys!

Cheers!

Oli

snarlydwarf
2006-03-19, 12:27
Try setting the router with a Truly Stupid(TM) Password. Something like.. well, "pass".

Then set the SB2 key to that.

Remember that 'Add' on the remote is 'delete'. 'pass' is not the same as 'Pass' and not the same as 'pass ' -- extra spaces at the end will haunt you.

If it works with a Truly Stupid(TM) Password, then the problem isn't the encryption, it's the password: use something more secure but now you'll know the encryption works even if entering keys is a pain.

oli
2006-03-19, 13:26
Nope. Just temporarily set the WPA-PSK network key to 12345678 (has to be minimum of 8 characters) and whilst the SB2 detects the network and the server's IP address, it is still assigned a strange IP address and ultimately fails to connect to the server. Aren't there any Slim people who can chime in on this?

Cheers!

Oli

snarlydwarf
2006-03-19, 13:43
Don't use all-numeric passkeys.

(There is a technical reason: passkeys can be expressed as either a string of characters that is hashed to make a key... or it can be expressed as numeric: in english, I guess, the best comparison is that 'twelve' is not the same as as '12' to a computer. The SB interprets '12345678' as a number. Your router most likely treats it as a string.)

Try all-letters.

oli
2006-03-19, 13:56
Nope. Just tried 'abcdefgh' and still no joy.

Cheers

Oli