PDA

View Full Version : Internet Radio problems



NWP
2006-03-15, 23:50
I am using the 3/15/2006 build of slimserver and I can't connect to Shoutcast nor Live365. When I got to Shoutcast, I get the following error:


There was an error parsing the stream information. Try reducing the number of streams if you've set a great number. (2)

I've tried reducing the number of streams in the setting to as low as 1, but I continue to get the same error.

__________

For Live365, I can't log in. When I click on the Live365 link, I get a message that simply states "Login problem". I can use the same username/password to connect to Live365 through a web browser and I never had trouble connecting with 6.2.

Are these known bugs or is it just me?

mherger
2006-03-16, 00:38
> I am using the 3/15/2006 build of slimserver and I can't connect to
> Shoutcast nor Live365. When I got to Shoutcast, I get the following
> error:

Hmm... we're getting more and more of these reports :-(.

Are you using the Windows version of SlimServer? Do you have perl
installed on your computer? If you installed the previous 6.2.x version
again, does it work?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

andyg
2006-03-16, 08:22
NWP wrote:
> For Live365, I can't log in. When I click on the Live365 link, I get a
> message that simply states "Login problem". I can use the same
> username/password to connect to Live365 through a web browser and I
> never had trouble connecting with 6.2.

Can you try resetting your Live365 password in the web interface? If it still
fails, enable the debug flag d_plugins to get some more information.

NWP
2006-03-18, 11:01
Hmm... we're getting more and more of these reports :-(.

Are you using the Windows version of SlimServer? Do you have perl
installed on your computer? If you installed the previous 6.2.x version
again, does it work?


I removed 6.5b1 (was using the build from 3/15) and installed 6.2.1 and both Shoutcast and Live365 worked fine.

I am using Windows 2000 sp4. I don't have perl installed on my computer as far as I know unless it came with the Slimserver install. Am I supposed to install Pearl to run 6.5b1?



Can you try resetting your Live365 password in the web interface? If it still
fails, enable the debug flag d_plugins to get some more information.

I tried resetting my password multiple times in the slimserver interface but it did not help. I also went to the Live365 website and changed my password but the new password didn't work either. I did notice something that may be strange: My old password was four characters in length, but when I would go into the internet radio settings, there were more than 4 asterisks in the password box. I think there were 8. I realize that many programs change the length of the asterisk field hiding the password, but I didn't think Internet Explorer did this.

I also tried enabling the debug flag d_plugins, but I saw no difference in the output in either shoutcast or Live365. Should I have seen additional debug info in the slimserver web interface, or am I supposed to look for it in a log file somewhere?

Thanks for the help on this. I just convinced my brother to buy two Squeezeboxes and the Nokia 770, and I want to make sure I can get him set up with both internet radio and the 770 skin.

NWP
2006-03-18, 11:16
Just to update this:

I uninstalled 6.2.1 again, but this time I also deleted the Slimserver directory in "Program Files" and deleted all playlists and favorites stored in my "My Music" folder.

I installed the 3/18 nightly build and get the same exact problems on both Shoutcast and Live365. Shoutcast gives this error: "There was an error parsing the stream information. Try reducing the number of streams if you've set a great number. (2)". Live365 can't log in.

Again, I don't know if it means anything, but my new Live365 password is 6 characters in length, but when I go to the Live365 settings screen there are 9 asterisks in the password field.

Not that it matters, but I am more concerned with getting Shoutcast to work than Live365. Once Slimserver turned me on to Shoutcast I pretty much stopped using Live365.

edit: I also enabled the d_plugins flag and see no difference in the output. Also, radioio is working fine.

edit2: wow, this radioio doesn't even have a reggae station? that makes them pretty useless to me!

mherger
2006-03-19, 05:12
> I installed the 3/18 nightly build and get the same exact problems on
> both Shoutcast and Live365. Shoutcast gives this error: "There was an
> error parsing the stream information. Try reducing the number of
> streams if you've set a great number. (2)".

I really don't understand. I just checked the changes in the 6.2.2 branch:
there have only been very few of them (mostly added translations), and
surely _none_ that touches that part of the plugin. You could replace the
current version of the plugin with the one of the 6.2.2 nightlies:

http://tinyurl.com/ms3nc

Does this fix your problem?

I opened a bug:

http://bugs.slimdevices.com/show_bug.cgi?id=3183

Please add any information about your system to that report (including
Windows version, language settings etc.)

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

NWP
2006-03-19, 10:20
I replaced the Plugin with the one you linked and it fixed the problem.

I updated the bug report with my system info.

mherger
2006-03-19, 11:07
I replaced the Plugin with the one you linked and it fixed the problem.

Just to be sure... Could you please swap back and forth between these two version and always reproduce the bahaviour even with only eg. 300 streams?

If yes, could you please give this version a try?

Thanks!

NWP
2006-03-19, 12:11
That attachment doesn't seem to be downloading correctly for me. I will remove and reinstall Slimserver so I have the old version of plugin.pm, then I will switch them back and forth to see what happens.

edit: I was able to download the last plugin.pm you posted, it just saved as an .htm and I had to change the extension.

When I switch back and forth between the plugins, stopping and starting slimserver between switches, I get the following results:

first plugin you posted (42,778 bytes): works
second plugin you posted (42,994 bytes): works
plugin from 6.5b1 build 2006-3-15 (47,074 bytes): does not work.

btw: I set my streams to 100.

NWP
2006-03-19, 12:35
I think I didn't understand AndyG's instructions on enabling the the d_plugin flag before. I enabled it from the web interface. I saw in the other thread where you told someone to run slim from the command line with the flag, so I tried that.

This is what I get. Hope it helps:



2006-03-19 14:31:47.7519 Shoutcast: next update Mon Mar 20 14:31:47 2006
2006-03-19 14:31:47.7547 Shoutcast: async request
2006-03-19 14:31:51.0854 Shoutcast: get XML content
2006-03-19 14:31:51.0863 Shoutcast: parse XML
2006-03-19 14:31:51.0987 Shoutcast: problem reading XML:
not well-formed (invalid token) at line 1, column 6, byte 6 at /PerlApp/XML/Parser.pm line 187
2006-03-19 14:31:51.1203 Shoutcast: create page
2006-03-19 14:31:51.2003 Shoutcast: that's it

andyg
2006-03-19, 12:44
On Mar 19, 2006, at 2:35 PM, NWP wrote:

>
> I think I didn't understand AndyG's instructions on enabling the the
> d_plugin flag before. I enabled it from the web interface. I saw in
> the other thread where you told someone to run slim from the command
> line with the flag, so I tried that.
>
> This is what I get. Hope it helps:
>
>>
>> 2006-03-19 14:31:47.7519 Shoutcast: next update Mon Mar 20 14:31:47
>> 2006
>> 2006-03-19 14:31:47.7547 Shoutcast: async request
>> 2006-03-19 14:31:51.0854 Shoutcast: get XML content
>> 2006-03-19 14:31:51.0863 Shoutcast: parse XML
>> 2006-03-19 14:31:51.0987 Shoutcast: problem reading XML:
>> not well-formed (invalid token) at line 1, column 6, byte 6 at
>> /PerlApp/XML/Parser.pm line 187
>> 2006-03-19 14:31:51.1203 Shoutcast: create page
>> 2006-03-19 14:31:51.2003 Shoutcast: that's it
>>

Unfortunately if things like Shoutcast spit out bad XML there isn't
much we can do. However, Shoutcast is working fine for me today, so
maybe they've fixed the problem.

mherger
2006-03-19, 13:01
> Unfortunately if things like Shoutcast spit out bad XML there isn't much
> we can do. However, Shoutcast is working fine for me today, so maybe
> they've fixed the problem.

I did have the problem mentioned today with the number of streams set to
2000. Reducing to 200 fixed it.

BUT there have been repeated reports of cases where even 10 stations
wouldn't work. Where replacing the 6.2.2 version with a 6.2.1 would fix
it. I can't understand at all, though, as the changes are really minor.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

mherger
2006-03-19, 13:02
> This is what I get. Hope it helps:

It's the usual suspects... BTW: what language setting are you using (OS
and Slimserver)?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

NWP
2006-03-19, 13:06
Unfortunately if things like Shoutcast spit out bad XML there isn't
much we can do. However, Shoutcast is working fine for me today, so
maybe they've fixed the problem.

I agree the problem could very well be on their end, but I find it odd that the 6.2 plugins work but the 6.5b1 plugin does not.

I guess it is also odd that this bug seems to only be showing up on my system.

NWP
2006-03-19, 13:08
It's the usual suspects... BTW: what language setting are you using (OS
and Slimserver)?


I'm using English on Slimserver and Windows is set to English (United States).

NWP
2006-03-28, 20:29
just a further note:

I convinced my brother to buy two squeezeboxes and a Nokia 770 (he's friggin loving it so far) and he is having the same exact problem with Shoutcast. I am going to email him the plugin.pm from 6.2.

He is also using Windows 2000 pro.

mherger
2006-03-28, 21:52
> I convinced my brother to buy two squeezeboxes and a Nokia 770 (he's
> friggin loving it so far) and he is having the same exact problem with
> Shoutcast. I am going to email him the plugin.pm from 6.2.

Could you please do the test I mentioned, swapping between the two
versions within a few minutes only? Just to be sure it's really the plugin
version... Thanks!

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

Pat40
2006-03-28, 23:36
Hello, I have exactly the same problem with SlimServer 6.5b1 (every nightly build). With SHOUTcast Internet Radio, I get the following error: "There was an error parsing the stream information. Try reducing the number of streams if you've set a great number. (2)". With Slim Device Picks, Live Music Archive and Podcast Broswer I get the following error: "Failed to parse <http://.......>".
When I replace the ShoucastBrowser plugin with the 6.2.1 version of plugin.pm, SHOUTcast Internet Radio is back and there is no more error. If I switch again with 6.5b1 of plugin.pm, error message come back.
I have tried the same method for plugin.pm in Picks folder with the same result. With the 6.2.1 version of plugin.pm, I can connect to Slim Device Picks, with 6.5b1 version I get the Failed to parse error. Because there is no LMA folder with 6.2.1 version, I can't try this solution for Live Music Archive. At last, with Podcast folder my method doesn't work and if I replace the 6.5b1 plugin.pm with the 6.2.1, I must switch off my Squeezebox after trying to connect to Broadcast.

Sorry for my english, but I'm a french user.

NWP
2006-03-29, 01:41
> I convinced my brother to buy two squeezeboxes and a Nokia 770 (he's
> friggin loving it so far) and he is having the same exact problem with
> Shoutcast. I am going to email him the plugin.pm from 6.2.

Could you please do the test I mentioned, swapping between the two
versions within a few minutes only? Just to be sure it's really the plugin
version... Thanks!

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

I did do that.

I shut down slimserver between switching the plugins. Do you want me to leave it running?

mherger
2006-03-30, 09:08
Ok, here's another try at fixing the Shoutcast issue. It will only work with 6.5 (as I understood the problem only occurs in 6.5, right?).

Please replace the existing Shoutcast/Plugin.pm with this one, restart Slimserver, and give it another go.

Regards,

Pat40
2006-03-30, 19:43
Ok, here's another try at fixing the Shoutcast issue. It will only work with 6.5 (as I understood the problem only occurs in 6.5, right?)

Hello, your plugin.pm is working well with 6.5. In fact, when I replace 6.5 plugin.pm in ShoutcastBrowser and Picks folders by 6.2.1 plugin.pm, all is fine and I can listen Shoucast Radios and Slim Devices Picks with SlimServer 6.5. Unfortunately, I have not found LMA folder in 6.2.1 version and I can't replace plugin.pm for Live Music Archives.

Regards

Pat40
2006-03-30, 20:23
Sorry for disturbing you but I just realized that these errors are referenced as bug 2930 and so are investigated. Good luck.

mherger
2006-03-30, 21:31
> Sorry for disturbing you but I just realized that these errors are
> referenced as bug 2930 and so are investigated. Good luck.

Thanks for that hint! I marked bug 3183 as duplicate.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

mherger
2006-03-30, 21:35
> Hello, your plugin.pm is working well with 6.5.

Excellent! This should bring us closer to solving the problem. I still
don't understand why this happens to some of you, but not to most others.
But at least we have an idea where to have a look.

> 6.5 plugin.pm in ShoutcastBrowser and Picks folders by 6.2.1 plugin.pm,
> all is fine and I can listen Shoucast Radios and Slim Devices Picks
> with SlimServer 6.5. Unfortunately, I have not found LMA folder in
> 6.2.1 version and I can't replace plugin.pm for Live Music Archives.

Try downloading them from
http://svn.slimdevices.com/trunk/server/?rev=5696 - if my theory is
correct, this should work. Please confirm. Thanks!

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

Dan Sully
2006-03-30, 23:04
* mherger shaped the electrons to say...

>Ok, here's another try at fixing the Shoutcast issue. It will only work
>with 6.5 (as I understood the problem only occurs in 6.5, right?).

I'm guessing that it's only happening on 6.5 on Windows, right?

I just made a change to our build machine that should hopefully fix this.

-D
--
<iNoah> you know, most free operating systems come preinstalled with their own high horse.

NWP
2006-03-31, 02:56
Ok, here's another try at fixing the Shoutcast issue. It will only work with 6.5 (as I understood the problem only occurs in 6.5, right?).

Please replace the existing Shoutcast/Plugin.pm with this one, restart Slimserver, and give it another go.

Regards,

Yes, the problem only happened in 6.5 and this version of the plugin does work!

Thanks!

mherger
2006-03-31, 03:21
> Yes, the problem only happened in 6.5 and this version of the plugin
> does work!

Dan has made a change which should fix the issue in the latest nightly
build. Could you please give it a try?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

mherger
2006-03-31, 11:30
> I just made a change to our build machine that should hopefully fix this.

Got a first thumbs up in the german forum. This seems to have fixed it.
What was causing the problem?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

Dan Sully
2006-03-31, 11:39
* Michael Herger shaped the electrons to say...

>>I just made a change to our build machine that should hopefully fix this.
>
>Got a first thumbs up in the german forum. This seems to have fixed it.
>What was causing the problem?

I made a change to XML::Simple to accept the scalar ref, and had moved that
change into trunk/server/lib/XML/Simple.pm - there was a copy of
XML/Simple.pm in the Perl directory on our Windows build machine that was
different, so ActiveState was picking that one up.

I've submitted my changes back to the author, but no response. :(

-D
--
<faisal> my life is collapsing to what will soon be NEGATIVE INTEGER degrees of separation.

Pat40
2006-03-31, 23:49
Wonderful. The last nighlty build fixes all the problems for Shoutcast radios, Slimdevices Picks, Live Music Archive and Podcasts. Many thanks to this community for your hard work. SqueezeBox is really an amazing device and thanks to you, this little box is more marvellous. Many thanks Michael and Dan !

Regards,
Patrick

smc2911
2006-05-18, 23:48
Don't know if it's related to the same problem, but running 6.5b on linux (deb package), I have problems accessing Slim Device Picks and ShoutCAST (LMA is fine). I don't know how long this has been a problem as I haven't tried in ages. With d_plugins set I get the following error:


Can't call method "header" on unblessed reference at /usr/share/perl5/Slim/Networking/SimpleAsyncHTTP.pm line 188.


On the web-server (using firefox) I see the following:


ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: http://pan:9000/plugins/Picks/index.html?

The following error was encountered:

* Connection Failed

The system returned:

(111) Connection refused

The remote host or network may be down. Please try the request again.

In either case, anything playing on the SB stops and the screen goes blank temporarily.

Sean.

andyg
2006-05-19, 04:57
On May 19, 2006, at 2:48 AM, smc2911 wrote:

>
> Don't know if it's related to the same problem, but running 6.5b on
> linux (deb package), I have problems accessing Slim Device Picks and
> ShoutCAST (LMA is fine). I don't know how long this has been a problem
> as I haven't tried in ages. With d_plugins set I get the following
> error:
>
>
> Can't call method "header" on unblessed reference at
> /usr/share/perl5/Slim/Networking/SimpleAsyncHTTP.pm line 188.

You need to delete your FileCache directory, that will solve the
problem.

smc2911
2006-05-19, 05:24
Success! Thanks very much.