PDA

View Full Version : New user problem: Slimserver on Linkstation



fishyrich
2006-03-13, 17:54
[Edit] Apologies for the duplicate post - I got an error message first time and didn't think it had gone. :-|

Hi,

I am setting up slimserver v6.2.1 on my Linkstation 250 MIPS, and I am getting a bit stuck.

I have been following the excellent instructions on http://fieldnetworks.com/slim/linkstation.html but am still having some difficulty.

So far I have replaced the firmware with the Openlink version from http://linkstationwiki.org/Projects/OpenLink

This enabled me to telnet into the linkstation and gain root access (BTW when I telnet to the linkstation I am immediately root, without having entered a password - how can I re-enable password access for root telnet?!)

I didn't at first change Perl, as my linkstation came with Perl 5.8.7.

I unpacked the tar ball of slimserver 6.2.1 into /mnt/hda/slimserver, and tried to run it using the command ./slimserver.pl --daemon --prefsfile /mnt/hda/slimserver/etc/slimserver.pref --cachedir /mnt/hda/slimserver/etc
but got this error message:

The following modules failed to load: DBD::SQLite XML::Parser HTML::Parser Compress::Zlib
To download and compile them, please run: /SlimServer_v6.0.2/Bin/build-perl-modules.pl

I poked around on this slimdevices forum and the http://groups.yahoo.com/group/LinkStation_General/ forum and found one message suggesting that slimserver 6.2.1 was incompatible with Perl 5.8.7. I was pointed to http://fieldnetworks.com/ to download Perl 5.8.5. I intalled this, replacing the softlink from /usr/bin/perl to /usr/local/bin/perl5.8.5. However now I get a different error message!
./slimserver.pl: require: command not found
./slimserver.pl: use: command not found
./slimserver.pl: use: command not found
./slimserver.pl: package: command not found
./slimserver.pl: line 25: syntax error near une
./slimserver.pl: line 25: `our %Config = ('

Following further searches, I gather that this error might be because the version of perl I downloaded is for the PPC Linkstation rather than the MIPS Linkstation. I was directed back to http://linkstationwiki.org/Articles/MIPSelSlimServer which recognises the first problem I had, and suggests how to install the missing perl modules.

This is as far as I have got.... unfortunately I don't understand the instructions on http://linkstationwiki.org/Articles/MIPSelSlimServer !!

I would be grateful for some simple instructions, or a specific download that I need!

Many thanks

mherger
2006-03-14, 00:19
> http://linkstationwiki.org/Articles/MIPSelSlimServer which recognises
> the first problem I had, and suggests how to install the missing perl
> modules.

Do this. In fact, that's what the error message says. I wouldn't bother
installing a new perl version before having installed these modules.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

fishyrich
2006-03-14, 15:18
The Linkstationwiki site says that to install the modules I will need also to install the development tools. I have got both (modules and dev tools) but the README of the dev tools tells me that it will need 100MB to install, yet this will take up half my free disk space in rootfs!

Is this a good use of my limited partition space in rootfs? Or should I just pick out the dev tools that I will need (and which ones?!)

thanks again