PDA

View Full Version : I know I've asked this before, but.... (!)



DrNic
2006-03-07, 07:15
Hi all
A while back I commented that on my system (currently running SS 6.2.2 - 5448 - Windows XP - EN - cp1252, with a "SB3") if an album was a "compilation" album then the server would not list the tracks in track order. I thought this might have been an iTunes/mp3 issue so have held off whilst I converted over to FLAC, but it still persists.
To clarify via the web browser (Firefox 1.0.7) - in the left hand pane, viewing a compilation album (FLAC) the tracks are not in number order but seem to be ordered by the performing artist alphabetically. However, if the album is selected to play as a whole then the tracks appear correctly in the player pane on the right hand side. Also the SB3 itself lists the tracks in correct order, even when browsing the album itself (like viewing the left pane on the browser).
Is there a way to correct this behaviour?

Thanks
Nic

ceejay
2006-03-07, 08:03
When you are "browsing", is that by Music Folder or by one of the other routes? (the mechanism and behaviour is quite different...)

Have you verified (using MP3tag or similar) that the tracks in question do have a tracknumber tag in them?

Ceejay

DrNic
2006-03-07, 08:21
When you are "browsing", is that by Music Folder or by one of the other routes? (the mechanism and behaviour is quite different...)

Have you verified (using MP3tag or similar) that the tracks in question do have a tracknumber tag in them?

Ceejay

Browsing is by "Browse Albums" - this produces the problem

Browsing by "music folder" lists the tracks in the correct order as they are named with the track number first then name (01 blah, 02 blah blah etc)

Tags are all perfect (ahem!) in such that all tracknumbers are present and correct with no other sorting tags specified,, or partinsets etc..

thanks

Nic

DrNic
2006-03-09, 08:05
*BUMP* !

Is there any explaination for this track ordering behaviour??

Please, pretty please?

Nic

ceejay
2006-03-09, 10:19
Sorry, I'm stumped. I'm on a similar (slightly later perhaps) build... SlimServer Version: 6.2.2 - 5549 - Windows XP - EN - cp1252 ... and I can't reproduce your problem. I go Browse Albums -> A Compilation Album -> track listing in the browser, they come up in the right order.

Can I suggest having a REALLY good look at your tags? Use Mp3tag to check to see if you have ID3 tags as well as Vorbis comments, perhaps? I think that can confuse slimserver...

If that doesn't show something up, have a look in the database itself (eg with the SQLite browser), and/or turn debug on while you completely rescan your library (you might want to set up a test library with just a handful of albums in - make sure you have some "normal" as well as compilations in there or you'll trigger another error).

HTH

Ceejay

DrNic
2006-03-10, 04:11
Thanks Ceejay for mulling this one over for me!
This has got me stumped too.
What really bakes my cookie is the fact that on the physical SB3 the order is fine, no matter what method of browsing is used!!!
I'm confused... :(
I have gone over the files with a fine toothed comb and can say that there are only VOrbis comments (no ID3 at all) on the FLAC files, obviously on the few remaining MP3 there are ID3 tags but these can't be interfering with SS interpretation of the FLAC files, surely?!

Next I suppose I need to look at the database, not sure what I am supposed to look for though...!
Thanks again for the help!

NIc

DrNic
2006-03-10, 04:30
OK then
I have downloaded the SQLite browser (nice bit of software BTW) and have found the slimserver.db file.
Thing is, what should I be looking at?

Any help would be greatly appreciated!

Nic

DrNic
2006-03-10, 13:54
OK, sorry for keep "replying" to my own thread!
I searched the forums and found KDF's original instructions for browsing the SQLite db, when I first voiced this problem back in december...
He suggested looking at the MULTIALBUMSORTKEY value for the tracks.
Now using my laptop with a smaller music library, still using the old MP3's from iTUNES import, I note that the order is correct in all views (Browse Albums, Browse Music Folder, and Browse Artists-Various Artists) for the compilation albums.
Looking at this db value (multialbumsortkey) I see that it is formed like this:

THRILLSEEKERS CHILLOUT SESSION 03 WINTER COLLECTION DISC 2 01 LOVE STORY

This is for the first track (hence 01 and track name)
Now for the subsequent tracks only the last part changes ie 02 POOR LENO instead of 01 LOVE STORY.

This differs from my main library and server setup, which continues to display the track order alphabetically!

For the same album it is this:

THRILLSEEKERS CHILLOUT SESSION 03 WINTER COLLECTION DISC 2 01 LOVE STORY

ROYKSOPP CHILLOUT SESSION 03 WINTER COLLECTION DISC 2 02 POOR LENO

etc

I note that the artist name preceding the album name is changing with each track.
Could this be the reason that the list is being ordered by artist instead of track number?
If so then why is the last tracks artist (you'll have to trust me that the last track on disc 2 of The Chillout session 03 - winter collection is by Thrillseekers!) been used for all the track entries in the "working" version - is this a critical entry to make the order by track number?

Am I on the right track? What server option would need to be changed to get my desired behaviour, or do I have to edit the db by hand every time i rescan? (ouch!)
Could someone please offer an opinion for me.
I hope this post explains the situation well enough... :)

Nic