PDA

View Full Version : SlimServer won't open in Firefox



JeffCharles
2006-03-05, 08:35
Firefox is my default browser on my WinXP desktop. When I try to open SlimServer from the tooltray or by double clicking its web shortcut, I get the message "This file does not have a program associated with it..." If I then Reset Web Settings in IE (setting IE as the default browser), SlimServer opens in IE. If I then reset FireFox as default, the error recurs.

SlimServer does open without a problem from the FireFox address bar.

Slim Devices support has been very responsive in trying to resolve this problem, so far without success. I thought I would post here in case someone has run into it before.

Jeff

tyler_durden
2006-03-05, 09:32
If you change the default browser to firefox you can no longer use the "automatic update" "feature" in Windoze.

You don't suppose M$ has any reason for making it difficult to use a competitor's browser...

I_F

radish
2006-03-05, 15:39
If you change the default browser to firefox you can no longer use the "automatic update" "feature" in Windoze.

You don't suppose M$ has any reason for making it difficult to use a competitor's browser...

I_F

Works fine for me. Firefox is default, Windows Update opens IE.

As for the original problem, it's not clear what would cause that. A lot of people here use Firefox and it should work (the icon just uses a Windows API call to open the default browser). Can't really offer much except good luck!

ceejay
2006-03-05, 16:36
works for me too.

May not be exactly the same problem, but have a look at http://forums.slimdevices.com/showthread.php?t=16799 to see if this helps

Ceejay

JeffCharles
2006-03-05, 16:56
I posted a request for help at in the Firefox support forum and was directed to the following page: http://kb.mozillazine.org/Default_browser#Force_Firefox_to_make_itself_the_d efault.

The option I used was the software listed as number [2] in the middle of the page. It's called DefaultBrowser. Apparently, just setting Firefox as the default browser in Firefox itself did not do the whole job. After using DefaultBrowser to set Firefox as the default, SlimServer now opens OK.

Thanks for your replies.

Jeff

nelamvr6
2006-03-05, 17:21
You can also open SlimServer by typing "http://localhost:9000/" in any browser address bar, Firefox, IE, Netscape, whatever.

You can also make a bookmark in Firefox so you don't have to click the systray icon.