PDA

View Full Version : Help - Slimserver CPU Hog



oldmanmusic
2006-03-03, 03:01
I have used SqueezeBox with Slimserver for quite a while now but have recently started experiencing problems. Nearly every time the server starts up, it uses round about 98% of CPU resources (according to Activity Monitor). If I try to launch web access the browser hangs while trying to load. This also causes the Squeezebox to loose connection with the server.

I am using version 6.2.1 of Slimserver. My music library has 7048 tracks. I use iTunes. My system specs are:

Mac G5 Dual 2 GHz
2 GB RAM
System 10.4.5

All apps, etc are located on the main hard drive. I also use MusicMagic Mixer which is linked to Slimserver (although even if I stop MMM I still have the same problem).

Any help would be gratefully appreciated. This is driving me nuts!


Thanks

Craig, James (IT)
2006-03-03, 03:10
Probably the iTunes library scan.
You can configure the interval at which this occurs or disable it in
favour of a scheduled rescan, with the iTunes Rescan Interval setting.
Try setting this to 0 (disabled) and restarting SlimServer to see if
that's the problem.

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

govardha
2006-03-13, 07:27
Oldmanmusic,

Did James's suggestion fix the problem for you?

Gov

gbreit
2006-03-13, 10:53
We had a discussion about this in the past week or so. You need to be careful when you are doing library management with iTunes. Check out this thread:

http://forums.slimdevices.com/showthread.php?t=21723

gb

dean
2006-03-13, 12:09
The latest nightly release for 6.2.2 has some fixes for iTunes
importing that should improve the overall performance of SlimServer
when importing iTunes information and also fix a few other bugs.