View Full Version : Help! My new SB3 can't connect to SlimServer

2006-02-28, 08:15
I am having a problem setting up my new SB3! I have connected it all up, but at the end of the "Network Setup" process I cannot get it to connect to my SlimServer. It connects to the Wireless network fine (and gets itself an IP via DHCP), but then it insists I give it an IP address for the SlimServer, and whatever I try to connect to (have tried - the IP address of my PC, also tried (default gateway) and (is this the SlimServer local IP?) I keep getting the error "can't connect to SlimServer" on the SB3.

I know my SlimServer is running OK (SoftSqueeze is working fine on a laptop I have).

I have tried turning WEP encryption off on my WLAN (am fairly sure I have proved that is not the issue - the SB3 connects to the WLAN and gets itself an IP address with WEP on or off).

Have also now tried turning my firewall (an Nvidia motherboard (A8N-SLI Premium) firewall) off (Windows XP firewall is also off) and still it does not work, so think I have eliminated firewall problems from the equation.

I have noticed that when checking "Current Settings" on the Squeezebox, the Subnet Mask is shown as instead of, and I can't find a way to correct this. Also, the "Gateway" and "DNS server" addresses in the "current settings" on the SB3 are which doesn't seem right, but again there doesn't seem to be any way to change these.

Also I am a little confused as to why I have to tell the SB3 what IP address to connect to the SlimServer on in the first place - according to the instructions I have read, there should be an option to do this automatically. Anyone know how to get the SB3 to automatically detect the SlimServer?

Am tearing my hair out now - anyone got any ideas on what is wrong here - I want to play with my new toy!!!

Failing any help, does anyone know if there is a customer services telephone number for Slim in the UK?

Massive thanks in advance to anyone who can help!!!


2006-02-28, 08:21
I gather that if you make a very short call to SlimDevices in the USA to give them your phone number they will then phone you back.

2006-02-28, 08:35
Thanks - do you have a number or should I just use the nymber in the contact section of this website?

Interestingly I have just tried to ping the SB3 and it did not work. I am now wondering if it has connected to the right WLAN or not... very confused!

Robin Bowes
2006-02-28, 08:48
mwoodroof wrote:

> Failing any help, does anyone know if there is a customer services
> telephone number for Slim in the UK?

Hey Dean - look, someone's looking for a support number in the UK. ;)


2006-02-28, 08:49
OK, so I have just moved the SB3 upstairs, right next to my Belkin router. Been through the setup again, same results. The SB3 says it has connected to the WLAN (encryption still off) and gets itself an IP address. "Current Settings" menu on the SB3 says I have a 100% signal strength, but I still have for the subnet address and for the gateway and dns addresses in this menu.

When I try to ping that IP address at the cmd prompt it does not work. Can anyone tell me if it should be ping-able?!

Any ideas gratefully received!!

2006-02-28, 08:55
Have you tried connecting via a wired connection? I had similar problems where the SB3 was mis-interpreting the DHCP response and getting a dodgy IP address. If wired works, try upgrading the firmware on the SB3. I also had to open the ports on the firewall, but you seem to have done that.

WLAN works a treat once it is up and running...


Patrick Dixon
2006-02-28, 09:01
It sounds like you are not getting a proper connection to the wireless network or a proper DHCP address.

Beware, it can fail the wireless security checks and still get to the looking for slimserver bit - so don't be fooled.

Check that the DCHP address the SB3 is being allocated is within your DHCP address range.

Try to connect with no wireless security on (again), and check you are not blocking the SB3 MAC address in your wireless setup.

2006-02-28, 09:16
Thanks for the suggestions guys, and quick responses too. This product would definitely be stuffed without such an active and helpful user community - you should all get paid for helping Slim customers!!!

Think you were on the right track - the good news is that I have just managed to get it up and running. The solution (at the moment) was to assign the SB3 a static IP. I used (the SoftSqueeze on my laptop which was working was showing in the SlimServer as

After doing this, I was able to ping the SB3 from the command prompt. And lo and behold, this has made it work. It even picked up the SlimServer on my desktop PC automatically.

The IP addresses that the SB3 was previously picking up automatically before all started 169.254. I guess these are out of my DHCP pool range (is that right? how do I check my DHCP pool range?). Any idea why this would be?

First thing the SB did was to upgrade firmware. Maybe I can try going back to dyanamic IP and it will work now?

Am still quite confused and would like to understand all this properly!!!

Oh, and apologies for the multiple posting very quickly, but as you can imagine have been very keen to get my new toy working ;-)

2006-02-28, 09:32
Just tried to re-setup the network settings on the SB3 after my firmware upgrade, and it is still not working - still getting a seemingly dodgy IP address (starting 169.254) from DHCP, and then not seeing the SlimServer. Why is this?

Gone back through and set a static IP manually (and when I do this I can set the subnet, gateway and dns addresses correctly) and it works again - as soon as I do this the SB3 says "looking for SlimServers" and finds the one on my desktop PC straight away.

As I said, would be nice to know why this is, although as it works with a static IP I suppose I can just leave it like that... any of you helpful peeps out there got any thoughts on this though?

Now to try turning on my WEP encryption and firewall and hope it still works after that!

Have loved flicking through my MP3s on my hi-fi though - it really is an awesome product when working!!!

2006-02-28, 09:57
If it's any consolation, I've found the same thing with my Netgear router. Getting an IP address for the SB via DHCP seems to be hit-or-miss, and mostly miss. But a static IP works fine, and doesn't have any drawbacks for me, and probably won't for you, either.

2006-02-28, 10:58
Just tried to re-setup the network settings on the SB3 after my firmware upgrade, and it is still not working - still getting a seemingly dodgy IP address (starting 169.254) from DHCP, and then not seeing the SlimServer. Why is this?

There are LOADs of threads on this, mostly in the beginners forum, this is quite common issue ... the 169.254 address isn't dodgy as such, its just what devices allocate themselves when they can't find a DHCP server. From that point on you are doomed!

If assigning a manual IP address works, I'd say that was a result and leave it alone (others have had to do the same). Wireless is still a bit of a black art, it seems.


2006-02-28, 11:51
Not sure which Belkin router you are using, but I had exactly the same issue with a Belkin pre-N v2 router. The DHCP seems a little flaky to say the least, although I actually prefer to use static IPs if at all possible. Since then it's been working flawlessly for me.

If you could add your experiences in the Wiki, it would be helpful for others:


2006-02-28, 13:29
Have added a comment to the Wiki, same as yours (that was why I tried static ip, so thanks a lot!), with my router model - a Belkin F5D6230-3.

Hope it worked OK, found editing the Wiki a little sketchy (when it went into edit mode I couldn't see all the text I was editing!!?)

Many thanks.

2006-02-28, 13:54
Wiki looks fine to me, glad it helped !

To answer your earlier question, upgrading the firmware (28, 29 and now 33) hasn't enabled me to go back to dynamic DCHP with the Belkin pre-N v2 (I've tested more out of curiosity than actual wish to change my current set up).

Whilst my XP laptop connects fine to the Belkin router using dynamic DCHP, my Axim Pocket PC needs to have a static address too, so my impression is that it's the router rather than the interaction of the SB and the router alone.