PDA

View Full Version : Tags Problem - Duplicate Albums



mwoodroof
2006-02-25, 11:22
I am having a problem with tags - I have an album which SlimServer is picking up twice - once correctly and then a second time with the same name but only containing track 7.

Having checked these forums for possible solutions I have now checked all the files in this album folder with "ID3-TagIT" and "Mp3tag" software, and there is the tags on all the tracks look OK - the album tag is identical on all of them, and all the track specific tags are in the same format.

Naturally I have made SlimServer rescan my music folder after I have corrected the tags.

Does anyone have any idea what the problem might be?

Is there anyway I can force SlimServer to "forget" the duplicate album containing only one track - as I said, the other album is fine, containing all the tracks, correct order etc.

Thanks in advance for any help anyone can offer!

Siduhe
2006-02-25, 11:46
I am having a problem with tags - I have an album which SlimServer is picking up twice - once correctly and then a second time with the same name but only containing track 7.

Having checked these forums for possible solutions I have now checked all the files in this album folder with "ID3-TagIT" and "Mp3tag" software, and there is the tags on all the tracks look OK - the album tag is identical on all of them, and all the track specific tags are in the same format.

Naturally I have made SlimServer rescan my music folder after I have corrected the tags.

Does anyone have any idea what the problem might be?

Is there anyway I can force SlimServer to "forget" the duplicate album containing only one track - as I said, the other album is fine, containing all the tracks, correct order etc.

Thanks in advance for any help anyone can offer!

I've had this problem a couple of times. It sounds like a tag problem. Even if the Album tag looks the same, it sometimes needs forcing for Slimserver to see it as one. Have you tried selecting all the songs in the album in your tagger and forcing the same Album tag on all of them, then doing a full clear library and rescan (not just a find new music scan)? Let us know if that does the trick.

mwoodroof
2006-02-25, 11:57
Thanks very much for the quick help!!

Read your suggestion and thought I would just try the "library clear and rescan" option first - didn't know you could do this - and it has done the trick without forcing the album names all the same!

Bit strange - surely the normal "new and changed" scan should have picked up on these changed tags - in fact it usually does on other tag changes I have made.

Oh well, thanks again for the advice, all is right in the SlimServer world again!

Siduhe
2006-02-25, 12:00
Glad to hear it - I know what you mean about "new and changed" - in my experience it only finds "new" music. You usually need to do a full rescan for "changed" music.

mwoodroof
2006-02-26, 09:29
OK, so I have been thinking about this and surely there must be a way to force SlimServer to "properly" rescan one artist/album to pick up changes? Anyone know any more about this?

If there is not, does anyone know if this functionality has been suggested to those marvellous folk at Slim Devices for a future update of the software - it really would be a lot better than always haveing to do a full library rescan...

Bonesteel
2006-03-02, 05:37
I've had this happen when I import a CD in iTunes (tags set by Gracenote), then subsequently selecting all the tracks and adding the album artwork. In 6.2.2 I tried a clear and full rescan, but the dupes remain. If I turn off "use iTunes" for the server, the problem disappears, but then I can not see artwork. Anyone seen this or have a solution?

Thanks

Update -

This seems to happen regardless of if I use iTunes or not. Any ideas?