PDA

View Full Version : How to configure Autodisplay



Bart
2006-02-25, 11:02
I have posted before, and made an enhancement request, to get the player to dim it's display at night and brighten it again in the morning. I have a Squeeebox in the bedroom, with some film over the display so that it is dim enough at night not to be distracting but still bright enough to show the time. However it is too dim to see in the morning, so I have to press Brightness several times every morning. I have downloaded the Autodisplay plugin but I cannot see how to make it work - I was hoping that if I got it to work then it would be possible to get it to dim the display instead of turning it off. I have put it in the correct place and it appears under "Plugins" for that player, but it never works. When I put in a time to turn on or off the display nothing happens.
Am I misunderstanding something? What are these different states (on, off, idle)?

tgoldstone
2006-02-26, 13:04
What version of Slim are you running? The plugin functions on version 6.x.x ok. I recommend 6.2.x as it is the latest stable branch. The plugin can take up to 60 seconds to trigger after the shutoff time has been reached, wait a while and see if the screen turns off. I know that this plugin works as it is working just fine for me.

rudholm
2006-02-27, 02:14
The plugin works fine for me as well. I'm runing slimserver 6.2.2 February 10 nightly release.

The plugin doesn't really "dim" the display, it turns it completely off, and this behavior is not controlable by the user. However, it's pretty easy to modify the plugin. The dim setting is done in line 271, it looks like this:

$client->brightness(0);

You can put any valid brightness level in place of that 0. I changed it to 1 (one level above off) and am happy with it.

Bart
2006-02-27, 02:51
I am running SlimServer Version 6.2.1 -5194-Windows XP-EN-cp1252
What happens is:
I set an "Off" time in Autodisplay
I set the plugin to "On"
The time passes but the display does not change (even after waiting a few minutes past the time)
The time on the web interface has reset itself to 00:00


You can put any valid brightness level in place of that 0. I changed it to 1 (one level above off) and am happy with it.
Glad to hear that this works - this is exactly what I want to do.

Krobb
2006-02-27, 05:50
... Nice. Made a wiki out of it:

http://wiki.slimdevices.com/index.cgi?AutoDisplay

tgoldstone
2006-02-27, 06:55
Are you entering the time in the web UI? One thing I have noticed is that if you don't enter the time perfectly HH:MM AM|PM then it doesn't work. Try entering the time using the remote and see if that works.

Bart
2006-02-27, 09:20
Are you entering the time in the web UI? One thing I have noticed is that if you don't enter the time perfectly HH:MM AM|PM then it doesn't work. Try entering the time using the remote and see if that works.
I entered it using the remote and now it works. Thanks for your help.
I have changed the time format to give me h:mm, by changing the line in SlimServer.pref file from
timeFormat = |%I:%M:%S %p
to timeFormat = |%I:%M
which might be why it was not working through the web interface?

rudholm
2006-02-27, 10:50
FWIW, I had the same problem. When I entered times via the web interface, I had difficulty getting the settings to take, but it always worked without problem when I entered them on the Squeezebox. I haven't made any changes to my server's time format (although I have configured it so that the Squeezebox displays 24-hour time when off).

tgoldstone
2006-02-27, 20:55
Well I guess I'll have to take a look at the time input function.