PDA

View Full Version : how can squeezebox turn on a pc



russj
2006-02-25, 09:52
This has stumped me for a while now. When i switch on my squeezebox and press the power button, the pc operating the slimserver switches on. It doesnt come out of standby, it switches on from complete power off. Question is how? How does a computer that is off receive a signal and know what to do with it, I cant understand it as surely the squeexebox would be sending a signal over wireless to my router to be directed to an ip address that was not contactable because the computer was off. Here's the strange part. It only does this if the computer has been totally denied power - switched off at the mains. If i shut down the machine, pressing the power button no longer wakes the server.

I'm sure its some sort of technology bt i cannot see how it can work. I could understand if it was waking up a machine that was in standby, but not one that wasnt even switched on.

I hope someone can shed some light on this strange behaviour.

nelamvr6
2006-02-25, 10:15
You must have "Wake On Lan" enabled.

Mark Lanctot
2006-02-25, 10:29
It's funny - most people fuss for days trying to get WOL working and here you have it working when you don't want it to.

You can disable WOL from your BIOS setup or from Settings - Control Panel - System - Harware - Device Manager - <your network adapter under the "Network adapters" category> - right-click - Properties - Advanced tab.

russj
2006-02-25, 10:38
Its a feature i want to keep, i was just interested in how it worked. Having looked at the network card config, wake on lan was actually disabled, but it still seems to work.

fairyliquidizer
2006-02-26, 09:16
strange. Did you check the setting in Windoze? (Manual explains where it is)

Michaelwagner
2006-02-26, 18:02
I can't explain why it works when it's turned off, some misunderstanding somewhere there, but let me tell you how WOL works and maybe some more will come clear.

When you turn a modern PC off by its own power switch (not with a power bar), you don't really turn it all off. Small bits of it stay on, and the power supply makes a trickle of power available for those small bits.

One of the small bits is (part of) the network card. If your computer is like mine, there's a LED on the network card and it will be lit.

There's enough intelligence staying on in the network card to recognize a so-called "magic packet" which says, more or less "Hey, you, wake up" and the address of the network card.

The network card has a cable to yank the main power supply and wake the PC all the way up.

The operating system, when rudely awoken this way, has to know what has happened, so it needs Wakeup-On-Lan (WOL) support (but most do these days).

Hope this helps.

strapats
2006-03-28, 11:19
my system seems to act very much like russj's. i never changed any settings, but still my sb3 is able to start up my pc. contrary to russj however, i'd really like to disable this function. strange thing is though, in my bios it says "Power On by Modem/LAN" -> Disabled. the settings for my LAN in XP are ok as well ('Allow this device to bring the computer out of standby' is unchecked). does anyone have an idea of how this might be possible?

Michaelwagner
2006-03-28, 18:14
does anyone have an idea of how this might be possible?
the only thing that comes to mind ... any chance you have 2 network cards in that PC and it's only turned off for the other one?

chris.mason
2006-03-29, 03:49
my system seems to act very much like russj's. i never changed any settings, but still my sb3 is able to start up my pc. contrary to russj however, i'd really like to disable this function. strange thing is though, in my bios it says "Power On by Modem/LAN" -> Disabled. the settings for my LAN in XP are ok as well ('Allow this device to bring the computer out of standby' is unchecked). does anyone have an idea of how this might be possible?

If you have a second NIC plugged into the PCI bus, that might explain it. Otherwise my guess would be that that on/off switch in the BIOS for that setting doesn't actually work - maybe you need to update the BIOS? Alternatively, check all your other power management settings in the BIOS and make sure that anything relating to waking the PC is switched off.

One other thing you could do, if you have a router with firewall built in, is to filter out magic packets from your LAN (UDP port 9 I think it is).

Chris.

strapats
2006-03-30, 11:40
thank you very much for replying, i appreciate the suggestions. i don't have a second network card, just an onboard nic. i'll have another look in my motherboard's manual. if that doesn't help, perhaps i'll have a go at updating the bios. though that isn't something i trust myself with.

btw, i should have mentioned that i think the squeezebox is a superior device, considering it was my first post. so there you go.