PDA

View Full Version : Slimserver ODBC driver problem



Khuli
2006-02-23, 14:49
I've just installed the ODBC driver http://www.ch-werner.de/sqliteodbc/ and have a few questions/points:

It set up 3 drivers.. SQLite, SQLite3 and SQLite(UTF-8). I pointed these all to slimserversql.db but only the SGLite3 would produce anything in MS Access (the other 2 gave an error).

Anyway, I got the various tables linked after some delay.. the [contributor] field in 'Albums' is text, whereas the [ID] field in 'Contributors' is numeric (??).

However, I've not managed to work around accented characters.. my entry for Björk is coming through as Björk. Anyone know how to correct this?

Thanks.

cjhabs
2006-02-23, 17:09
I don't know too much about this but I would expect the ID field to be numeric as it usually signifies a key used to link between tables.

Also, as Björk uses a special character in the name that is showing up as 2 characters in MS Access, I think you'll need to get the UTF-8 driver working as UTF-8 handles multi-byte Unicode characters.

HTH

Habs


I've just installed the ODBC driver http://www.ch-werner.de/sqliteodbc/ and have a few questions/points:

It set up 3 drivers.. SQLite, SQLite3 and SQLite(UTF-8). I pointed these all to slimserversql.db but only the SGLite3 would produce anything in MS Access (the other 2 gave an error).

Anyway, I got the various tables linked after some delay.. the [contributor] field in 'Albums' is text, whereas the [ID] field in 'Contributors' is numeric (??).

However, I've not managed to work around accented characters.. my entry for Björk is coming through as Björk. Anyone know how to correct this?

Thanks.

Khuli
2006-02-24, 02:21
... which implies that the UTF-8 driver isn't compatible with SQLite3 , so not much chance of me getting it working :(