PDA

View Full Version : Unable to stream at lower bitrate



puneetd
2006-02-22, 14:15
Because of frequent network interference, I have been trying to get slimserver to convert my flac files on-the-fly to MP3 for streaming to my SB2. I haven't had any success yet. Under serversettings->file types, I have checked the box for FLAC->MP3, but the following error message is returned:

Required binary was not found: [flac] -dcs --skip=$START$ --until=$END$ -- $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -

I have both the lame 3.96 and flac 1.1.1 codecs installed on my computer.

Any ideas how to make this work?

Mark Lanctot
2006-02-22, 14:38
Have you put LAME in the right place?

In SlimServer help - Frequently Asked Questions -
"Where do I put the lame, oggtools or other
transcoding programs?"

"Under Windows, they should be placed in the
C:\Program Files\SlimServer\server\Bin or the
C:\Windows folder.

On the Mac, you can place executable programs in
your Library/SlimDevices/bin folder, or in the
system path.

Under linux they should be placed in the system
path. That probably means /usr/local/bin. Most rpm
packages will take care of that for you."

Also to get bitrate limiting going you do not
necessarily have to use Server Settings - File
Types, you should go to Player Settings - Audio -
Bitrate Limiting. This will also tell you if it
has found the LAME encoder, "The LAME encoder
appears to be installed correctly on your system."

puneetd wrote:
> Because of frequent network interference, I have
been trying to get
> slimserver to convert my flac files on-the-fly to
MP3 for streaming to
> my SB2. I haven't had any success yet. Under
serversettings->file
> types, I have checked the box for FLAC->MP3, but the
following error
> message is returned:
>
> Required binary was not found: [flac] -dcs
--skip=$START$ --until=$END$
> -- $FILE$ | [lame] --resample 44100 --silent -q
$QUALITY$ --abr
> $BITRATE$ - -
>
> I have both the lame 3.96 and flac 1.1.1 codecs
installed on my
> computer.
>
> Any ideas how to make this work?
>
>

--
___________________________________


Mark Lanctot
___________________________________

kdf
2006-02-22, 15:03
Quoting puneetd <puneetd.23ngrz1140643801 (AT) no-mx (DOT) forums.slimdevices.com>:

> Any ideas how to make this work?

the lame binary must be installed in the path. c:\windows\system, or
c:\program files\slimserver\server\Bin, for examples.

Flac binary is unlikely to e the problem, since the server comes with a copy.
-kdf

puneetd
2006-02-23, 01:36
Perfect fix. Streaming like a champion.
I appreciate the helpful responses.
Puneet.

charlesr
2007-01-16, 10:01
I've just switched my slimserver over from my mp3 folder to my freshly ripped FLAC folder. Previously I could stream the mp3s no problem from slimserver on my home pc to winamp on my work laptop at the office.

Now when I show winamp the stream and tell slimserver to use lame to encode the flacs to mp3 before sending the stream (it confirms lame is properly installed on the server page), nothing happens when I press play on the server. Winamp says welcome to slimserver and notices the name of the last item in the playlist but doesn't play the stream.

Just to note, the FLACs stream fine to my squeezeboxes around the house and sound so much better.

What have I missed? Bet it's really simple.

Eric Seaberg
2007-01-16, 10:21
I just started re-ripping all of my music to FLAC since Apple's lossless is having problems with SS.

I woke up this morning to begin listening to some of the newly ripped files and they won't convert to LAME. I'm having to limit to 320k on my wireless devices, yet the Transporter is wired and runs NO LIMIT. NO LIMIT settings allow the files to play fine, but my 811.b network can't handle that throughput, so I keep it limited.

LAME IS installed correctly, as I can convert Apple Lossless or AAC files to the 320k limit, but no FLAC->LAME.

All file types are set correctly. I even reverted back to SS 6.5 with no change. Latest nightly give the same response. LAME is updated to the latest version, too.

I've tried everything... any ideas?

charlesr
2007-01-20, 00:11
anyone got any ideas to my query above?