PDA

View Full Version : permission problem: opendir failed



cenzo
2006-02-14, 14:02
it seems that slimserver is unable to use its group privileges.

i start slimserver with an init script, wherein i declare:

--user=slimserver --group=slimserver

in /etc/group i have:

muzak:x:101:slimserver

and in /etc/passwd i have:

slimserver:x:999:999::/usr/local/slimserver:/usr/sbin/nologin

id slimserver yields:

uid=999(slimserver) gid=999(slimserver) groups=999(slimserver),101(muzak)

and the directory that it fails to open is:

drwxr-x--- 12 tom muzak 296 Feb 14 00:01 muzak

specifically- the log file shows:

2006-02-14 15:43:57.9753 opendir failed: /home/muzak: Permission denied


Please help. I cannot figure this one out. The server works fine when the group permission on the directory is changed from muzak to slimserver. but i really do not want it set that way.

thanks.
vg

Robin Bowes
2006-02-14, 15:30
cenzo said the following on 02/14/2006 09:02 PM:
> it seems that slimserver is unable to use its group privileges.
>
> i start slimserver with an init script, wherein i declare:
>
> --user=slimserver --group=slimserver
>
> in /etc/group i have:
>
> muzak:x:101:slimserver
>
> and in /etc/passwd i have:
>
> slimserver:x:999:999::/usr/local/slimserver:/usr/sbin/nologin
>
> id slimserver yields:
>
> uid=999(slimserver) gid=999(slimserver)
> groups=999(slimserver),101(muzak)
>
> and the directory that it fails to open is:
>
> drwxr-x--- 12 tom muzak 296 Feb 14 00:01 muzak
>
> specifically- the log file shows:
>
> 2006-02-14 15:43:57.9753 opendir failed: /home/muzak: Permission
> denied
>
>
> Please help. I cannot figure this one out. The server works fine when
> the group permission on the directory is changed from muzak to
> slimserver. but i really do not want it set that way.

Why not make the music directory world-readable, i.e.:

chmod o+rx /home/musak

R.

cenzo
2006-02-14, 16:58
I suppose I didnt make the problem clear:

The problem is that I cannot get slimserver to use its group privileges.

Yes, slimserver has no problem when the files are world readable. But this does not solve the problem.

Is slimserver able to use group privileges assigned in /etc/group? If not- can this be fixed?

snarlydwarf
2006-02-14, 17:08
Please help. I cannot figure this one out. The server works fine when the group permission on the directory is changed from muzak to slimserver. but i really do not want it set that way.


Why not specify --group=muzak on the invocation?

drtebi
2007-06-01, 02:24
This is indeed quite a problem. Especially if updating e.g. from 6.3 to 6.5.

It should not just be assumed that we can adjust all our user/group and permission settings to fit whatever slimserver needs.

However, for now the solution for me was the one mentioned here--run slimserver with --group=<groupname>

Ideally, slimserver should work in regards to what is in /etc/groups.