View Full Version : Can't connect wireless SB on WPA, only WEP!

2006-02-14, 12:29
Have had couple of SB2's for 6 months or so and love them! Setup on wireless network was no problem, used WPA security, and been generally fine since.

Recently the SB displays went black as when Slimserver down or network connection drops. Usually reboot of router is all it takes.

This time however, I just couldn't re-establish connection. Tried restart of Slimserver, upgrade to latest release, reboot of router and upgrade of router firmware - nothing! SB network setup went fine, found wireless network etc. until they tried to obtain IP addresses. Kept coming up with IP addresses outside the range usually assigned by router, and then couldn't 'see' music source or Slimserver.

Trawled through the forums and tried various suggestions, even though most problems were with connecting to or seeing the network in the first place, and nothing worked. Only got them to connect correctly when I change network security from WPA (which I'd been using fine since I got the SB's) to 128bit WEP. Now working OK, but it's really bugging me. I use another wireless PC and a tablet, and would prefer to go back to WPA encryption.

As far as I know, none of the settings on the SB or network had been changed before the problem ocurred.

Any ideas? Thanks

2006-02-14, 13:19
I'm surprised nobody has chipped in with this yet, but I guess its my turn.
Please provide more info on your setup, ie. router model, Slimserver version & SB firmware version, OS, etc. You didn't update your Slimserver recently, did you? I haven't a clue why WPA would just stop working, while WEP still does.....

2006-02-14, 13:39

I've got squeezebox 2's, running on a Netgear DG834GT ADSL Router, Windows XP.

When the SB's stopped working, I wasn't aware of having made ANY changes any settings, either to the network, SB or slimserver.

In trying to re-establish a connection I upgraded Slimserver to 6.2.2. When I eventually got them running the SB's automatically upgraded to firmware version 29.

To be honest, I tried so many steps to get them running again, I'm not sure which was the most crucial. But when I had finally re-established connections on WEP, I reset the network and squeezeboxes to the original WPA setup - I got the same erroneous IP addresses and was unable to connect to the PC/Slimserver. When I switched back to WEP everything was OK.

Even when I was trying to solve the problem I was able to check the network wasn't at fault; my tablet was on the same security settings and was connecting fine.