PDA

View Full Version : Help! Web interface not responding (latest nightly)



jimwillsher
2006-02-13, 14:27
Hi all,

I've just installed the latest 6.2.2 nightly on Ubuntu via alian and dpkg. Everything insatlled successfully, and slim starts, but the web interface won't respond. When I start it via --diag this is what I get:



squeeze@orca:/usr/local/slimserver$ ./slimserver.pl --diag
2006-02-13 21:22:41.6188 Odd number of elements in anonymous hash at /usr/local/slimserver/Slim/Web/Setup.pm line 2313.
2006-02-13 21:22:41.6193 Use of uninitialized value in anonymous hash ({}) at /usr/local/slimserver/Slim/Web/Setup.pm line 2313.
2006-02-13 21:22:41.8617 Using a hash as a reference is deprecated at /usr/local/slimserver/Plugins/MusicMagic/Plugin.pm line 1251.
2006-02-13 21:22:41.8622 Using a hash as a reference is deprecated at /usr/local/slimserver/Plugins/MusicMagic/Plugin.pm line 1266.
2006-02-13 21:22:41.9970 defined(@array) is deprecated at /usr/local/slimserver/Plugins/ShoutcastBrowser/Plugin.pm line 138.
2006-02-13 21:22:41.9973 (Maybe you should just omit the defined()?)
2006-02-13 21:22:41.9979 defined(%hash) is deprecated at /usr/local/slimserver/Plugins/ShoutcastBrowser/Plugin.pm line 171.
2006-02-13 21:22:41.9981 (Maybe you should just omit the defined()?)
2006-02-13 21:22:42.4196 Use of uninitialized value in numeric eq (==) at /usr/local/slimserver/Slim/Player/Player.pm line 618.
2006-02-13 21:22:42.4243 Use of uninitialized value in pattern match (m//) at /usr/local/slimserver/Slim/Player/Source.pm line 2220.

or alternatively



2006-02-13 21:24:31.6946 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7041 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7048 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7142 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7147 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7242 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7248 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7535 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.7543 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.8027 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.
2006-02-13 21:24:31.8033 Use of uninitialized value in substitution (s///) at /usr/local/slimserver/Slim/DataStores/DBI/DBIStore.pm line 1474.


The web interface isn't responding at all, just sitting there like a lemon.

Slim looks like it's listening though



root@orca:/usr/local/slimserver/Bin# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:9090 *:* LISTEN 6083/perl
tcp 0 0 *:9000 *:* LISTEN 6083/perl


but my browser (IE) sits there saying opening 192.168.1.150:9000

before eventually timing out.

Is anyone else experiencing anything dodgy like this? I'm sure all these errors aren't exactly a wonderful coding example...

I'm using:


root@orca:/usr/local/slimserver/Bin# perl -v

This is perl, v5.8.7 built for i486-linux-gnu-thread-multi
(with 1 registered patch, see perl -V for more detail)

root@orca:/usr/local/slimserver/Bin# uname -a
Linux orca.jimwillsher.co.uk 2.6.12-10-686 #1 Mon Jan 16 17:58:04 UTC 2006 i686 GNU/Linux





Many thanks,



Jim

PS I'll keep restart it, that sometimes seems to work.....

kdf
2006-02-13, 15:15
Quoting jimwillsher <jimwillsher.236t0b (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Hi all,
>
> I've just installed the latest 6.2.2 nightly on Ubuntu via alian and
> dpkg. Everything insatlled successfully, and slim starts, but the web
> interface won't respond. When I start it via --diag this is what I
> get:

--diag is a BAD idea unless you are really digging for something. It
makes a mess of regular expressions and totally skips over the more
obvious causes for problems. I honestly do not know what it is
actually useful for at all, given how much it breaks even with a
working install.

../slimserver.pl --d_server --d_http will be more useful.

d_server is good to make sure everything inits ok.
d_http will show any request and response for the web server

The only change from yesterday's build was to the player UI for browse
music folder, and some updated translations.

-k