PDA

View Full Version : Rogue Compilations



jonheal
2006-02-10, 05:12
I'm using a variant of 6.2.2.

I've noticed a few instances where SlimServer has tagged a few of my albums as "compilations" even though I did not tag them that way myself. These are classical recordings that had different artists on a few of the tracks.

I would prefer that SlimServer not make these decisions for me. Is this behavior changed in 6.5?

funkstar
2006-02-10, 05:30
I retagged everything like that to have the given album artist in the 'Artist' tag then moved all the actual artist names into the 'Original Artist' tag. I don't know if SS makes use of this tag, i'm not bothered really, just means i don't loose the meta data within the file. it's there if i ever need it.

SS doesn't do anything clever with my various artist files. It thinks 'Various Artists' is a valid artist name and treats everything like regular albums. Thats the way i like it. The majority of my compilations are dance mix CDs, so it wouldn't make sense to have idividual tracks played on their own.

jonheal
2006-02-10, 06:32
I'd still like to know if this behavior has changed in 6.5, or if it can be changed in 6.2.2.

slimpy
2006-02-10, 07:50
I'd still like to know if this behavior has changed in 6.5, or if it can be changed in 6.2.2.
It can be changed under Server Settings - Behavior - Compilations
Select "List compilation albums under each artist" from the dropdown list.
Slimserver treats albums with different artists as a compilation if all files are located in the same directory even if they are not tagged as compilations.

-s.

Dan Sully
2006-02-10, 08:27
* jonheal shaped the electrons to say...

>I've noticed a few instances where SlimServer has tagged a few of my
>albums as "compilations" even though I did not tag them that way
>myself. These are classical recordings that had different artists on a
>few of the tracks.
>
>I would prefer that SlimServer not make these decisions for me. Is this
>behavior changed in 6.5?

You can turn off 'Auto Various Artists Identification' in the Server Settings.

Alternatively, if you are using FLAC / Ogg, you can explictly set
COMPILATION=0 in your tags.

-D
--
On second thought, let's not go to Camelot. It is a silly place.

jonheal
2006-02-10, 09:12
Thanks Dan and Slimpy. I'll try it when I get home.

jonheal
2006-02-11, 03:10
* jonheal shaped the electrons to say...

>I've noticed a few instances where SlimServer has tagged a few of my
>albums as "compilations" even though I did not tag them that way
>myself. These are classical recordings that had different artists on a
>few of the tracks.
>
>I would prefer that SlimServer not make these decisions for me. Is this
>behavior changed in 6.5?

You can turn off 'Auto Various Artists Identification' in the Server Settings.

Alternatively, if you are using FLAC / Ogg, you can explictly set
COMPILATION=0 in your tags.

-D
--
On second thought, let's not go to Camelot. It is a silly place.
Dan,

I'm not sure where that setting can be found. There is a setting entitled "List compliation albums under each artist | Group compilation albums together," but it has no effect on this problem.

Basically the compilation column in the albums table is set to 1 on three of my classical albums. I can update the table and set it to 0 but when I restart SlimServer, the column is reset to 1.
As I said in my previous posts, what distinguishes these particular tracks is that the tracks of each album do not have the same infomation in all of the Artist tags. (I tend to leave the Artist tag blank for my classical albums, these three have soloists on some tracks.)

ceejay
2006-02-11, 03:32
Dan,

I'm not sure where that setting can be found. There is a setting entitled "List compliation albums under each artist | Group compilation albums together," but it has no effect on this problem.

Basically the compilation column in the albums table is set to 1 on three of my classical albums. I can update the table and set it to 0 but when I restart SlimServer, the column is reset to 1.
As I said in my previous posts, what distinguishes these particular tracks is that the tracks of each album do not have the same infomation in all of the Artist tags. (I tend to leave the Artist tag blank for my classical albums, these three have soloists on some tracks.)

I think Dan was suggesting that you create a tag COMPILATION with value 0 in these files, not to patch the database (which will get rewritten every time Slimserver rescans). You might want to try that.

Also, I think "Auto Various Artists Identification" is the same as "Group Compilation Albums Together" in 6.2.2 - the name has changed, AFAIK. But this doesn't explain why you are getting Various Artists grouping going on with this disabled, which is what I think you've said.

One thing I think we've touched on before... I personally really wouldn't leave ARTIST blank for anything, its just asking for trouble with computer audio players which expect that as basic information. If you don't have anything better to put in there, why not just duplicate COMPOSER?


HTH

Ceejay

JJZolx
2006-02-11, 08:48
Dan,

I'm not sure where that setting can be found. There is a setting entitled "List compliation albums under each artist | Group compilation albums together," but it has no effect on this problem.
Good question. What happened to the 'Auto Various Artists Identification' setting? I know it used to be there.


Basically the compilation column in the albums table is set to 1 on three of my classical albums. I can update the table and set it to 0 but when I restart SlimServer, the column is reset to 1.
Not sure why it would be reset if you restart. If you _rescan_ it would definitely be reset. You need to set a tag in (all of) the files on the album.

I was aware that COMPILATION=1 explicitly told SlimServer that an album is a compilation, but wasn't aware that setting COMPILATION=0 explicitly told SlimServer that an album is _not_. Sounds like it would be a good practice to tag all albums with the appropriate COMPILATION tag.