PDA

View Full Version : Greatest Hits grouping question



joncourage
2006-02-03, 16:17
My "Greatest Hits" albums are getting grouped under Various Artists, even tho the artist tag is the same for each of the albums (eg Chicago, Aerosmith, etc).

I tried changing the setting for "Common Album Titles" and re-scanning, but the artist (eg Chicago) still doesn't show up under Browse/Artists, only under "Various Artists".

Anyone offer some help on what I may be doing wrong?

Thanx!

Patrick Dixon
2006-02-04, 02:29
You have checked the box so that it uses 'Common Album Titles', haven't you?

joncourage
2006-02-04, 09:38
Yep (see above), originally it was un-checked. So I tried selecting it and re-scanning but the artists who only have a Greatest Hits album still don't show up under Browse/Artists...?

Siduhe
2006-02-04, 09:49
My "Greatest Hits" albums are getting grouped under Various Artists, even tho the artist tag is the same for each of the albums (eg Chicago, Aerosmith, etc).


That kind of behaviour sounds a bit like the way that the compilation setting works. Try switching Compilation behaviour (just above the common titles) to "List compilations under each artist". Does that change anything ? If so, it may be that those albums are mis-tagged as compilations.

joncourage
2006-02-04, 13:42
That must be it, when I change that setting the album shows under the correct Artist.

I took a look at the tags (FLAC) using my tag editor and don't see anything that makes me think it's tagged as a compilation though. Not sure what that looks like so will try to compare to ones that really are compilations.

Siduhe
2006-02-04, 13:49
I don't use FLAC tags much (Vorbis comments ?), but if you can't immediately spot the problem this may help.

Not sure which tag editor you are using, but not all support "part of a compilation" so you may not see it. You can try downloading Tag&Rename. You get a 30 day free trial.

Go to the multi-field tab (across the top of the screen), load up an affected albums, select all, select "Edit all supported tag fields". Don't touch anything else but uncheck the "Part of compilation" field and press save. Test it's worked by selecting just one file and "Edit all supported tag fields" - the compilation box should be empty now.

You will need to do a full library rescan (bit of a pain) but this should sort it out.