PDA

View Full Version : Severe trouble with Internetradio both via SqueezeNetwork and iTunes-Playlists



sporketeer
2006-01-30, 16:37
I Just received my brandnew SqueezeBox 3 some 24h ago and have to admit that I really love this little "magic box".

Some trouble came up when I started to play around with the internetradio features of the box. The box freezes and behaves weird and seems to experience some trouble/errors.

My setup:
- Apple Macintosh Powerbook G4 15" running SlimServer 6.2.1, 1GB Ram, never exceeded 30% of CPU-usage during all tests (eg on-the-fly LAME transcoding), Mac OS X 10.4.4, Airportcard (11mBit/s i.e. 802.11b)
- Squeezebox 3 with firmware v28
- Router FRITZ!Box Fon WLAN 7050 (UI), Firmware-Version 14.03.101 running 802.11 b/g mixed mode, WPA Personal with 63char password
- DSL connection 6Mbit downstream, 580kbit upstream, no other traffic on the network except for the Squeezebox while testing
- no cordless 2.4GHz phones nearby
- All other WLANs in range are running on channel 11, mine as far apart as possible on channel 1
- no microwave-ovens nearby

A second test (which did not change anything) involved a second server on a 3GHz, 1GB Ram, WinXP SP2 PC running the same server software. Furthermore a second Squeezebox was added to the network.

In both cases the servers were limited to MP3 streaming to save network bandwidth (via LAME encoding). All "native" and load-heavy codecs were switched off. The tests where all conducted with at least 70% network strength on the broadcast-strength-measurement-tools.

No to the problem:
I experienced various problems when using both thte SqueezeNetworks (SNet) Internetradio Picks/Shoutcast Picks/ etc. as well as direct bookmarks to streaming sources from my iTunes Webradio playlist. I tryed this with .pls files/URLs copied from webpages (eg m1live.com, sky.fm, di.fm, ) and those obtained directly from iTunes' radio service (which include session details I think, which again makes them expire sometimes, and therefore they do not work).

1. The first and most painful problem which I experienced is the fact, that stations which I added to my favorites via Remote on the SBox directly were saved but caused the box to freeze after I selected them some 30 minutes later or so. Freezing in this case was final, no remote exits, no reconnecting via "left key", only pulling the plug worked.

2. Some stations started to react (the little note symbol showed up) and then froze the box. Again, no rescue, pulling the plug as a final resort.

3. When connecting via SlimServer on my Mac, I was able to see that some of the "jerking" was due to music-library browsing, but this cannot possibly be the problem for 1. and 2. since even in absence of any Slimserver those freezes occured.

I am quite unsure where to start looking for solutions. I wasn't able to find anything in the forum helping me any further. So maybe I am lucky and someone here has an idea what could be done to improve the performance of the webradio feature. Good looks are nice, but I would love the Squeezebox even more if it would just work :-)

Thanks for any ideas/hints/thoughts.
Jan