PDA

View Full Version : slimserver 6.2.1 on OS X 10.2.8



chris_donahue
2006-01-28, 11:56
I installed the latest production release of Slimserver 6.2.1 this morning, and when attempting to start the server get the following error message:

2006-01-28 10:50:20.1481 SlimServer OSDetect init...
2006-01-28 10:50:20.1485 SlimServer OS Specific init...
2006-01-28 10:50:20.1492 SlimServer daemonizing...
2006-01-28 10:50:20.1632 SlimServer settings effective user and group if requested...
2006-01-28 10:50:20.1648 SlimServer settings init...
2006-01-28 10:50:20.1868 SlimServer saving pid file.
2006-01-28 10:50:20.1890 Got to the END.
2006-01-28 10:50:20.1894 Got sigint.
2006-01-28 10:50:20.1896 SlimServer cleaning up.
2006-01-28 10:50:20.3837 SlimServer strings init...
2006-01-28 10:50:20.5939 SlimServer Setup init...
2006-01-28 10:50:20.6316 SlimServer setting language...
2006-01-28 10:50:20.6321 SlimServer IR init...
2006-01-28 10:50:20.6672 SlimServer Buttons init...
2006-01-28 10:50:20.6761 SlimServer Graphics init...
Can't locate auto/Storable/store.al in @INC (@INC contains: /Library/SlimDevices/ /Users/fox/Library/SlimDevices /Users/fox/Library/SlimDevices/Plugins/ /Library/SlimDevices/Plugins/ /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN/arch/5.6.0/darwin /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN/arch/5.6.0/darwin/auto /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN/arch/5.6/darwin /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN/arch/5.6/darwin/auto /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN/arch/darwin /System/Library/Perl/darwin /System/Library/Perl /Library/Perl/darwin /Library/Perl /Network/Library/Perl/darwin /Network/Library/Perl .) at /Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Display/Graphics.pm line 392
2006-01-28 10:50:27.8452 Got to the END.
2006-01-28 10:50:27.8456 Got sigint.
2006-01-28 10:50:27.8458 SlimServer cleaning up.

I realize that 10.2.8 isn't a supported OS X platform, but if there is a simple fix to this error, I'd much appreciate hearing about it!

Dan Sully
2006-01-28, 12:06
* chris_donahue shaped the electrons to say...

>I realize that 10.2.8 isn't a supported OS X platform, but if there is
>a simple fix to this error, I'd much appreciate hearing about it!

The 6.2.2 nightlies at http://slimdevices.com/dev_nightly.html will fix this.

-D
--
<dr.pox> does whistling in the dark make me go blind faster?

chris_donahue
2006-01-28, 15:41
Thanks for the help. I re-installed the latest 6.2.2 application, and get this error in the slimserver.log:

dyld: perl Undefined symbols:
_bytes_from_utf8

The console.log reports:

crashdump: Crash report written to: /Users/fox/Library/Logs/CrashReporter/perl.crash.log

/Users/fox/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim Launcher.app/Contents/Resources/Start Slim Server.sh: line 13: 716 Trace/BPT trap ./slimserver.pl --daemon --d_server --logfile ~/Library/Logs/slimserver.log >>~/Library/Logs/slimserver.log 2>&1

And finally, the perl.crash.log has:

Command: perl
PID: 2065

Exception: EXC_BREAKPOINT (0x0006)
Code[0]: 0x00000001Code[1]: 0x8fe01220

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe10654 in link_in_need_modules
#2 0x8fe121d0 in _dyld_link_module
#3 0x900169c8 in NSLinkModule
#4 0x00002968 in 0x2968
#5 0x00002b58 in 0x2b58
#6 0x90ef1ebc in Perl_pp_entersub
#7 0x90eeafdc in Perl_runops_standard
#8 0x90ea3380 in perl_call_sv
#9 0x90ea6d1c in S_call_list_body
#10 0x90ea6888 in Perl_call_list
#11 0x90ec9b64 in Perl_newATTRSUB
#12 0x90ec627c in Perl_utilize
#13 0x90ebe8b8 in Perl_yyparse
#14 0x90f1a3e8 in S_doeval
#15 0x90f1bdd0 in Perl_pp_entereval
#16 0x90eeafdc in Perl_runops_standard
#17 0x90ea3380 in perl_call_sv
#18 0x90ea6d1c in S_call_list_body
#19 0x90ea6888 in Perl_call_list
#20 0x90ec9b64 in Perl_newATTRSUB
#21 0x90ebe734 in Perl_yyparse
#22 0x90ea23ec in S_parse_body
#23 0x90ea1778 in perl_parse
#24 0x0000258c in 0x258c
#25 0x000022b0 in 0x22b0
#26 0x00002130 in 0x2130

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0202f030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x8fe09bd8 ctr: 0x8fe293ac mq: 0x00000000
r0: 0x00000004 r1: 0xbfffdf50 r2: 0x8fe0b794 r3: 0x0000002f
r4: 0x00000000 r5: 0x0000002f r6: 0x0000000a r7: 0x65735f66
r8: 0x726f6d5f r9: 0x00000000 r10: 0x8fe4850c r11: 0x00000010
r12: 0x8fe71a56 r13: 0x00000080 r14: 0xa0eaa088 r15: 0xa0eaa088
r16: 0xa0ea19bc r17: 0xa0eadbec r18: 0x00000001 r19: 0xa0ea19bc
r20: 0xa0ea8d94 r21: 0x00000000 r22: 0x00000000 r23: 0x00442130
r24: 0xa0ea8d94 r25: 0x00002a2c r26: 0x00002a2c r27: 0x00021ef8
r28: 0x8fe4841c r29: 0x8fe484ec r30: 0x8fe484ec r31: 0x8fe0995c

Is there a recommended version of Perl to run, or is this a 10.2.8 problem?

Dan Sully
2006-01-28, 15:56
* chris_donahue shaped the electrons to say...

>Is there a recommended version of Perl to run, or is this a 10.2.8 problem?

It's really a 10.2.8 problem. Because we use the system perl on OSX - and
that's really just too old. If you install a newer version of Perl via
Fink/Darwinports, and run /path/to/new/perl Bin/build-perl-modules.pl - that
might work.

-D
--
This knob controls the thing that changes when you turn it. - noah

MartinP
2006-01-28, 17:26
I posted this problem last week - the thread is on this board. Slimserver 6.2.1 requires OS 10.3, according to Slim Devices support people. I was able to install version 6.1.1 successfully. I'm running OS 10.2.8 on an old beige G3.

SoundBoy
2006-01-28, 19:32
I posted this problem last week - the thread is on this board. Slimserver 6.2.1 requires OS 10.3, according to Slim Devices support people. I was able to install version 6.1.1 successfully. I'm running OS 10.2.8 on an old beige G3.

Hi Eveybody - get yourself un upgrade to OS Panther and 256 MB. You will get the first one for 40$ and the second for 20$. I tried a lot to run a newer SlimServer on my Imac with OS 10.28 - even installed the newest Perl version. Tip: save yourself the time and upgrade. Not worth the grey hairs..

Cheers Markus

MartinP
2006-01-29, 08:22
The beige minitower G3 doesn't run Panther, so to do as you suggest I'd have to buy a new machine. Why bother? I have Slimserver 6.1.1 running happily, and communicating with the latest version of Softsqueeze.

The earlier versions of Slimserver are available at www.slimdevices.com/downloads/

Ben
2006-01-29, 12:49
XPostFacto (http://eshop.macsales.com/OSXCenter/XPostFacto/) will let you run the later versions of OS X on those early machines.

Ben

chris_donahue
2006-02-02, 09:50
Thanks for all the comments. I think the easiest solution for 10.2.8 users is to simply install 6.1.1.

MartinP
2006-02-02, 10:59
There's another thread on this topic in which the Slim Devices CTO has written that Slimserver 6.2.2 will in fact run on OS 10.2.8 soon, after a few bugs have been ironed out. Future versions of Slimserver will not support 10.2.8.