View Full Version : Problem installing softsqueeze 2.3

2006-01-25, 13:57
I recently downloaded softsqueeze 2.3 from sourceforge. (I assume it is not yet integrated into any of the nightly builds?) It worked fine at home, and cleaned up FLAC gapless very nicely. But at the office I am getting an installation error.

I see the message, "softsqueeze is preparing the install4j wizard," and the progress bar fills up to about two blocks from full. Then it hangs for a minute or so, then says:

install4j Wizard

The Java(TM) VM could not be started. Please restart the installation.You may use the parameter "/manual" to download or manually select a different VM.

and here's the log file that it generates:

Started executable D:\dl\softsqueeze_windows_2_3(2).exe at Wed Jan 25 15:53:03 2006

Init done
Starting work
extracting files
Included files: 7
Temp dir: C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\i4jruntime.jar (size: 322405)
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\platform.zip (size: 166968)
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\MessagesDefault (size: 18557)
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\i4jparams.conf (size: 4044)
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\License (size: 18009)
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\content.zip (size: 2873466)
extracting C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\stats.properties (size: 103)
extracting files done
Current working dir: C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628
Full JRE path: C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir15 628\jre.tar.gz
No JRE included
LoadDLL (0, (null), 0)
Searching for a JVM
Testing location (type Y)
checkJavaExe (C:\Program Files\Java\jre1.5.0_06\bin\java.exe, [out], 1.4, , 0)
file exists
got version from registry 1.5.0_06
checkJavaExe returning 1
Trying to load JVM-DLL from c:\program files\java\jre1.5.0_06\bin\java.exe
Trying c:\program files\java\jre1.5.0_06\bin\hotspot\jvm.dll (exists 0)
Trying c:\program files\java\jre1.5.0_06\bin\client\jvm.dll (exists 1)
Loading of JVM-DLL successful
launching program
vmoption count 7
vmoption 0: -Dexe4j.semaphoreName=d:_dl_softsq~2.exe
vmoption 1: -Dexe4j.isInstall4j=true
vmoption 2: -Dexe4j.moduleName=d:\dl\softsq~2.exe
vmoption 3: -Dexe4j.processCommFile=C:\DOCUME~1\jp004172\LOCALS ~1\Temp\e4j_p2768.tmp
vmoption 4: -Dexe4j.tempDir=C:\DOCUME~1\jp004172\LOCALS~1\Temp\ e4j3C.tmp_dir15628
vmoption 5: -Djava.class.path=C:\DOCUME~1\jp004172\LOCALS~1\Tem p\e4j3C.tmp_dir15628\i4jruntime.jar;C:\DOCUME~1\jp 004172\LOCALS~1\Temp\e4j3C.tmp_dir15628\content.zi p;C:\DOCUME~1\jp004172\LOCALS~1\Temp\e4j3C.tmp_dir 15628\platform.zip;
vmoption 6: -Dsun.java2d.noddraw=true
Creating JVM
JVM created
main class: com/exe4j/runtime/WinLauncher
param count: 6
param 0: false
param 1: com.install4j.runtime.installer.Installer
param 2: d:\dl\error.log
param 3:
param 4: false
param 5: D:\dl\softsqueeze_windows_2_3(2).exe
calling main
main returned
dest JVM

2006-01-25, 14:45
I recently downloaded softsqueeze 2.3...It worked fine at home, and cleaned up FLAC gapless very nicely.

What version were you using prior to trying 2.3? You were having trouble with gapless FLAC playback?

2006-01-27, 06:49
I believe I was using 2.2

2006-01-27, 08:03
What do you mean you had trouble with gapless FLAC playback? I tend to use crossfade so I have not experienced any trouble.

2006-01-30, 13:50
It looks like your Java installation may be broken, it might be worth
trying to reinstall Java or trying the
softsqueeze_windows_with_jre_2_3.exe download from sourceforge.