PDA

View Full Version : Music Magic Duplicates



agentsmith
2006-01-22, 07:59
After installing Music magic I keep getting duplicates of most songs, one with the MM logo and one without.

I tried wiping the SQL DB and rescan with same results.

Siduhe
2006-01-22, 08:44
Delete the setting for your Music Library under Server Settings and save it as blank ? You should leave this field blank if you are importing Music Library information from iTunes or Moodlogic.

Ben Sandee
2006-01-22, 11:14
On 1/22/06, Siduhe <Siduhe.221mdb (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> Delete the setting for your Music Library under Server Settings and save
> it as blank ? You should leave this field blank if you are importing
> Music Library information from iTunes or Moodlogic.


Untrue -- at least IMHO. I leave this set even using MM and the server
software correctly recognizes that the same track is present in both
library. There have been bugs in the past that resulted in duplicate track
entries as the OP described -- but IMO they were bugs and I haven't had the
problem recently (using 6.5 svn updated every few days).

HTH,

Ben

agentsmith
2006-01-23, 06:44
So 6.5 should solve this problem?

I guess I will try 6.5 again


On 1/22/06, Siduhe <Siduhe.221mdb (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> Delete the setting for your Music Library under Server Settings and save
> it as blank ? You should leave this field blank if you are importing
> Music Library information from iTunes or Moodlogic.


Untrue -- at least IMHO. I leave this set even using MM and the server
software correctly recognizes that the same track is present in both
library. There have been bugs in the past that resulted in duplicate track
entries as the OP described -- but IMO they were bugs and I haven't had the
problem recently (using 6.5 svn updated every few days).

HTH,

Ben

Ben Sandee
2006-01-23, 07:27
On 1/23/06, agentsmith <agentsmith.223b8z (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> So 6.5 should solve this problem?
>
> I guess I will try 6.5 again
>

I don't remember when this problem was fixed -- just be aware that 6.5 has
its own list of problems though. Until 6.5 is more stable you might be
better off using the other poster's suggestion of clearing your browse
folder path.

Ben

dSw
2006-01-25, 11:03
I had this problem recently when evaluating MMM. I also had several blank entries in my library and entries that came up "Error URL not found" or something like that.

This was the deal breaker for me. I've spent enough time trying to get it to finish it's "validation" of my library and I certainly won't pay for software that doesn't integrate properly.

davidC
2006-02-17, 17:28
i had the same duplicates problem (and another related MMM playlist problem - File not found) ... in my case it was due to "non-english" unicode characters in the path or filename (accents, umlauts etc).

somewhere between the MMM database and Slim database, the url is getting mangled on these filenames (which i think explains the duplicates, one entry that Slim found on it's scan, and something showing up with identical tag info, but a mangled different filename, hence the dupes)

hopefully Predixis or Slim can sort out dealing with unicode urls, it shouldn't be a big deal.

but in the meantime, i wrote a rough vb.net prog to recusrsively scan through the music folder on the server, and do it's best to replace these extended characters (tried to replace all the various e with an e, the different flavors of o with an o etc)
the authentic, culturally correct artist and track info is still stored in unicode in the tag, so you don't lose anything by ASCII-fying the path and filename.


anyhow after running the renamer, refresh the MMM db, and then refreshing SlimServer db, all the false duplicates are gone, all tracks have a MMM icon, and all playlists genertaed that include these tracks now work OK

if you want to try and rename some of your accented filenames, see if this fixes it, or at least have a good poke about the unicode paths

david