PDA

View Full Version : Linkstation & Slimserver module problem



thorby
2006-01-21, 05:25
I know there are a number of posts concerning this and I have looked at them and I have had no success (I am not UNIX literate).

I have been following Marc Field's excellent guide on installating slimserver but having problems on a Linkstation II box (mipsel processor). Like a few before me I get to the stage of running slimserver (./slimserver.pl etc..) and I get the failed modules error (The following modules failed to load: DBD::SQLite XML::Parser HTML::Parser Compr
ess::Zlib).

From reading posts and deduction I figure I am missing development tools/compilers for the build on the Linkstation. My question is simply Where do I get them (mipsel-tools-2.tgz from linkstationwiki.og)?, where do I put/install them on the box? and finally do I need to run build-perl-modules.pl for slimserver after installation?

Specs/Info:
Linkstation II Mispel processor running perl 5.8.7
slimserver 6.2.1 install

Many thanks in advance for any help.

Robin Bowes
2006-01-21, 16:24
thorby said the following on 01/21/2006 12:25 PM:
> I know there are a number of posts concerning this and I have looked at
> them and I have had no success (I am not UNIX literate).
>
> I have been following Marc Field's excellent guide on installating
> slimserver but having problems on a Linkstation II box (mipsel
> processor). Like a few before me I get to the stage of running
> slimserver (./slimserver.pl etc..) and I get the failed modules error
> (The following modules failed to load: DBD::SQLite XML::Parser
> HTML::Parser Compr
> ess::Zlib).
>
>>From reading posts and deduction I figure I am missing development
> tools/compilers for the build on the Linkstation. My question is simply
> Where do I get them (mipsel-tools-2.tgz from linkstationwiki.og)?,
> where do I put/install them on the box? and finally do I need to run
> build-perl-modules.pl for slimserver after installation?
>
> Specs/Info:
> Linkstation II Mispel processor running perl 5.8.7
> slimserver 6.2.1 install
>
> Many thanks in advance for any help.

Hi,

I have successfully installed slimserver remotely on a Linkstation II
(mipsel) for a client.

I'd be happy to do the same for you.

AIM: robinbowes
Yahoo: robin_bowes
MSN: robin-.net <at> robinbowes <dot> com

R.

thorby
2006-01-28, 04:11
Thanks for the offers of help. I Though I had better come back and let people know I resolved it and I will explain how. Firstly appologies for the delay but with a 8 week old baby you kinda forget things.

If you own a MIPSEL processor Linkstation (Firmware above v2.0 I believe) and have the same problems installing slimserver to resolve the issue I needed to do the following,

Went thorugh Marc Field's guide (http://www.fieldnetworks.com/slim/linkstation.html) when you have unpacked slimserver and try to run it you will get module failure errors.

1.Goto the linkstation wiki site find the mipsel slimserver modules. These are the missing modules for the MIPSEL processor:
(http://linkstationwiki.org/Projects/MIPSelSlimServerModules)
(http://linkstationwiki.org/downloads/mipsel-hdhlan/)

2. Download and install them onto the linstation on one of the visible shares

3. Download another telnet application other than the windows one (Apparently the windows telnet performs double clicks), I used PenguiNet.

4. Telnet onto the linkstation using the new telnet app

5. Move the files to the root of the linkstation from the share (mv command)

6. Unpack the files (tar xzvf file command)

7. Run the install (./install.sh). The installation should prompt you to run and then to remove the installation files (if you only get a single prompt and the install doesn't work, your telnet app is doing the double return thingy)

and you should be able to go back and run slimserver now.

Since I am a unix novice I though this would help others.