PDA

View Full Version : Unable to play XFM radio feed



markcaines
2006-01-16, 17:44
Hi,

I've been trying to play the following internet radio station:

mms://ms2.capitalinteractive.co.uk/xfm_high

but get no sound. It looks as if it is going to work, and says it is loading the station, but I just get silence. Most other radio stations seem to work.

I'm running Mac OSX 10.4.4 with a SB2.

coldslabs
2006-01-16, 18:28
I'm not being any help, but I can confirm it is working for me.

SB1
SlimServer 6.2.1
Ubuntu Linux

JJP
2006-01-17, 00:09
xfm_high works for me also

sometimes you have to make do with
mms://ms2.capitalinteractive.co.uk/xfm_low

which is pretty awful bandwidth though

Jonathan

markcaines
2006-01-17, 01:14
Nothing from the low stream either...

AaronS
2006-01-17, 15:27
I have the same problem. I can't play any wma stream in format of XFM's. Bascially, unless I get a url that ends in something like..

filename.asx

or filename.wmv

I can't play it.

I'm running this..

"SlimServer Version: 6.2.1 - 5194 - Windows XP - EN - cp1252"

Mitch G
2006-01-17, 16:09
I might be talking through my butt, and maybe I think AlienBBC is more magical than it is, but have you tried using AlienBBC to play it?

That said, in my early days of trying to get AlienBBC working, I believe I had a similar problem with wma feeds. I think in the end my problem was related to some parental control software I had installed on the computer. Have you tried disabling firewalls and the like to see if maybe some important TCP port is being blocked or something?

Just some thoughts,


Mitch

markcaines
2006-01-17, 17:16
Mitch,

Thanks for the thoughts. I'm also a fan of AlienBBC (but wondered if that might be what was stopping this stream working). I don't have any kind of parental control software installed.

I've tried setting up a playlist with the stream for AlienBBC in an AlienStream folder located in my plugins folder, but that doesn't get recognised by AlienBBC when I go into AlienBBC Playlists. Am I doing something wrong? I'd love to get this working.

Mark

markcaines
2006-01-17, 17:22
OK - I have now put the alienstream folder in the right place (was just being stupid before), and AlienBBC now finds it. However, the deadly silence remains... I've opened a whole host more ports in my firewall (on my computer rather than my router). Lots of ports on my router are open too though. If anyone can recommend other ports I should be opening, maybe that would help.

Mitch G
2006-01-17, 20:43
I tried it via AlienBBC as well as just plugging in the Radio URL in the Internet Radio page and it works for me.
So it works with an SB1 and Slimserver 6.2.1 running under XP.

Do you have any of the filetypes unchecked? All mine are checked except for the Shorten ones.

I'm assuming AlienBBC works for you otherwise?

Which firewall do you have on your computer? If it's Zone Alarm, I think I had read during my personal AlienBBC trials and tribulations that you need to completely uninstall ZoneAlarm to get some things to work.

Just a couple more thoughts.

BTW, that XFM is pretty good. :)


Mitch

AaronS
2006-01-18, 04:52
Thanks for the advice, but there shouldn't be any need to use AlienBBC, as WMA is supported natively now. Maybe we should file a bug report?

Though first I'll check if I have any file types unchecked...

markcaines
2006-01-18, 10:45
Still not getting anywhere...
I'm using a Mac so don't have Zone Alarm; I've opened all the ports that could possibly be relevant (as far as I know) both on my computer firewall and on my router firewall.

AlienBBC works fine for the BBC streams.

All the right filetypes are checked.

Any suggestions from the Slim Devices people?

AaronS
2006-01-18, 11:19
Here's the URL I'm trying to play

http://ms2.capitalinteractive.co.uk/xfm_high

If I put this into the 'radio tune in' box, nothing happens.

But, I've just discovered that if I put...

mms://ms2.capitalinteractive.co.uk/xfm_high

It works!

Web browsers must be able to deal with the faulty URL, but the Squeezebox cannot.

markcaines
2006-01-18, 12:45
Doesn't work for me, I'm afraid.

This is the log output with d_source set.

2006-01-18 19:43:45.8873 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:45.9004 4b:83:55:e8:05:bc: Switching to mode stop from stop
2006-01-18 19:43:45.9010 Already in playmode stop : ignoring mode change
2006-01-18 19:43:45.9015 Adding song index 0 to song queue
2006-01-18 19:43:45.9016 Clearing out song queue first
2006-01-18 19:43:45.9017 Song queue is now 0
2006-01-18 19:43:45.9032 4b:83:55:e8:05:bc: Switching to mode stop from stop
2006-01-18 19:43:45.9034 Already in playmode stop : ignoring mode change
2006-01-18 19:43:45.9036 Adding song index 0 to song queue
2006-01-18 19:43:45.9036 Clearing out song queue first
2006-01-18 19:43:45.9037 Song queue is now 0
2006-01-18 19:43:45.9040 4b:83:55:e8:05:bc: Switching to mode play from stop
2006-01-18 19:43:45.9061 openSong on: mms://ms2.capitalinteractive.co.uk/xfm_high
2006-01-18 19:43:45.9077 URL is remote : mms://ms2.capitalinteractive.co.uk/xfm_high
2006-01-18 19:43:45.9080 Trying to open protocol stream for mms://ms2.capitalinteractive.co.uk/xfm_high
2006-01-18 19:43:45.9083 Found handler for mms://ms2.capitalinteractive.co.uk/xfm_high - using Slim::Player::Protocols::MMS
2006-01-18 19:43:46.2070 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.2072 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.2073 undermax = 1, type = wma, softsqueeze = 4b:83:55:e8:05:bc, lame = /Users/markcaines/Library/iTunes/Scripts/iTunes-LAME.app/Contents/Resources/lame
2006-01-18 19:43:46.2074 checking formats for: wma-flc-softsqueeze-4b:83:55:e8:05:bc
2006-01-18 19:43:46.2075 checking formats for: wma-flc-*-4b:83:55:e8:05:bc
2006-01-18 19:43:46.2075 checking formats for: wma-flc-softsqueeze-*
2006-01-18 19:43:46.2076 checking formats for: wma-flc-*-*
2006-01-18 19:43:46.2076 Checking to see if wma-flc-*-* is enabled
2006-01-18 19:43:46.2077 enabled
2006-01-18 19:43:46.2077 Found command: [mplayer.sh] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
2006-01-18 19:43:46.2080 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.2082 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.2083 Matched Format: flc Type: wma Command: [mplayer.sh] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
2006-01-18 19:43:46.5233 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.5235 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.5243 Using command for conversion: "/Users/markcaines/Library/SlimDevices/bin/mplayer.sh" -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 "mms://ms2.capitalinteractive.co.uk/xfm_high" | "/Users/markcaines/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Bin/darwin/flac" -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
2006-01-18 19:43:46.5462 remoteURL is a song : mms://ms2.capitalinteractive.co.uk/xfm_high
2006-01-18 19:43:46.5528 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.5532 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.5533 undermax = 1, type = flc, softsqueeze = 4b:83:55:e8:05:bc, lame = /Users/markcaines/Library/iTunes/Scripts/iTunes-LAME.app/Contents/Resources/lame
2006-01-18 19:43:46.5536 checking formats for: flc-flc-softsqueeze-4b:83:55:e8:05:bc
2006-01-18 19:43:46.5537 checking formats for: flc-flc-*-4b:83:55:e8:05:bc
2006-01-18 19:43:46.5538 checking formats for: flc-flc-softsqueeze-*
2006-01-18 19:43:46.5539 checking formats for: flc-flc-*-*
2006-01-18 19:43:46.5540 Checking to see if flc-flc-*-* is enabled
2006-01-18 19:43:46.5541 enabled
2006-01-18 19:43:46.5542 Found command: -
2006-01-18 19:43:46.5546 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.5559 Setting maxBitRate for Mac player to: 0
2006-01-18 19:43:46.5561 Matched Format: flc Type: flc Command: -
2006-01-18 19:43:46.5562 remoteURL command - type flc format flc
2006-01-18 19:43:46.5569 remoteURL stream format : flc
2006-01-18 19:43:46.9502 4b:83:55:e8:05:bc New play mode: play
2006-01-18 19:43:46.9603 4b:83:55:e8:05:bc: Current playmode: play
2006-01-18 19:43:55.3618 Read to end of file or pipe
2006-01-18 19:43:55.3620 end of file or error on socket, opening next song, (song pos: 4186(tell says: . ), totalbytes: )
2006-01-18 19:43:55.3622 opening next song...
2006-01-18 19:43:55.3627 4b:83:55:e8:05:bc: Switching to mode playout-stop from play
2006-01-18 19:43:55.3629 4b:83:55:e8:05:bc New play mode: playout-stop
2006-01-18 19:43:55.3640 4b:83:55:e8:05:bc: Current playmode: playout-stop
2006-01-18 19:43:55.3642 No pending chunks - we're dropping the streaming connection
2006-01-18 19:43:55.3665 4b:83:55:e8:05:bc: Can't opennext, returning no chunk.
2006-01-18 19:43:55.4729 4b:83:55:e8:05:bc: Decoder underrun while this mode: playout-stop

AaronS
2006-01-18, 13:04
I'm not an expert, and someone will give you a better answer than me.. but it seems your setup is using mplayer to play the file, which shouldn't be neccessary, as the SB2 can play wma files natively now. A software/firmware upgrade might solve your problems.

Triode
2006-01-18, 13:17
Above debug is for softsqueeze which needs to decode on the server. Try mplayer from the command line with the feed - you probably see error messages.

AaronS
2006-01-19, 09:10
Ignoring the above...

I'm now trying to listen to XFM Scotland

I can put any of the following into Windows Media Player and hear the stream

http://ms2.capitalinteractive.co.uk/beat_stream
mms://ms2.capitalinteractive.co.uk/beat_stream
http://rope.icgo.fimc.net/staticweb/onair_players/onair_xfm_scotland/player/onair_xfm.asx

But none of them will play on my SB2.

I do think that windows media URLs can be a bit inconsistent, and stream providers don't always get it right - but surely the SB2 should be as resiliant as Windows Media Player?

markcaines
2006-01-20, 03:43
I can play the standard xfm stream on windows media player for mac, but not as a stream in iTunes. Could this be a LAME issue?

Craig, James (IT)
2006-01-20, 03:59
> I can play the standard xfm stream on windows media player
> for mac, but not as a stream in iTunes. Could this be a LAME issue?

It's a wma stream so it's unlikely to work in iTunes!

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

markcaines
2006-01-20, 06:12
> I can play the standard xfm stream on windows media player
> for mac, but not as a stream in iTunes. Could this be a LAME issue?

It's a wma stream so it's unlikely to work in iTunes!

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

Ah yes. Note to self: buy new brain.

bpa
2006-01-20, 06:18
The WMA stream should be decoded by your SB2. You didn't post any d_source log using the SB2 - the log you posted was for SoftSqueeze. There may be a settings problem which a log may uncover so post a log using the SB2.

Logs are best saved in a file, zipped and then attached to the post.

markcaines
2006-01-23, 13:26
BPA,

Sorry for the poor etiquette on log posting. I've now attached the log for playing the stream on my SB2. I'd welcome any thoughts.

Mark

AaronS
2006-01-23, 14:46
I've submitted a bug report here (http://bugs.slimdevices.com/show_bug.cgi?id=2860). Please add your experiences.

daverush
2006-01-29, 06:40
I'm trying to get Century FM using URL mms://ms2.capitalradiointeractive.co.uk/Century_1002 which works on Windows Media Player. Using Server version 6.2.1 with SB3 and Softsqueeze

AaronS
2006-03-07, 03:09
Does anyone know if there's been any progress on this?

markcaines
2006-03-07, 09:13
No progress that I know of - very frustrating.

bpa
2006-03-07, 14:25
Some since were complaining that SoftSqueeze didn't work, I did some test on filetype setting with SoftSqueeze with this URL mms://ms2.capitalinteractive.co.uk/xfm_high
and found a combination that worked.
I have the following filetypes enabled (i.e. all other disabled)
All 3 AIFF, All 3 FLAC, MP3, All 4 Musepack, All 3 OGG Vobis, of RTSP only RTSP->MP3, WAV-> MP3 & WAV->WAV, Windows Media -> MP3 & Windows Media -> WAV.

I found that if I enabled WAV->FLAC I got no output from Softsqueeze - errors and stream closes down or is closed down.

For the record - I am running Suse 9.2 Slimserver 6.5b1 AlienBBC 1.10beta Mplayer CVS 060219 SoftSqueeze 2.2.

markcaines
2006-03-23, 05:07
I've now found that playing around with file-types solves the problem. I've basically followed BPA's suggestions, and now have it working. The only remaining problem is that the XFM feed is such poor quality!

bpa
2006-03-23, 05:39
Some suggestions regarding quality.

1. XM plugin has two quality setting - high and low bit rate - are you using high bitrate ?
2. If you are transcoding to MP3 ensure LAME is set to generate highest quality
3. Check if the bit rate limit to a player is not set too low

Craig, James (IT)
2006-03-23, 05:42
I also think it sounds pretty terrible even on the high bit-rate.

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

markcaines
2006-03-23, 05:46
bpa - thanks. I'm using the "high" stream and have got everything set to the best quality possible, and it's great for other radio feeds. The problem is that XFM (or more precisely Capital) doesn't devote much bandwidth to internet streams.