PDA

View Full Version : No .shn Playback OS X



stel27
2006-01-16, 12:44
Can't figure out why my G5Imac running 10.4.4, Slimserver 6.2.2 won't playback .shn files.

When I save/change the shn related preferences in Slimserver it shoots out the related line from convert.conf and says it can't find an appropriate binary.

I'm running (Carbonized) Shorten 1.1a4 available here:

(http://www.hornig.net/shorten.html)

I can decode/recode shns on the Mac without issue;FLAC/mp3 playback work great.


Is it a path issue in convert.conf? Do I need to substitute the path to the shorten binary in the appropriate $FILE$ directive in convert.conf? I don't really understand the syntax of convert.conf and haven't been able to find any documentation related to it. My convert.conf looks alright, I guess...

Could somebpody that has functional shn to /wav/flac/mp3 playback on their SB3/Slimserver give some help/recommendations?

I have an as*load of archived .shns - this is a big issue for me.

kdf
2006-01-16, 12:56
Quoting stel27 <stel27.21qthb (AT) no-mx (DOT) forums.slimdevices.com>:

> I have an as*load of archived .shns - this is a big issue for me.

check the logs with d_source enabled in server settings->debugging.

more than liklely, it is a problem with the metadata. Shorten
documentation is very limited for extracting metadata directly. The
classic method of extracting the WAV header is the one used by
slimserver. This doesn't seem to work for all shorten files, and I
have never found a reason why.

-kdf

stel27
2006-01-16, 13:13
Thanks - I'll look into those logs.

If it is a problem with shorten metadata would this mean shn playback on my SB3 is hopeless and a mass recode necessary?

Man I hope not...