PDA

View Full Version : iTunes scan time



ppeeler001
2006-01-09, 11:37
I am running SlimServer 2.6.1 on Windows XP with a 3G Squeezebox.

Got it about 2 weeks ago and set up G:\music (external USB drive) as my music location.

This is my iTunes music folder location.

My problem was I want to organize my music via iTunes, but SlimServer was looking in G:\music and finding things that had been removed from my iTunes library. Also I wasn't getting my iTunes playlists (despite having the "use iTunes" button clicked).

I went ahead and changed my "Music Folder" and my "Playlist Folder" on the main server settings tab of slim server to a blank (per the instructions -- "You can leave this field blank if you are importing your music library information from iTunes"). I also manually specified my iTunes music library file and music location. Then I clicked on a "clean rescan".

Got the "Note: SlimServer is still scanning your music library, please be patient as this may take a while", which is fine, but it's been in this state for over 18 hours now, which seems like, way too long.

I turned on a few of the debug traces (iTunes and import) and I'm getting the same message every 5 minutes:

2006-01-09 12:58:23.8076 Import: Scanning with 1
import plugins
2006-01-09 12:58:23.8079 Playlist scan started at:
Sun Jan 8 18:20:10 2006
2006-01-09 12:58:23.8080
2006-01-09 13:03:23.9375 Import: Scanning with 1
import plugins
2006-01-09 13:03:23.9377 Playlist scan started at:
Sun Jan 8 18:20:10 2006
2006-01-09 13:03:23.9378

There doesn't seem to be any progress (i.e. there are no artists in my artist folder, no albums in my albums folder, etc.) and CPU usage is low/non-existant.

If anyone has any suggestions, I'd appreciate them -- I would also love to know what a clean load via iTunes should look like (I know when I loaded via slim server, I saw artists immediately -- is this true of iTunes as well), and how long I should expect it to take (given that I have about 50GB of music and a dozen iTunes playlists (half of them "smart").

Please let me know if there is any other information I can provide.

Thanks for your help and input.

Regards,
Phelps

Imagika
2006-01-09, 13:10
I've always run into problems when trying to point iTunes away from the default folder, especially when it's on an external/networked drive.

I took a look at iTunes complaints and this was often on there. I run iTunes and Slimserver on the same machine. Music database is in specific folders, but I just let iTunes use the default folder. I don't let iTunes manage my music and only let it build it's own database which is all it needs the iTunes folder for I believe.

With above setup, all has been working well!




This is my iTunes music folder location.

I went ahead and changed my "Music Folder" and my "Playlist Folder" on the main server settings tab of slim server to a blank (per the instructions -- "You can leave this field blank if you are importing your music library information from iTunes"). I also manually specified my iTunes music library file and music location. Then I clicked on a "clean rescan".

Regards,
Phelps