View Full Version : Remote Button Sensitivity

2006-01-07, 06:56
I realize that if you hold down the UP or DOWN buttons on the remote, SB3 will scroll through the available selections. But mine is TOO sensitive. Often, even if I just tap one of those buttons the SB3 will scroll through two selections instead of one. It's very frustrating. I know I'm kind if a butter-fingers, but I'm not THAT bad! I hope this isn't normal behavior.

Slimerver 6.2.1

2006-01-07, 08:31
are you playing alienbbc at the same time? I sometimes get this when using alienbbc; the gui becomes a little less responsive and skips over menu items two at a time. However, it's fine the rest of the time.

I guess that slimserver is preoccupied with transcoding the realaudio streams and gui updates are not as smooth as they could be.

2006-01-07, 09:33
I suspect that you are actually streaming flac to the player.
In this case it is bug: 2018 (http://bugs.slimdevices.com/show_bug.cgi?id=2018)

2006-01-07, 13:17
This bug also occurs with formats other than FLAC. I see it daily with WMAs.

2006-01-07, 13:27
I suspect that you are actually streaming flac to the player.
In this case it is bug: 2018 (http://bugs.slimdevices.com/show_bug.cgi?id=2018)

You are correct, sir.

Maybe someone'll fix it sometime. In the meantime, I'll just continue pulling what little hair I have left, out.

2006-01-07, 13:49
This annoyance occurs on both my SB2/SB2 remote and SB3/SB3 remote. There was talk of it being possibly due to the SB being in a room surrounded by glass windows/reflective surfaces. As my SB2 is in a conservatory surrounded by glass windows I thought this could be the case and thought nothing more of it, but when I got my SB3 (with a dodgy display I might add) this is also showing the problem and it's in a standard wallpapered room, so now I don't know.

I have also noticed that when browsing through the menus it can do a double jump, and, in the majority of cases, immediately pressing the opposite direction button also causes it to jump back a double jump, as though it's something to do with the displayed info.

I agree that it needs sorting as when it happens it's a RPITA especially if you know the next entry in the menu is the one you want to select.

2006-01-07, 16:04
I think the problem is in the remote control unit itself. When you press and hold the arrow button the remote repeatedly sends the command to change the display (flip the menu). If the remote sends it too quickly, or the buttons aren't well debounced, it will send the command out multiple times and go further than you want. The server is just doing what the remote tells it to do.

This can be fixed either in the remote control or in the server software. If the server is simply programmed to recognize multiple menu flip commands and just ignore every second one. Then it will still respond to a single push (when you manage to let go quick enough to not send multiple commands) but will automatically ignore excess commands.


2006-01-07, 20:06
There was a post regarding this not too long ago. The solution was to change the IR timing. If you are using Windows then this solution will only work if you are not using the pre-compiled binary (.exe). What you can do is change the IR timing in the slim\hardware\IR.pm file. Find the following lines in the file and change them to the below values as a start.

# If time between IR commands is greater than this, then the code is considered a new button press
$Slim::Hardware::IR::IRMINTIME = 0.256;
$Slim::Hardware::IR::IRHOLDTIME = 0.512;
$Slim::Hardware::IR::IRSINGLETIME = 0.512;

2006-01-07, 20:07
I'm not sure if it's the remote itself. I received my SB3 this week and just got it hooked up this afternoon. I noted the same problem with the occasional double-jumps. However, not only does it happen with the SlimDevices SB3 remote, but also with my Harmony 880 remote.


2006-01-08, 13:18
Yes, a very annoying problem which also happens with wma lossless. I only experience this when a track is playing however.

2006-01-08, 15:30
Assuming you are playing lossless transcoded to flac, I think it is the same problem as in the bug I referenced.

For the moment if you don't mind eating more cpu on the server and a bit more network bandwidth, you can alter server settings file types to avoid sending flac to the player:
disable: wav->flc, wma->flc, flc->flc

2006-01-29, 19:26
I have had the problem with the remore and I recently got the harmaone 880 and am having severe skipping with it. i have to belive it's not the remote. I thoigh i saw in another post that will be fixed with the next release of the server software. Please!!!!!!!!!!!!!!!!!!!