View Full Version : Clarkconnect Install

2006-01-05, 09:03

I am wondering about distro's and am thinking of going with Clarkconnect 3.21. Anyhow I have looked round the clarkconnect website and they have a slimserver 5.x rpm package. So my question is can I just install the 6.2.2 RPM from the slimdevices website? I am still waiting for a hard drive so I've not tried this.

So anyone using slimserver 6.2.2 on clarkconnect. If so how did you install it?


2006-01-05, 16:00
i'm using clarkconnect, bit i'm still on 2.something

to install i connect to the cc box with putty and run the following from the terminal :

rmp -Uvh "url of the latest .rpm at slimdevices.com"


2006-01-06, 03:14
Thanks I will give it a go once I have the hardware built and installed. Hope it really is this easy the slug install is a lot more complex.

2006-01-06, 04:53
Quick update. As my case doesnt look like its arriving until next week. I installed clarkconnect into a VMware session on my PC and then installed the RPM from the slimserver website and it all worked.

It was really easy to do and straight forward. As I am building a headless server / appliance this is what I will be doing. I dont need X it all runs under init 3. And I can configure it in a web browser.

So to get a working slimserver I had to download

ClarkConnect Home 3.21 ISO
Slimserver RPM
and Putty to give me command line access to install the rpm.

Installed clarkconnect and set up some shares etc
copied the rpm onto the share
Used Putty to connect to the server
Installed the Slimserver RPM (rpm -Uvh)
Pointed slimserver to a music directory
Ensured slimserver was set to automatically start (Just click auto in the clarkconnect webpage)
rebooted the box
All ok :)

2006-01-24, 08:56
Ok Final update. Got all the physical hardware assembled and working. Mini-ITX 600Mhz fanless with 250Gb samsung and 512Mb RAM. I would recommend a faster processor if buying new but I got this cheap from ebay.

Clarkconnect wouldnt install nicely from the CD kept getting a read error so probably something wrong with my image. So I selected to install via FTP and it installed fine (Hooray for broadband). Once the OS was up I copied all my mp3s onto \shared\music. Installed the slimserver redhat rpm and then let slimserver build the mp3 index (after telling it where to look).

All looked good until I tried playing a song. It wouldnt open anything which I tracked down via this group to be a permissions prob. So I did a chown and chgrp of the entire music directory telling it slimserver was the owner then got slimserver to redo its index from scratch. Slimserver now runs fine and is so much quicker than the NSLU2 I was running on before.

The only problems I have left is that I cant get the USB ports to work at usb 2.0 (only a prob when I do a backup) and the box doesnt shutdown when I press the power switch both could eventually be solved probably with BIOS and ACPI settings. But frankly I am not really bothered.

I have the machine running 24/7 sat on a shelf no monitor or keyboard.

2006-01-27, 06:38
Thanks for posting this. My two SB3s just arrived today and I'm almost ready. I've installed Clarkconnect Home 3.2 on my server (an inherited E-machines PC with P4 1.5GHz, 256MB of RAM, to which I have added two 250GB Samsung 5400RPM hard disks). I've downloaded the RPM and ripped a bunch of CDs to FLAC using Exact Audio Copy (many more to do though).

Being a complete Linux newbie, I'm feeling quite pleased with myself, until I look at the blank screen on the SB3. I need to figure out what Putty is as mentioned above and see if I can figure out how to install the RPM. I'm also a little concerned that my wireless router will be too far away (it's up in the attic and the SB3s will both be a level below the attic). I also won an auction at work for a Gigabit switch, which I'm picking up tonight, so I think I'll get that going first before I try installing Slimserver, just in case there is any problem with IP addresses and suchlike. I'll report back later with my progress. I don't expect it will be plain sailing, but I'm sure I'll get there in the end. I'm looking forward to 'freeing my music'!


2006-01-28, 10:09
Mission accomplished! I have two SB3s sharing the same SlimServer box with a strong WPA key and am in music heaven. I may even get the one for the living room red-wined at some stage. I'm having a big ripping session at the moment (after losing some 20 gigs of ripped disks through a poor understanding of ClarkConnect, but it could have been worse). I'm rediscovering loads of old music that had been gathering dust. Wonder if it will gather digital dust on the HDD? ;)

FWIW, I tried installing SlimServer using Putty but couldn't get it to work. I ended up using Webmin with the rpm -Uvh with the URL to the latest version of SlimServer, and bingo!

From what I can gather, the learning curve with the Squeezebox will continue for a long time as it seems to be incredibly configurable with plugins and suchlike. A great device indeed.


Patrick Dixon
2006-01-29, 02:20
Embouldened by the success and encouragement of other CC users here, I've done a test install on an old laptop.

So far so good ... a nice small image to download (378MB), painless and fast installation and very easy setup. Admin via a nice browser UI, so not much different to a router/switch. I'm very impressed.

Now I have slimserver running (with mySQL), and I'm looking at AlienBBC. Has anyone installed MPlayer on CC, and if so how did you go about it? The CC repositries don't have it (not really surprisingly as it's not usually the kind of thing you'd want on a server), and attempting to instal an rpm give a whole load of failed dependencies. It looks like CC3.21 is based on FC2 (?), so can I just add an FC2 repo to the list and apt-get install mplayer? If so which repo do I add?

Thanks in advance for any hints.

2006-01-29, 13:51
I too tried to use a mplayer rpm on CC and gave up in the end...

..got it working by downloading the source and compiling it on the server. Obvious advantage of this is that MPlayer is now optimised for my processor (Athlon).

From memory I needed to install a couple of development tools using apt-get with the standard CC Sources. Looking at my command history it looks like I used:

apt-get install gcc
apt-get install libpng-devel

Then to compile it (following instructions in the readme in the source):

make install

Took a while to compile, but worked first time!

Patrick Dixon
2006-01-30, 02:18
I did actually get an FC3 rpm to work in the end. I also installed the mplayer essential codecs package (I can't remember whether this is actually necessary for AlienBBC). The essential codecs rpm package is very fussy about the naming of the mplayer rpm, so I tried a few rpms before I found one that worked.

There may have been some mplayer dependancies that apt-get sorted out, but I arrived via a tortuous route so it's difficult to be certain what additional packages were eventually required!

The compilation route sounds straightforward and should give a 'better' mplayer - so I will give it a go. Thanks.