PDA

View Full Version : Duplicated track entries when using playlists - POSSIBLE SOLUTION



luga00
2006-01-02, 08:55
I've had the same problem that a lot of people on these boards seem to have had with M3U playlists causing double entries in the album track listings.
I've tried moving the playlist to a different directory and telling SS about it but this and other things I've tried did not work.

I did notice however that playlists created from within the SS web interface did not cause this problem and it was only when creating playlists with WMP10 that the duplicate entries occured.

The problem seems to be that WMP10 M3U entries use an explicit ip address to the server whereas the web interface entries use a local drive letter.

eg. This is from a WMP10 created playlist and causes a duplicate:
#EXTINF:0,17 God Only Knows.wma
\\192.168.1.3\Music Library\Beach Boys\The Very Best of the Beach Boys\17 God Only Knows.wma

This is the same entry from an M3U created by SS web interface that doesn't create any duplicate entries.:
#EXTINF:0,17 God Only Knows.wma
D:\Beach Boys\The Very Best of the Beach Boys\17 God Only Knows.wma

I apologise if this already a known issue but it could help some people in the interim.

Russ

Olaf
2006-02-20, 14:27
I had problems with duplicated tracks, too. When I imported new CDs, recently, the related album seemed to contain each track twice. This was not the case in former times. My actual configuration is:

SlimServer Version: 6.2.1 - 5157 - Mac OS X 10.4.5 (8H14) - DE - utf8

I had SlimServer configured to use iTunes (6.0.2 in the meantime), but also filled in an entry for the path to the music files: /Users/Shared/Daten/Musik, which is my iTunes music folder, too. I'm almost sure, I needed this entry in former times, but maybe the behaviour of SlimServer or iTunes has been changed or whatever. When I cleaned up the path to the music files and did a rescan of the music library, the double entries were gone.

Chuck Pelto
2006-02-20, 15:01
Got a playlist I've had for quite some time.

Now I'm getting reports on various songs found on this playlist that
the file cannot be found. iTunes can find and play the mp3 file just
fine.

What is the solution to this problem?

Fred
2006-02-20, 17:47
Got a playlist I've had for quite some time.

Now I'm getting reports on various songs found on this playlist that
the file cannot be found. iTunes can find and play the mp3 file just
fine.

What is the solution to this problem?

If this is an iTunes playlist, then it should get updated if the song has moved. Try a full rescan.

If it is a Slimserver playlist, then there is no way the server can find the song again if it moves. iTunes does move the song around depending on its settings when f.e. you change an album title.

In this second case, the only way is to recreate the playlist. If you use iTunes, it is simpler to manage playlists within iTunes.

Fred

Sb42
2008-01-26, 20:15
Finally the mystery has been solved! There was a shortcut in one of the Albums that pointed to My Computer, which of course included the \Music folder. The reason why it didn't seem the obvious culprit before was that it was labelled 'CD Drive' so I assumed it wasn't the problem.

Thanks for all the suggestions!