PDA

View Full Version : 6.2.2 - 5491 - Windows XP - EN - cp1252 various artists sort of works - help



Deaf Cat
2006-01-01, 13:31
Hiya,
Can't quite understand, I can't seem to find the option of labling an Album with Various Artists as Various Artists I'm sure it was there on the previous version.

Strange thing is some Albums are labled as Various Artists and others list all the Artists on the Album..?

kdf
2006-01-01, 13:40
On 1-Jan-06, at 12:31 PM, Deaf Cat wrote:

>
> Hiya,
> Can't quite understand, I can't seem to find the option of labling an
> Album with Various Artists as Various Artists I'm sure it was there on
> the previous version.
>
server settings->behaviour. the header is now "Compilations"
-k

Deaf Cat
2006-01-01, 14:40
Cheers for the reply this is what I have:

Compilations
You can choose to have compilation albums appear together under "Various Artists" or have them appear under each artist in the compilation.

Group compilation albums together

Albums that contain songs that are tagged with a band may be listed under that band name or with the other artists for that album. The band tag is also known as TPE2 and may appear as the "album artist" in some software.

List albums by band


I thought these choises would give the Various Artists lable to all Albums but it does not seem to...?
I will Rescan again - fingers crossed it won't crash again.

Well half way through re-scanning it seems to now list all the artists for all the compil albums.....I thought the options I chose made sense to list as Various....?? Please...??


****!! the thing crashed again, sorry, PC has been crashing for a week or so now (I have been thinking its was network probs just leaving it hoping it would come back)so I don't get to the machine before its started its self again, but I caught it this time its running CKDISC or something like that, I guess I need to back up a bit sharpish! incase hdd falls over Ahrrrr!

Sorry back to Compilation options....

finnie
2006-01-10, 08:05
I am also having the same issue (I think!).

My compilation albums have 'Album Artist' tag set to 'Various Artists' and the 'Artists' tag set to the individual track's artists.

No matter what I do with these behaviour settings, and how many times I rescan I get all the individual artists listed in 'Browse Artists' view.

I have tried 6.2.1 and all nightly builds since to solve this.

If I view my albums in Windows Media Player (which I use to rip) everything is as expected.

Starting to go slightly mad with this one...

Deaf Cat
2006-01-11, 14:45
Ah ha I'm glad in a way that I'm not the only one with this problem,as I was thinking my hdd was on the blink, but maybe not....

Still unclear if I'm doing something wrong or pc is having a flap..?

mattybain
2006-01-12, 02:20
I am also having the same issue (I think!).

If I view my albums in Windows Media Player (which I use to rip) everything is as expected.

Starting to go slightly mad with this one...

I am guessing from this that you rip into WMA format? If this is the case then there is a bug which seems to mean that unless the TPE2/ALBUM ARTITS tag is empty the album will be picked up both as various artists and also listed by the individual artists.

What you need to do is remove the this tag and hopefully it should start to work.

A bug has been raised but I am not particuarly hopeful about it getting fixed in the near future.

This is not ideal as if you want to use MCE or WMP to view the music library it relies on the album artist beng populated.

Deaf Cat
2006-01-13, 08:55
Ah ha that would explain the list being part and part as I am in the process in re-ripping in EAC/FLAC. Cool PC not going on the blink.
Cheers

finnie
2006-01-13, 09:16
I am guessing from this that you rip into WMA format? If this is the case then there is a bug which seems to mean that unless the TPE2/ALBUM ARTITS tag is empty the album will be picked up both as various artists and also listed by the individual artists.

What you need to do is remove the this tag and hopefully it should start to work.

A bug has been raised but I am not particuarly hopeful about it getting fixed in the near future.

This is not ideal as if you want to use MCE or WMP to view the music library it relies on the album artist beng populated.

Thanks for that info.

Are you saying that the 'Artist' tag should be set to Various Artists, and the "Album Artist" tag should be empty ?

slimpy
2006-01-13, 09:46
Are you saying that the 'Artist' tag should be set to Various Artists, and the "Album Artist" tag should be empty ?
No, set the Artist tag to the track's artist and leave Album Artist empty (or remove).
Slimserver will recognize the album as a compilation based on the different track artists within the album. This behaviour seems to be broken if the Album Artist is set.

-s.

finnie
2006-01-14, 05:45
I tried clearing the "Album Artists" tag, but that didn't help, how would I remove the tag ?

Jeff52
2006-01-14, 06:16
No, set the Artist tag to the track's artist and leave Album Artist empty (or remove).
Slimserver will recognize the album as a compilation based on the different track artists within the album. This behaviour seems to be broken if the Album Artist is set.

-s.

I have my Album Artist tagged as "Various Artists" and the albums appear in the web interface but not the player interface and I filed a bug report about it. This explains why there are no albums under Various Artists in the player interface but I am puzzled as to why they do show up correctly via the web interface.

mattybain
2006-01-14, 09:10
I tried clearing the "Album Artists" tag, but that didn't help, how would I remove the tag ?

That should have done it.

Actually now that I look at my artist listing it is displaying all my WMA various artists again so looks like something might have changed in the latest builds of 6.2.2 what version are you running?

I will investigate again and see what I can come up with.

mattybain
2006-01-14, 09:16
Actually quick thought - did you wipe the database and rescan? this will be required to pick up the various artists correctly.

finnie
2006-01-17, 01:33
Actually quick thought - did you wipe the database and rescan? this will be required to pick up the various artists correctly.

If I do as you suggested I now have artists listed as expected on my Squeezebox which is great. However the web interface now lists all artists, i.e. even artists from compilations - strange !