PDA

View Full Version : Slim server 6.0a2 crash



Philip Meyer
2005-03-06, 12:46
Should beg reports for the 6.0 alpha be posted in the discuss or developers list? I posted a problem report a couple of days ago here but there were no replies.

I have just experienced another problem.

The server had been running all day; I'd done several searches, played some albums, turned the unit into standby, and went out for an hour. I got a "SqueezeBox has lost connection to server" message shortly after pressing the power button to turn the unit "on". I think I briefly saw something like "problem with RSS feed", then the display went blank. I held down the power button to do a soft-reset, and the unit seemed to come back to life without a problem (so the slimserver must still have been alive at this point).

I did a search for artist, selected an album in the returned results, and Slim.exe crashed. I looked in the Application Event Viewer and found the following message:

Can't call method "moodlogic_mixable" on an undefined value at /PerlApp/Slim/Buttons/BrowseID3.pm line 697.

The time for the entry looks about right, but I don't know why this would be connected with trying to browse albums. I don't have moodlogic plugin enabled.

Phil

Dan Sully
2005-03-06, 12:52
* Philip Meyer shaped the electrons to say...

> Should beg reports for the 6.0 alpha be posted in the discuss or developers
> list? I posted a problem report a couple of days ago here but there were
> no replies.

Bug reports should go into bugzilla at http://bugs.slimdevices.com/

> I did a search for artist, selected an album in the returned results, and
> Slim.exe crashed. I looked in the Application Event Viewer and found the
> following message:

I've just checked in a fix for the crash to Subversion. The server will now
emit a warning for which url/file it couldn't fetch an object for. This will
hopefully let us know what in your collection it didn't like/was missing, etc.

-D
--
It is dark. You are likely to be eaten by a grue.

Philip Meyer
2005-03-06, 13:00
>Should beg reports for the 6.0 alpha be posted in the discuss or developers list?
Hmmm, that should have been "bug reports", not "beg reports"! :)

I just restarted the server, and tried to play the album again, this time searching for it through the web UI Live Search facility (fishbone skin).

The server crashed again, this time the event log entry contained the following:

Operation `""': no method found, argument in overloaded package Class::DBI::Object::Has::Been::Deleted at /PerlApp/Slim/Music/Info.pm line 1451.

Phil

Philip Meyer
2005-03-06, 13:00
>Bug reports should go into bugzilla at http://bugs.slimdevices.com/
>
I thought it would be better to discuss problems first, rather than raise official bug reports, in case the bug had already been fixed, or more information was needed, etc.

>I've just checked in a fix for the crash to Subversion. The server will now
>emit a warning for which url/file it couldn't fetch an object for. This will
>hopefully let us know what in your collection it didn't like/was missing, etc.
>
Are you indicating that there is something wrong with a particular file I am trying to play?

Something does see a bit strange in that the album I was trying to play has 11 tracks. I am now currently playing the album after browsing by artist (instead of searching). Only some of the tracks are listed (tracks 4, 6-11), but I'm sure earlier I had viewed the album with all tracks listed.

Phil

Dan Sully
2005-03-06, 13:01
* Philip Meyer shaped the electrons to say...

> I just restarted the server, and tried to play the album again, this time
> searching for it through the web UI Live Search facility (fishbone skin).
>
> The server crashed again, this time the event log entry contained the
> following:
>
> Operation `""': no method found, argument in overloaded package
> Class::DBI::Object::Has::Been::Deleted at /PerlApp/Slim/Music/Info.pm
> line 1451.

Is this with the current Subversion trunk, or the official Alpha 2 release?

Thanks.

-D
--
They're techno trousers, ex-NASA, fantastic for walkies!

Dan Sully
2005-03-06, 13:05
* Philip Meyer shaped the electrons to say...

> I thought it would be better to discuss problems first, rather than raise
> official bug reports, in case the bug had already been fixed, or more
> information was needed, etc.

Yep - that's great. We also don't want to loose unofficial reports. :)

>>I've just checked in a fix for the crash to Subversion. The server will now
>>emit a warning for which url/file it couldn't fetch an object for. This will
>>hopefully let us know what in your collection it didn't like/was missing, etc.
>>
> Are you indicating that there is something wrong with a particular file I
> am trying to play?

Yes - such as a file that has been misclassified. It's harder to tell without
much more information though - so the additional debugging I added should get us there.

> Something does see a bit strange in that the album I was trying to play has
> 11 tracks. I am now currently playing the album after browsing by artist
> (instead of searching). Only some of the tracks are listed (tracks 4,
> 6-11), but I'm sure earlier I had viewed the album with all tracks listed.

Hmm.. any sort of pattern you can see? Are you using MoodLogic or MusicMagic?

-D
--
They're techno trousers, ex-NASA, fantastic for walkies!

Philip Meyer
2005-03-06, 13:13
Hi Dan Sully <dan (AT) slimdevices (DOT) com>,

>> Operation `""': no method found, argument in overloaded package
>> Class::DBI::Object::Has::Been::Deleted at /PerlApp/Slim/Music/Info.pm
>> line 1451.
>
>Is this with the current Subversion trunk, or the official Alpha 2 release?
>
SlimServer_v2005-03-05.exe. I wasn't sure where to get the official Alpha 2 release; I just downloaded the latest.

I just had another related crash for this problem. Track 6 was playing. I was looking at the tags to see why other tracks weren't listed for the album in slimserver. I discovered that all but one track had v1 and v2 mp3 tags, and some of the genre tags of tracks were different (this was on purpose at the time, but I usually set the genre for all tracks on an album to the same now, as slimserver used to order by genre first - has this been amended in 6.0?).

So I amended the tags. I couldn't save the tags for Track 6, so I tried to change the playing track (from the WebUI). Crash:

Can't locate object method "url" via package "Class::DBI::Object::Has::Been::Deleted" at /PerlApp/Slim/Music/Info.pm line 584.

Phil

Dan Sully
2005-03-06, 13:16
* Philip Meyer shaped the electrons to say...

>>Is this with the current Subversion trunk, or the official Alpha 2 release?
>>
>SlimServer_v2005-03-05.exe. I wasn't sure where to get the official Alpha 2 release; I just downloaded the latest.

That's better for us actually - as things have changed since the alpha release, obviously.

> I just had another related crash for this problem. Track 6 was playing. I
> was looking at the tags to see why other tracks weren't listed for the
> album in slimserver. I discovered that all but one track had v1 and v2 mp3
> tags, and some of the genre tags of tracks were different (this was on
> purpose at the time, but I usually set the genre for all tracks on an album
> to the same now, as slimserver used to order by genre first - has this been
> amended in 6.0?).
>
> So I amended the tags. I couldn't save the tags for Track 6, so I tried to
> change the playing track (from the WebUI). Crash:
>
> Can't locate object method "url" via package
> "Class::DBI::Object::Has::Been::Deleted" at
> "/PerlApp/Slim/Music/Info.pm line 584.

Hmm.. did you rescan after changing the tags?

Also - the genre problem has been fixed.

-D
--
They're techno trousers, ex-NASA, fantastic for walkies!

Philip Meyer
2005-03-06, 13:21
Hi Dan Sully <dan (AT) slimdevices (DOT) com>,

>> Can't locate object method "url" via package
>> "Class::DBI::Object::Has::Been::Deleted" at
>> "/PerlApp/Slim/Music/Info.pm line 584.
>
>Hmm.. did you rescan after changing the tags?
>
No - I was going to, but it crashed before I got the chance! I was trying to change the playing track, so that I could save the change to the tag, as the file was locked ;)

>Also - the genre problem has been fixed.
Great!

Phil

Philip Meyer
2005-03-06, 13:47
>Hmm.. did you rescan after changing the tags?
>
I tried to rescan after my latest crash - after the rescan had finished, it only listed 3 tracks from the album!

I cleared the cache (does this wipe the database, or is there some cache between the DB and the server?) to perform a full rescan. Browsing the album now lists all tracks correctly. I haven't tried doing a search to find the album, as I'm actually quite enjoying listening to the album now ;)

Phil