PDA

View Full Version : Serious iTunes Volume Adjustment Problem



biomech
2005-12-26, 16:21
HELP!

Half of my 12,000+ MP3 collection sounds horrible on my new Squeezebox. When some of the songs play on my Squeezebox, the volume on the on-screen analyzer is pegged and it sounds like white noise. You can hear the song playing under the horrible white noise. I have not changed the default volume settings on the Squeezebox.

I'm testing now and all of the songs that exhibit this problem are ones that I have used iTunes’ Volume Adjustment feature to alter the volume of the individual track. If I go back into the iTunes’ Track Info dialog box and move the volume slider back to zero (no adjustment) and rescan the library in Slimserver, I still get this problem.

As a test, I took a track that sounded fine on the Squeezebox:

1) Increased the volume slightly in iTunes
2) Set the volume adjustment back to zero in iTunes
3) Rescanned my library in Slimserver
4) Played the song on the Squeezebox
5) Nearly destroyed my speakers

How can no one have noticed this problem? Please tell me there is a work around, or a way to purge this setting from my MP3s.

I am using iTunes 6.0.0.18 and SlimServer Version: 6.2.1 - 5194 - Windows XP - EN - cp1252

biomech
2005-12-27, 06:21
If I shut off Volume Adjustment on my Squeezebox the problem goes away. Sounds like this is a bug in the code that interprets iTunes volume adjustment tag.

As a side note, I learned a few things about iTunes. The volume adjustment tag is stored in the mp3 and the iTunes library (itl and xml files). I deleted all references to the volume tag in the xml file, rebuilt the itl library file, and the volume tags reappeared. During the rebuild, iTunes scanned the mp3s and picked up the missing volume information from the individual mp3s.

I wish I new how to purge this tag from the mp3 files.

Michaelwagner
2005-12-27, 20:06
Be very careful about how you remove the tags. I seem to recall there's a problem with iTunes and those tags. If you try to "undo" them the wrong way, you lose the data and can't go back.

I'll try to see if I can find the thread, but I wanted to get this in here now ...

Michaelwagner
2005-12-27, 20:23
Some resources:
http://wiki.slimdevices.com/index.cgi?AutomaticVolumeAdjustment

http://forums.slimdevices.com/showthread.php?t=17468&highlight=itunes+volume+adjustment

http://forums.slimdevices.com/showthread.php?t=17902&highlight=itunes+volume+adjustment

I'm sorry, I can't seem to find the place where they described how to remove the tags, but I think you need to remove them with itunes if they were put in with itunes, not just remove them with a tag stripper. But that's from memory, and I don't actually use replaygain, so it's not on the top of my must_remember list.