PDA

View Full Version : Can you create accounts that cannot change server settings?



mangotbg
2005-12-21, 19:14
I'd like to be able to allow my friend access my stream, but I don't want him to be able to have access to change settings. Is this at all possible? I've set up a password, so he has to enter the username/password just to listen, but if he were to try and access the address minus the "/stream.mp3" then he'd have control over all the settigns...(i.e. changing the password and what not)..


For those of you that saw my first post/thread, I finally got things working. It was INFACT F-Secure Internet Security 2006 that was causing my problems (where only the host PC could access the SlimServer). Even though I uninstalled the firewall it kept entries in the registry that were blocking almost all connectivity.

I love SlimServer! I'm here in New Orleans and I have access to the thousands of mp3s I have back in Tampa! It's great! As soon as I move into a larger home (i.e. not the one bedroom I'm in) and I'll have the need for a Squeezebox!

MrC
2005-12-21, 20:46
Install and configure the NoSetup plugin, and configure the IPs you want to allow access to the server settings.

http://wiki.slimdevices.com/index.cgi?PluginServerUtilities

mangotbg
2005-12-21, 20:48
Thanks for such a quick response, do I have to be on the host pc to install that or can I do it via the web interface?

MrC
2005-12-21, 20:51
You have to get the file into the Plugins directory. The web interface does not support upload capability, so you either have to be on the host PC, or use some other file transfer mechanism (ftp, scp).

mangotbg
2005-12-21, 20:54
Actually, when I click te link for nosetup it gives me this msg:

"
Es wurde kein Artikel gefunden!"

Which according to Google Translate means

No Item found! Anyone know where else to get this plugin?

mangotbg
2005-12-21, 20:55
Damn, you guys with the quick responses. I've been nothing but impressed with this community!

MrC
2005-12-21, 21:55
I've updated the wiki. You can also reach the plugin via:

http://www.herger.net/slim-plugins/detail.php?nr=428&kategorie=slim-plugins

mherger
2005-12-22, 00:22
> "Es wurde kein Artikel gefunden!"
> Which according to Google Translate means
>
> No Item found! Anyone know where else to get this plugin?

Google translated fine. There seems to be a power failure(!) at my
hosters' right now :-(. Did you get the plugin? I could send you a copy to
your mail. Just contact me by pm: michael at herger dot net.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

mherger
2005-12-22, 00:25
> I've updated the wiki. You can also reach the plugin via:

Was the link in the wiki broken?

> http://www.herger.net/slim-plugins/detail.php?nr=428

Uff! It's back again... My hoster suffered from a city-wide power failure
in Zurich!

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

MrC
2005-12-22, 12:34
Hello Michael,

This was the link that previously pointing to NoSetup in the plugins wiki:

http://www.herger.net/slim/detail.php?nr=390

I changed it to:

http://www.herger.net/slim-plugins/detail.php?nr=428&kategorie=slim-plugins

mherger
2005-12-23, 00:12
> http://www.herger.net/slim/detail.php?nr=390
> http://www.herger.net/slim-plugins/detail.php?nr=428&kategorie=slim-plugins

Thanks! As you can see I re-organized the site a while back, gave the
plugins their own folder. Didn't update all links, though... Thanks for
fixing this. I'll have to check the others, too.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

mangotbg
2005-12-23, 00:51
I just want to reiterate that you guys F#%*ING ROCK!

Here's a little update blurb about my status:

So just before I left for New Orleans, I did a clean reinstall of windows on my home machine. Installed slimserver, and the other computers on my network worked like a charm. I set up a password, forwarded the two ports 9000 3848(whatever that other one is). I logged into my neighbor's wireless and I had access! Sweet!

Fast forward to the last day or so, and I've been enjoying my mp3 colletion from my mother's place! Double sweet! I call up my brother and try to get him to access my stream from iTunes just by giving him the http:xxxxxxxxxx:9000/stream.mp3 link and telling him the password and whatnot. It was a "no-go". He was in a rush because he's coming up to visit, as well, so I didn't get time to troube shoot.

Me being the troubleshooter that I am, I get on the phone with a friend of mine back in Florida and give him the same info and work from there. He's telling me the same thing.

I then began undoing all of the security items to figure out why he couldn't even access the slimserver homepage (with no password).

I don't know if it was me lessening the security levels, dumbluck or just that he was typing things incorrectly (he's an AOL user, so not the PC guru like myself or you ;)) but we finally get him onto the slimserver website.

After an hour on the phone with my friend I finally have him jamming to my tunes. Righteous! I also figured out the whole player settings concept. I guess that's why they couldn't hear anything in itunes when I was giving them the http:xxxxxxxxxx:9000/stream.mp3 link. I just assumed that it was ONE stream, so when I had my playlist and was listening to it through SoftSqueeze and they were telling me they heard nothing, it was baffling me. I noticed the dropbox w/my IP address, click and see his IP dropped a couple songs in the playlist and everything was gravy!

So what the hell is the moral of this story? RTFM (Read the #@*@ing manual)! I still haven't looked through the wiki, but I'm betting this is explained in it. I'll have to save that for tomorrow, I'm tired now.

I'll be honest this post might not read well...I've had a bit to drink and it's late late late. Not to mention I've gone back and added paragraphs and what-not to explain things. Anyways, you guys are great! Thanks!

mangotbg
2005-12-23, 00:53
Just to prove how F*ed up I am, I just realized I already told you guys, in this original post, that things were working...way to waste another 15 minutes of my time! Oh well!