View Full Version : My SB3 will not connect to my wireless network.

2005-12-11, 09:33

Having real problems here.

Got squeezebox just over 2 weeks ago. Took me 3 hours to get it to connect to my wireless network

In the end the thing that worked was to update the firmware in my D Link G604T wireless ADSL router to the latest firmware from the Dlink website (V1.00B02T02.UK.20050815)

The SB3 worked fine until i brought a wireless laptop home from the office.

It seems by DHCP server assigned the wireless laptop the IP address that the SB3 had been previously using.

Now i simply cannot get the SB3 to connect.

I have done a factory reset on the SB3, then i go through the setup networking.

It finds my network SSID and reports signal strenth of +80%.

However it simply cannot get an IP address from the router and just keeps counting down from 20 to give the "unable to connect to wireless network".

All my other wireless devices connect 1st time every time.

Am seriously thinking of sending this back - especially given all the worrying similar posts on these forums.

Can anyone help?

My other settings for information are;

Security WEP 64 bit
SSID enabled
DHCP automatic.
Windows XP on main pc where slimserver sits
Kerio Personal Firewall (turned off whilst using SB3)


Frustrated in the UK - Geoggy.

2005-12-11, 09:51
Have you tried giving it a set ip address instead of using dhcp to see if that fixes it?


2005-12-11, 09:59
Give your SB a static IP and call it a day.

If the scenario is as you've described it, the DHCP server implementation in your DLink is not doing the right thing. The dynamic address previously in use by your SB should have been remembered and not given out to your laptop. The laptop should have been given another IP.

There are a couple of DHCP problems with SB as well, and are reported in slim's bug database.

2005-12-11, 10:02
where can i give it a static address? i cant see where this is in the menu.

the sb3 was switched off when the dhcp assigned the ip to the laptop - so i dont see why it shouldnt assign the next available ip address regardless of whether it has previously assigned it to a piece of kit last week or last year.

i think the dhcp is faulty in sb3 firmware 28.

2005-12-11, 10:18
When you do the network setup on the SB3, it gives you the option of getting an ip via DHCP, you want to say no and assign one yourself.

2005-12-11, 10:26
When you do the network setup on the SB3, it gives you the option of getting an ip via DHCP, you want to say no and assign one yourself.

not on my box.


set up networking >
connect to a wired / wireless network >
choose region >
choose network ssid >
choose encryption >
enter wep key >

"connecting to network"

i dont get asked anywhere in the set up if i want to assign a static ip

2005-12-11, 10:32
Right - the DHCP is the next step _after_ "connecting to network". If it's not getting past "connecting" then DHCP/IP addrs are not the issue. Try disabling WEP for a test.

2005-12-11, 10:47
ok - wep disabled.

no security option selected on sb3

still wont connect.

2005-12-11, 10:48
the sb3 was switched off when the dhcp assigned the ip to the laptop - so i dont see why it shouldnt assign the next available ip address regardless of whether it has previously assigned it to a piece of kit last week or last year.

That's because you don't understand DHCP. DHCP servers maintain a list of previously allocated IP addresses paired with MAC addresses, so that as much as possible, assignments may remain fairly static.

As Radish has pointed out, you are no longer establishing a wireless connection to your AP. That needs to be solved before you get to the DHCP allocation.

2005-12-11, 10:56
That's because you don't understand DHCP.
hey give me a break im a bean counter not a wireless engineer! ;o)

right, ive reset factory defaults on both router and sb3.

no security.

the sb3 sees the ssid of the network, but still wont connect. my wireless card in my main pc connected back to my router immediately, so i know the router is working 100%

2005-12-11, 11:24
This is exactly the same problem that I was having with my SB2. However, as others have pointed out, this is nothing to do with DHCP, this is the wireless connection itself. You will find that this problem is not fundamentally with the squeezebox itself but actually with the Dlink G604T router. I understand that all the other devices will connect to the router and that the squeezebox will not (this was the same situation with me) but you should find that if you try pretty much any other wireless access point (and do if you can) with the squeezebox, everything works smoothly.
I now only use my Dlink as a router and use a separate wireless access point and this works fine.

There is however a workaround to the dlink router.
1. Turn off the dlink
2. Hold the power button on the SB remote until the unit restarts.
3. Go to the view current settings menu
4. Scroll to wireless signal strength. It should be at 0%
5. Turn off all other wireless devices (laptops, PDA's etc).
6. Turn on the dlink
7. Watch the screen on the squeezebox
8. As soon as the signal strength rises above 0%, scroll left to the main menu and connect to slimserver or squeezenetwork IMMEDIATELY.
9. If you are lucky (about 1 in 2 times), instead of displaying the dreaded 'connecting to wireless network' text, it should say 'connecting to squeezenetwork/slimserver'
10. If this does not work the first time, try it at least two more times but if that fails then your problem may be different.

You may also find that the wireless signal strength tends to jump from 70 or 80% suddenly down to 0% then back up again after a short while.

Hope this was of some help- I would certainly consider searching around for another wireless access point.

2005-12-11, 12:27
jonathan - thanks for your post mate.

i must be doing someting wrong

i followed your instructions to the letter up to point 8.

the signal strength jumped from 0 to 60 i then hit left on the remote and i cant get to the main menu - i only have 2 options on the farthest left menu

"network setup"


"view current settings"

i cant go anywhere else from here at all??

2005-12-11, 12:48
Hi Geoggy
Like I said, I run an SB2 and not an SB3. In fact, I have never used an SB3. This suggests that the menu's are different on the SB3. However, it will be worth hearing somebody else's view on this as this may not be the case.
The only other thing I would try is the network setup screen and scroll through the wireless connection setup in there after reaching step 8 in the procedure I posted.
Sorry I cannot offer any further help for the moment.
I really would also recommend that you borrow/try/buy another wireless access point as I strongly suspect that this is the source of the problem.
As for WEP- I would run it at 128bit if I were you(unrelated to the SB issue but just for more security).
Also, check that MAC filtering is disabled in the Dlink web interface. Whether the wireless is encrypted or not seems to have no effect on this connection problem.
Finally, it is important that you set the authentication type to 'shared' (as opposed to 'open' or 'both' in the web interface.
After checking all these settings, try my method again. If you are still not getting the squeezenetwork or slimserver options, we'll have to wait until somebody else posts to confirm whether the menu's are different.

2005-12-11, 13:24
dont ask me why because i tried this earlier and it didnt work - but i just swapped wep out for wpa.

tried sb3 and it connected - got an ip address no problems, connected to slimserver no problems and its working again.

dont know whether to feel relieved or not - i not going to spend hours and hours every couple of weeks when it decides to stop working for no reason!

2005-12-11, 15:04
In fact, you may be even more relieved to know that WPA is infinitely more secure than any form of WEP anyway.
Interestingly, using a wireless laptop and a couple of handy linux tools, I have cracked my own home wireless network 128 bit WEP encryption just to prove to myself how unsecure it is so you are definitely better off with WPA.
Glad that you have it working.
Let me know if you have further difficulties.

2005-12-11, 19:21
I had similar problems as you and was ready to hurl the squeezebox out the window. The issue was that I had another application I use for accessing my office network also running on port 9000. Although I disabled that application (Checkpoint VPN SecureClient), I still could not connect to the slimserver until I went into my wireless connections dialog box and unchecked the application. Once I did that, I was okay. Changing the port in Slimserver didn't help. YOu might want to check and see what applications are in your toolbar/startup and then check and see what applications are set up to run on your wireless connections (go into the properties dialog box of you wireless connections, general tab).

2005-12-12, 01:06
regardless of whether two devices are trying to use the same port or not, this should not prevent either device from connecting to the wireless network. Remember, until you have connected, you haven't even been issued an IP address by the router and so TCP traffic doesnt even exist at that stage.
I think this is a different problem related entirely to this access point.
Thanks for the info though