PDA

View Full Version : Can't get Slimserver started



aquifer
2005-12-10, 11:44
Hi. I'm considering buying a Squeezebox and, as many reviewers advised, downloaded the latest Slimserver version so I could see how it works and if I like it.

Anyway, I downloaded, installed, have tried to run it and all I get is an Internet Explorer page saying "Cannot find server" (it's trying to load http://localhost:9000). The Windows firewall is configured to let Slimserver access port 9000, for whatever that's worth.

Maybe I'm being extra dense today, but I can't find any documentation either on the Slim Devices site or downloaded with the software that tells me what I'm supposed to do next. The FAQs also don't seem to address this problem either. So I'm completely out of ideas.

Any suggestions? By the way, I'm running Windows XP SP2.

bpa
2005-12-10, 12:06
Do you have a small icon in the system tray that looks like a small Squeezebox 3 ?

If you see the icon - right click and try to start slimserver. If the icon in the system tray changes to have some blue then slimserver is running and try to access Slimserver using browser.
http://localhost:9000

If no blue writing appears in the systrat icon then open a dos box, cd to the directory containing slim.exe and run slim.exe from the command line. If there are error starting slimserver they will be posted to the screen.

aquifer
2005-12-10, 13:44
Thanks. Blue does appear when I right-click on the SlimServer icon and tell it to start -- but again, all I get is that Internet Explorer page telling me it can't find anything.

When I try running slim.exe from the command line, it just hangs up. I don't get an error message, but nothing else happens either.

bpa
2005-12-10, 18:43
That all sounds like slimserver is running ok - so the problem is with browser and port 9000.

Localhost should be in your system's hosts file. It's possible this entry is removed/disabled - try http://127.0.0.1:9000 in the browser - this is equivalent to localhost but using ip address.

aquifer
2005-12-10, 20:44
I get the same response (and, amusingly enough, the SoftSqueeze display says "Now Playing: NOTHING").

Is this possibly an antivirus issue? As I said, the Windows firewall says it's allowing SlimServer to access port 9000, but I have no idea if the antivirus program (Sophos) would be blocking it. (Sophos doesn't seem to do anything but scan for viruses, but I could be wrong about that.) Unfortunately, I don't have administrative privileges on this computer, I can turn the virus program off.

bpa
2005-12-11, 01:44
I think if Softsqueeze says "Now Playing - Nothing" then Slimserver is running. Did you define the music directory as part of the installation - if so check if Softsqueeze can go through your music.

The "Cannot find server" message is odd in that this is not typical if access to the port is blocked or there is nothing. However the message does not seem to be from slimserver.

What browser are you using ?

Do you have other software running that could be using port 9000 ?

aquifer
2005-12-11, 05:56
Hey -- I think I fixed it. I replaced "localhost" with "192.168.2.100", and now I'm in. Isn't that a little strange?

This is a work computer, so I'm not sure why all the settings are the way they are. But now I can play with it at least. It does look like a cool program.

If anyone from Slim Devices is reading this, it probably would help to have something in the FAQs addressing this sort of problem. I noticed similar questions posted on this forum, though nothing quite like my situation.

Anyway, thanks.

sunny
2005-12-11, 15:08
I had the same problem getting explorer to access that "localhost" page and I was going crazy. The responses to this thread helped me troubleshoot it. THANKS! Turns out my computer is set up to access my office from home, and I have "SecureClient" running in my toolbar. This uses the same port 9000. When I disabled this software, I had no more problems. I think if you have one of these VPN tunnel programs, you should NOT have it in your startup files to run automatically or remember to disable it when running slimserver.