View Full Version : Brand new SB3 and a Netgear DG834G

2005-12-07, 08:27
Hi all,

I've just received an SB3 in the post, but I am having terrible
trouble making it work with my Netgear DG834G Wireless Router.

First off, I connected the SB3 via ethernet, and upgraded the firmware to version 28. I believe this is the latest, right?

My router (running firmware 1.05.00 - also the latest I believe)
is configured to use WPA-PSK with a 23 character long key (upper
and lower case letters, no spaces), and a SSID of "PINKNOISE".

In testing in my study, if I disable the security on the WiFi, it connects just fine. If I reenable the security, it refuses to connect. I've reentered the password several times, and tried both WPA-Personal and WPA2-Personal on the squeezebox, and had no luck.

I understand from other postings I've read on here that the
Netgear's WPA-PSK option uses TKIP, not AES, so this should be
OK, right?

Getting that sorted is problem 1.

Problem 2 is that I do not appear to get a WiFi signal at all
in the place I want to put the SB3, even with the WiFi security
disabled. My laptop in the same place reports a 50% signal
strength. Has the squeezebox got a crap antenna or something?

Any hints people can give would be greatly appreciated; even just
knowing that there are people out there with this setup for whom
it does work would help!



John C
2005-12-07, 11:53
I got an SB3 a couple of weeks ago and have the same setup as you.
I have a Netgear DG834G (firmware version 1.05.00) using WPA security. I can post some of the settings if it will help, although I didn't do any manual configuration - the SB3 configured itself after I typed the WPA key.

2005-12-07, 17:18
Reentering the SSID and Username on both router and squeezebox
appears to have made it work - annoying, because I had to do it
several times before it worked.

But it connects to the wifi network now - just not in the kitchen
where I need it to :-(

Is it just me or is the SB3's wifi reception shockingly poor?
I'm really very annoyed I bought the WiFi version now...


2005-12-08, 13:54
I had similar problems,I use a DG834G with WPA personal.
Its really important not to leave any spaces in the password before the > arrow when entering the WPA password.
Mine is working fine plus slimserver on Mac Mini.