PDA

View Full Version : Unicode (Greek) in SB-G?



_NK_
2005-12-06, 03:24
Hello everyone,

I need to ask whether SB-G supports Greek characters on the display like SB2/SB3.

I own an SB2(living room) & I have an SB-G in the bedroom. Win XP, SServer 6.2.1. The SB2 displays the greek characters correctly while the SB-G shows "????????" where the greek characters are supposed to be. Hmm..I guess you could definitely say that greek seems to be all greek to SB-G ;)

I tried Bob's wonderful tool (TTftoSBG) and I produced some custom bmp fonts derived from ArialMs Unicode truetype font (with greek for the higher ascii range) and although evrything seems like it *should work*..it does not.

Does it have to do with "Slim::Hardware::VFD::setCustomChar()"?

Isthere something else there I should change?

Any feedback is more than welcome

Nikos

_NK_
2005-12-07, 02:44
C'mon guys..give me some pointers plz.
Is there any reason why an SB-G can not display non-english (greek in particular)characters?
My gut-feeling is that it can..but what's the culprit?

TIA

Nikos

Dan Sully
2005-12-07, 09:34
* _NK_ shaped the electrons to say...

>C'mon guys..give me some pointers plz.
>Is there any reason why an SB-G can not display non-english (greek in
>particular)characters?
>My gut-feeling is that it can..but what's the culprit?

It cannot - only SB2/SB3 can.

Sorry.

-D
--
"Hey, careful, man, there's a beverage here!"

_NK_
2005-12-08, 03:27
Hm, sorry to hear that.

Thanks for your feedback Dan & thanks for helping make such a good product

Nikos