PDA

View Full Version : SB3 won't connect to SlimServer over wireless network when WPA/TKIP encryption is on



benthos
2005-12-05, 18:01
Hi all,

This is a continuation of an earlier thread ("Also can't connect to SlimServer"). My problem is this: I can get the SB3 to connect to the SlimServer over my wireless network, but *only* if I turn off the wireless encryption and make the network open. I can get the SlimServer web interface to load o.k., and when the encryption is on, the SB3 will connect to the wireless network o.k. - it just won't connect to the SlimServer. I am using the latest, 6.5 nightly version of SlimServer. I have tried switching to ordinary WEP, but I seem to be having some unrelated problems with Windows, so I haven't been able to see if that works. Here's my other info:

Router (& dsl modem): Actiontec gt701-wg (see http://www.qwest.com/internethelp/modems/gt701/index.html)

Router firmware version: (not sure - it's the latest version, I just reinstalled it)

Router firewall: off (Windows firewall contains the 3 SB3 exceptions, per the manual - I think the SlimServer installation did this).

Wireless speed: mixed B and G.

Encryption type: WPA/TKIP, with a simple, 8 letter password

My computer's IP address (where SlimServer is installed) is 192.168.0.4, and again, the SB3 can connect to it, but only when encryption is off.

The IP address that the SB3 brings up via DHCP is 169.254.213.199. I guess this is the router address?

Anyone have any ideas? Nothing has worked yet.

Thanks

Chris in Santa Fe

snarlydwarf
2005-12-05, 18:11
Are you sure you're entering the key in the SB correctly? Extra spaces at the end are 'invisible' and easy to miss. (Use 'play' to delete extra characters.)

I use WPA/TKIP.

slimCL
2005-12-05, 21:19
The IP address that the SB3 brings up via DHCP is 169.254.213.199. I guess this is the router address?


I can't help you out on the wireless, but the 169.254.*.* network is used for auto-configuration. When a user device (PC, SB3, etc.) can't obtain a DHCP address, the networking chip inside the device pseudo-randomly assigns itself an address in the 169.254 network. In some networks, you can let the devices autoconfigure, but then you would have to know how to configure your router to work with the devices with 169.254 addresses. But, this is not something you would do at home.

Bottom line - figure out why your SB3 can't get an address from the DHCP server. When the SB3 can get a DHCP address, the 169.254 address will go away.

benthos
2005-12-07, 21:39
I was browsing around in some of the other forums here, and saw a recommendation that I use up all 13 characters in the WPA/TKIP password. I did so and, voila, wireless encryption now works and I can connect to the SlimServer! Also, it looks like the DHCP is working, it's pulling up a different IP address - 192.168.0.5. I am psyched! Thanks for the help.

slimCL
2005-12-08, 20:24
Good news. I hope to move from WEP to WPA this weekend now that my laptop supports WPA.