PDA

View Full Version : 2 Artists w/ same Album name - confused?



mikes
2005-11-21, 20:56
Since this is my first post, I must first say what a great product and company! I have been a very happy SB2 owner since August. I also want to thank the entire community. I have been able to find answers to all my questions on this forum.

After upgrading to 6.2.1 from 6.1.1, I have come across a strange problem which I am guessing is related to the changes for Various Artists. I have searched and was surprised that nobody had come across this problem before me, so I decided I should post a message before logging a bug just in case I am missing something obvious.

Essentially when there are 2 albums with the same tag with different artist tags, they are showing up combined as though they are one album. I actually have 2 examples in my collection.

Bela Fleck / Places
Brad Mehldau / Places

Bill Evans / The Last Waltz
The Band / The Last Waltz

They each show up combined when you select the album regardless of how you browse or search for it. All of my music is stored in the pretty standard artist/album directory structure. I think I have tried every combination of settings on the behavior tab along with setting and removing the AlbumArtist tag. They each have a unique AlbumSort tag as I like my albums sorted by artist/year/album. The only solution I have come up with is to give them each a unique album tag. Not the ideal solution, but it does work.

I understand there is no easy answer here as somebody else may actually see this as a desirable behavior as they may not keep their music well organized in folders and this may indeed be the same album with multiple artists. Maybe there could be a preference for those of us that want to enforce that songs from the same album are always in the same directory to avoid this situation.

Additional specifics about my setup:
SlimServer Version: 6.2.1 - 5194 - Windows XP - EN - cp1252

My music is all FLAC stored on local drive on a dedicated SlimServer and I sync from MMM running on the same machine.

Of the 750+ CD's that I have ripped thus far, I do have 2 actual various artist albums that are showing up correctly.

Everything is tagged with ArtistSort and AlbumSort tags in addition to the typical tags. At the moment, the 4 albums above are the only ones that have AlbumArtist tags so they are not mixed in with the Various Artist also.


Please let me know if I can provide any additional information or try anything else that may help understand what is happening here.

Thanks,
--mike

radish
2005-11-21, 21:03
Two options:

1) As you say, make the album name unique. Not ideal.
2) Add the album names to the "Common Album Titles" list on Server Settings/Behavior. That tells slimserver that for those album titles, it should also take the artist name into account. Should fix the problem.

mikes
2005-11-22, 12:38
Thanks for the second suggestion radish.

For anyone else, after changing the common album titles, I had to clear my library and rescan everything to see the change.