View Full Version : Slim Server WILL NOT START help please!

2005-11-21, 01:34
Sorry for the CAPS (frustration showing). I installed SS 6.2.1 on 3 machines, 2 laptops and a desktop. It works fine on the two laptops, but the desktop is the one I want to use as a server. (I also tried this with SS 6.2, 6.1 and 5.something - same result with all of them).

I'm running Windows XP on all machines with all the patches. They also have Zone Alarm (free) and McAfee Anti-virus.

The installation proceeds normally, but at the end I don't get the cue from the firewall that Slim Server wants to act as a server. I got this cue on the other two machines.

When I look at the tray icon the server is stopped. When I try to start slimserver via the tray icon it just says "starting" forever.

If I go to the services viewer the service is listed as stopped, if I try to manually start it I get an error box telling me "The SlimServer service on Local Computer started then stopped. Some services stop automatically if they have no work to do, for example the Performance Logs and Alert service."

If I use the command line and type "slim.exe" it tells me slim server is already running.
If I type "slim.exe -remove" It tells me "slim server removed".
If I then type "slim.exe" it tells me "slim server is already running".

I've tried removing and reinstalling with both the firewall and anti-virus turned off. I've removed it, deleted the folder in Program Files and gone through the registry deleting every left over Slim Server key. Then reinstalled. No dice.

I've tried shutting down all the other services running (that windows will let me shut down) and tried to retart SS, no dice.

The event viewer gives me the following error:

Application Error
Category (100)
Event ID 1000

Faulting application slim.exe, version, faulting module unknown, version, fault address 0x0012e838.

0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 73 6c 69 ure sli
0018: 6d 2e 65 78 65 20 30 2e m.exe 0.
0020: 30 2e 30 2e 30 20 69 6e 0.0.0 in
0028: 20 75 6e 6b 6e 6f 77 6e unknown
0030: 20 30 2e 30 2e 30 2e 30
0038: 20 61 74 20 6f 66 66 73 at offs
0040: 65 74 20 30 30 31 32 65 et 0012e
0048: 38 33 38 838

The error file that is generated when I reboot is:

<?xml version="1.0" encoding="UTF-16"?>
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\flac.exe" SIZE="217088" CHECKSUM="0xEB9F6A0F" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="09/29/2004 04:26:49" UPTO_LINK_DATE="09/29/2004 04:26:49" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\mac.exe" SIZE="71680" CHECKSUM="0xD3542C4" BIN_FILE_VERSION="" BIN_PRODUCT_VERSION="" PRODUCT_VERSION="3.99" FILE_DESCRIPTION="Monkey's Audio Console Front-End" COMPANY_NAME="Matthew T. Ashland" PRODUCT_NAME="Monkey's Audio" FILE_VERSION="3.99" ORIGINAL_FILENAME="MAC.exe" INTERNAL_NAME="MAC" LEGAL_COPYRIGHT="Copyright © 2000-2004" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="" UPTO_BIN_PRODUCT_VERSION="" LINK_DATE="07/09/2004 16:58:21" UPTO_LINK_DATE="07/09/2004 16:58:21" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\mov123.exe" SIZE="45056" CHECKSUM="0x16D515F0" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="06/16/2004 05:20:59" UPTO_LINK_DATE="06/16/2004 05:20:59" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\mppdec.exe" SIZE="78848" CHECKSUM="0x41DBC625" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="03/10/2004 19:12:49" UPTO_LINK_DATE="03/10/2004 19:12:49" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\oggdec.exe" SIZE="192512" CHECKSUM="0xD1C3638B" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="10/14/2004 23:38:10" UPTO_LINK_DATE="10/14/2004 23:38:10" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\socketwrapper.exe" SIZE="53248" CHECKSUM="0xF3D653C8" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="02/25/2005 23:37:21" UPTO_LINK_DATE="02/25/2005 23:37:21" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\sox.exe" SIZE="1726642" CHECKSUM="0x6C85B539" MODULE_TYPE="WIN32" PE_CHECKSUM="0x1AF1A2" LINKER_VERSION="0x10000" LINK_DATE="03/22/2005 08:57:58" UPTO_LINK_DATE="03/22/2005 08:57:58" />
<MATCHING_FILE NAME="Bin\MSWin32-x86-multi-thread\wmadec.exe" SIZE="57344" CHECKSUM="0x15EB78D5" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="03/14/2005 16:37:12" UPTO_LINK_DATE="03/14/2005 16:37:12" />
<MATCHING_FILE NAME="kernel32.dll" SIZE="983552" CHECKSUM="0x4CE79457" BIN_FILE_VERSION="5.1.2600.2180" BIN_PRODUCT_VERSION="5.1.2600.2180" PRODUCT_VERSION="5.1.2600.2180" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFF848" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.2180" UPTO_BIN_PRODUCT_VERSION="5.1.2600.2180" LINK_DATE="08/04/2004 07:56:36" UPTO_LINK_DATE="08/04/2004 07:56:36" VER_LANGUAGE="English (United States) [0x409]" />

I just got my Squeezebox in the mail and want to set it up, please anyone help!

2005-11-21, 01:40
The installation proceeds normally, but at the end I don't get the cue from the firewall that Slim Server wants to act as a server. I got this cue on the other two machines.

Sounds like its blocked. Go into the ZoneAlarm settings and make sure it is ticked to allow. Or delete it from there and run Slimserver again and it should prompt.

Also make sure you are not running Windows Firewall (with SP2 you might be) by checking the WIndows Firewall from control panel.


2005-11-21, 14:19
Slim Server is not listed in Zone Alarm's list of programs.
The server isn't starting so Zone Alarm doesn't see it.
Windows Firewall is disabled.

There has to be a conflict with another service or a hardware problem, but I have no idea how to trace it. I really don't want to do a clean install but am afraid I may have to.

2005-11-21, 14:31
Yes, but on the other hand you could do the clean install and still have the problem if it's something else. Still, always good to refresh Windows every few months.

ZoneAlarm even when disabled still does some things - before I had my router (now no need for firewall) I used to use ZoneAlarm but suddenly it got rubbish. I once had a firewall issue and disabled ZoneAlarm from starting. But only when removing it did the issue resolve. When you uninstall it make sure Windows Firewall hasn't "intelligently" enabled itself.

First thing I'd say is uninstall ZoneAlarm so we rule it out completely. Obviously disconnect from internet if you don't have a router, and when you do connect to internet to post here or whatever enable Windows Firewall for a while if you feel insecure and have no router.

Then uninstall Slimserver - delte folder if it's still there after uninstall.

Install Slimserver but do not choose the option to run as service - try and get it working first. Do NOT install beta/nightly version - only the 6.2 stable release.

Open up a command prompt and run Slim.exe from there, so you can see exactly what happens and post that here.

2005-11-21, 14:52

I'll try your suggestions. Weird that it would install fine on other machines running the same versions of Zone alarm.

I've reinstalled and unchecked "Automatically start" but when I go to the command line to start I'm told there is a copy already running.

I used the -diag flag and got this response.

"Odd number of elements in anonymous hash at /PerlApp/Slim/Web/Setup.pm line 2329."
"Use of uninitialized value in anonymous hash ({}) at /PerlApp/Slim/Web/Setup.pm line 2329"
"Problem: There is already another copy of the SlimServer running on this machine. (Unknown error)"

2005-11-21, 15:07
Right, it seems your Services are a bit confused.

Uninstall again.

Go into Admin Tools - Services and I BET you can see the entry for slimsvc still there. Maybe the problem has been it's trying to start up twice or other strange things. You can uninstall the service using Slim but let's not do that and ensure everything is gone - keep it uninstalled, delete C:\Program Files\Slim* and follow on....

Now there's probably a better way to do this, but here's how I delete it and this is a soon-to-be-reinstalled system at this stage anyway:

Start up regedit.

Locate the entry in the tree My Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\S ervices

You should see a slimsvc. Delete it.

Check if you have a Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\ etc... and do the same.

Just to be thorough delete this (if there)....

My Computer\HKEY_CURRENT_USER\Software\SlimServer

Reboot. Look again in Services - the slim stuff shouldn't be there.

Now go and install Slim again as I advised earlier, unchecking the option to start as service.

2005-11-21, 15:41
OK, Did the manual uninstall. Deleted all the files and keys. Uninstalled Zone Alarm. Checked in Security to ensure Windows Firewall was off.

Re-booted and reinstaleld SlimServer. Selected default paths and unchecked Start Automatically. At the end of the installation it STILL tried to start up automatically and failed to start. It STILL put the Slim Tray icon in the Startup folder.
I deleted the Slim Tray icon and rebooted and the service STILL tried to start by itself. And failed. It's not obeying when I make selections in the install routine, what's THAT mean?

2005-11-21, 19:12
Remove the Slimserver Tray Tool shortcut from your Startup items in your Start menu.

2005-11-22, 12:56
Rinse & repeat.

And just to make sure install it in a completely different folder.