PDA

View Full Version : Please tell me how to connect with Airport!



raphaeladidas
2005-11-18, 19:37
I am trying to connect a Squeezebox directly to a Mac with an Airport card (ie, no hub, router, whatever). Nothing seems to work. I guess where I am really stuck is when I make the connection and I am asked to "select a music source." The player wants me to "Specify an IP address for your SlimServer" and it seems like I don't really know what to enter because I can never get connected. I'm not an idiot but pretend I am, take me by the hand and tell me step by step what I need to do. This includes any settings I might need to make in Network and Sharing.

dean
2005-11-19, 11:51
You'll need to set your Airport to "Create network..." and then give
it a network name, then when you set up the player, choose that network.

Of course, you'll also need the slimserver software installed on your
computer and running and at that point the Squeezebox should be able
to find your server automatically by name.

raphaeladidas
2005-11-19, 18:39
You'll need to set your Airport to "Create network..." and then give
it a network name, then when you set up the player, choose that network.

Of course, you'll also need the slimserver software installed on your
computer and running and at that point the Squeezebox should be able
to find your server automatically by name.

I've followed these steps over and over again (before and after posting) and it always asks me to specify an IP address (as mentioned in the first post). What IP address is it looking for?

ceejay
2005-11-20, 00:59
I've followed these steps over and over again (before and after posting) and it always asks me to specify an IP address (as mentioned in the first post). What IP address is it looking for?

Since you don't have a DHCP server on your mini-network, I guess its asking for an IP address to give to the SB. Give it one similar to but different from the IP address of your Mac/Airport. So if that is 192.168.0.1, for example, your SB2 could be 192.168.0.2

Ceejay

raphaeladidas
2005-11-20, 08:31
Since you don't have a DHCP server on your mini-network, I guess its asking for an IP address to give to the SB. Give it one similar to but different from the IP address of your Mac/Airport. So if that is 192.168.0.1, for example, your SB2 could be 192.168.0.2

Ceejay

This didn't work either.

dean
2005-11-20, 22:34
On Nov 19, 2005, at 5:39 PM, raphaeladidas wrote:
> I've followed these steps over and over again (before and after
> posting) and it always asks me to specify an IP address (as mentioned
> in the first post). What IP address is it looking for?

You didn't say what was on the screen exactly. Is it looking for a
music source or an IP address for the player itself?

If SlimServer is running and it doesn't find it, it may be that you
have a firewall turned on? do you?

Jim
2005-11-20, 22:49
I know with Windoze for direct TCP/IP connections between computers they use 169.254.*.* range, and not 192.168.*.* as with proper networks.

I don't know Mac, but did you check your IP address ?

MrC
2005-11-20, 23:12
Jim - the 168.254.*.* IP range is an RFC-specified automatic private IP address range (aka "link local"), used for auto-assignment when no IP address is configured or can be found. It allows, for example, peer-to-peer connections w/out user intervention, but more generally automatic connections on a single link. This is OS-agnostic.

I'm not sure what you mean by "proper networks". 192.168.x.x (ie. 192.168/16) is just another RFC-specified private IP range. Users can also use 10/8 or 172.16/12 addresses. See RFC 1918 and 3330 for more info should this be of interest to you.

Jim
2005-11-20, 23:20
Yes. And as much as I can configure my network to use any IP address there's always some smart-*** on the internet with a private designated IP, or at least one that looks like one.

I was just trying to explain without getting technical. Now like I admitted I don't know Mac but Windoze always defaults to 169.254.*.* for a 1-1 connection (poor man's network) as opposed to the standard 192.168.*.* you usually get with a consumer networking hub/switch (proper network).

Of course with the Mac it's probably completely different, maybe you need to go to their music store and buy an IP address which of course you never own......and which has a more restrictive DNS than China...

MrC
2005-11-21, 00:06
Yes. And as much as I can configure my network to use any IP address there's always some smart-*** on the internet with a private designated IP, or at least one that looks like one.
Hmmm. Considering that internet routers do not pass private IP addresses onto the internet, i'm not sure what you mean.


Now like I admitted I don't know Mac but Windoze always defaults to 169.254.*.* for a 1-1 connection (poor man's network) as opposed to the standard 192.168.*.* you usually get with a consumer networking hub/switch (proper network).
This is because consumer routers have built-in DHCP servers. It DHCP giving out the IP, not the router portion. Some routers have their DHCP servers configured for the 172. range.

raphaeladidas
2005-11-21, 00:14
On Nov 19, 2005, at 5:39 PM, raphaeladidas wrote:
> I've followed these steps over and over again (before and after
> posting) and it always asks me to specify an IP address (as mentioned
> in the first post). What IP address is it looking for?

You didn't say what was on the screen exactly. Is it looking for a
music source or an IP address for the player itself?

If SlimServer is running and it doesn't find it, it may be that you
have a firewall turned on? do you?


It's looking for a music source and it happens whether or not the firewall is on.

dean
2005-11-21, 08:28
Ok, so that means that it's connected to your wireless. I assume
that scrolling UP/DOWN doesn't show the name of your computer, right?

This means that it can't connect to SlimServer. Confirm that you
have the SlimServer software installed and started in your System
Preferences.

Then check the IP address of your computer's Airport card under
Networking. What is it set to? What did your Squeezebox say the IP
address was? (i.e. did it start with 192.168... or 10.0.... or 169...

On Nov 20, 2005, at 11:14 PM, raphaeladidas wrote:

>
> dean Wrote:
>> On Nov 19, 2005, at 5:39 PM, raphaeladidas wrote:
>>> I've followed these steps over and over again (before and after
>>> posting) and it always asks me to specify an IP address (as
>> mentioned
>>> in the first post). What IP address is it looking for?
>>
>> You didn't say what was on the screen exactly. Is it looking for a
>> music source or an IP address for the player itself?
>>
>> If SlimServer is running and it doesn't find it, it may be that you
>> have a firewall turned on? do you?
>
>
> It's looking for a music source and it happens whether or not the
> firewall is on.
>
>
> --
> raphaeladidas
> ----------------------------------------------------------------------
> --
> raphaeladidas's Profile: http://forums.slimdevices.com/member.php?
> userid=2386
> View this thread: http://forums.slimdevices.com/showthread.php?t=18322
>
>

raphaeladidas
2005-11-23, 12:09
Ok, so that means that it's connected to your wireless. I assume
that scrolling UP/DOWN doesn't show the name of your computer, right?

This means that it can't connect to SlimServer. Confirm that you
have the SlimServer software installed and started in your System
Preferences.

Then check the IP address of your computer's Airport card under
Networking. What is it set to? What did your Squeezebox say the IP
address was? (i.e. did it start with 192.168... or 10.0.... or 169...
]

Okay, I power cycled the Squeezebox and things are SLIGHTLY better.
Here's what happens now:
*I set up a computer-to-computer network (call it NETWORK1)
*I choose NETWORK1 from the Squeezebox
*It connects to NETWORK1
*I auto obtain an IP address (169.254.xxx.xxx)
*Squeezebox asks me to select a music source. Before it only gave me the choice of entering an IP address. Now it shows NETWORK1 (192.168.xxx.xxx) but when I select that it can't connect. SlimServer is definitely running.

Robin Bowes
2005-11-23, 12:20
raphaeladidas said the following on 23/11/2005 19:09:
> *I auto obtain an IP address (169.254.xxx.xxx)

This won't work. You're not getting an IP address from your router properly.

I've seen a similar problem.

Try doing a factory reset and then entering the configuration
information again. This fixed it for me, most times.

R.
--
http://robinbowes.com

If a man speaks in a forest,
and his wife's not there,
is he still wrong?

raphaeladidas
2005-11-23, 12:30
raphaeladidas said the following on 23/11/2005 19:09:
> *I auto obtain an IP address (169.254.xxx.xxx)

This won't work. You're not getting an IP address from your router properly.

I've seen a similar problem.

Try doing a factory reset and then entering the configuration
information again. This fixed it for me, most times.

R.
--
http://robinbowes.com

If a man speaks in a forest,
and his wife's not there,
is he still wrong?

Referring to my original post, there is no router: I'm trying to connect directly to my AirPort card. But how is what I'm getting different from a properly obtained IP address?

dean
2005-11-23, 23:21
On Nov 23, 2005, at 11:09 AM, raphaeladidas wrote:
> Okay, I power cycled the Squeezebox and things are SLIGHTLY better.
> Here's what happens now:
> *I set up a computer-to-computer network (call it NETWORK1)
> *I choose NETWORK1 from the Squeezebox
> *It connects to NETWORK1
> *I auto obtain an IP address (169.254.xxx.xxx)
> *Squeezebox asks me to select a music source. Before it only gave me
> the choice of entering an IP address. Now it shows NETWORK1
> (192.168.xxx.xxx) but when I select that it can't connect. SlimServer
> is definitely running.
You are getting closer.

That last IP address is probably left over from when you connected
previously.

If you don't see the name of the computer listed (along with it's own
169.254... address) then it's likely the computer has an IP address
in a different range (you can check this with the Network Utility or
under Network on System Preferences) or you have a firewall turned on
on your computer (under System Preferences -> Sharing).

raphaeladidas
2005-12-01, 15:28
On Nov 23, 2005, at 11:09 AM, raphaeladidas wrote:
> Okay, I power cycled the Squeezebox and things are SLIGHTLY better.
> Here's what happens now:
> *I set up a computer-to-computer network (call it NETWORK1)
> *I choose NETWORK1 from the Squeezebox
> *It connects to NETWORK1
> *I auto obtain an IP address (169.254.xxx.xxx)
> *Squeezebox asks me to select a music source. Before it only gave me
> the choice of entering an IP address. Now it shows NETWORK1
> (192.168.xxx.xxx) but when I select that it can't connect. SlimServer
> is definitely running.
You are getting closer.

That last IP address is probably left over from when you connected
previously.

If you don't see the name of the computer listed (along with it's own
169.254... address) then it's likely the computer has an IP address
in a different range (you can check this with the Network Utility or
under Network on System Preferences) or you have a firewall turned on
on your computer (under System Preferences -> Sharing).

SlimServer is running. I stopped the firewall completely. It's still not working. Maybe it's me but the advice I've been given so far hasn't really been helpful. Can someone pretend like they are setting up this network on their computer and walk me through exactly what steps they would take to make it work?

raphaeladidas
2005-12-02, 15:31
Never mind. I decided to just buy a cheap router and all is well.