PDA

View Full Version : SlimServer keeping my NAS active (noisy)...?



akilgore
2005-11-14, 06:12
Hi all,

I've recently moved my music onto my new NAS (Synology DiskStation 101g+). The NAS is set to spin down the HD after 5 minutes of inactivity. Once this is done, the HD should not spin up again unless something accesses it. Likewise, the NAS's internal fan should not kick in unless the internal temperature gets too high.

When I want to listen to music, all works well...

However, the problem arises after I've finished listening to music and turned all players off. At this point, there's absolutely nothing on the network that should be accessing the NAS. However, for some reason the NAS's HD spins up briefly every few minutes or so. This activity is enough to cause the internal temperature of the NAS to exceed it's limit resulting in the fan kicking in. So, the net result is that the fan kicks in for a few minutes every ten minutes or so. All very frustrating as the fan is far from silent.

Anyway, after much tinkering with my network (e.g. taking devices of 1 by 1), I'm pretty sure that whatever is preventing the NAS from spinning down is running on my server PC which also runs SlimServer. To go a step further, I stopped the SlimServer service whilst the NAS was mishaving and the NAS went silent for the rest of the night!

Does anyone know what might be causing this problem...?
Or of a way to debug/cure it...?

Many thanks,
Andy.

mherger
2005-11-14, 06:24
> Does anyone know what might be causing this problem...?
> Or of a way to debug/cure it...?

Could be that slimserver writes out configuration, DB or playlist changes
every x minutes. You could try to move these files to the machine running
slimserver so there's only the music files on the NAS.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

akilgore
2005-11-14, 12:08
Hi,

Thanks for the reply...

I wasn't aware that such files existed.
Do you know what they're called or where I would find them...?
(I've had a look in my music folder (including hidden and OS files) but there wasn't anything obvious in there).

Many thanks,
Andy.

mherger
2005-11-14, 12:39
> Do you know what they're called or where I would find them...?

You're on Windows? slimserver.pref should be the configuration file,
slimserversql.db the database. Playlists are stored in the folder you
defined in the server settings of the web interface.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

akilgore
2005-11-14, 14:09
Hi,

> You're on Windows?
Yes, SlimServer is running on Windows 2000.

I searched for both the files you mentioned and neither of them exist on the NAS. (slimserver.pref exists in the server subdirectory and slimserversql.db within .../server/cache).

Thanks anyway,
Andy.

mherger
2005-11-14, 14:21
> I searched for both the files you mentioned and neither of them exist
> on the NAS. (slimserver.pref exists in the server subdirectory and
> slimserversql.db within .../server/cache).

What about playlists?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

akilgore
2005-11-14, 14:56
Hi,

> What about playlists?
Don't have a playlists folder setup.

I had completely forgotten about the FileMon utility from SysInternals - am using this now to monitor file/directory access to the NAS from the server PC. Will post my findings.

Thanks,
Andy.

MrC
2005-11-14, 15:13
Which debugging options would show open files or file accesses?

Michaelwagner
2005-11-14, 19:54
Which debugging options would show open files or file accesses?

--d_files will show opening and closing of files (by slim, not by the db)

I don't know if anything will show accesses.

Some flag or other tells you when the cache is flushed, but I can't see right now which it is (and I threw away the old logs which showed me when I was done with them).

akilgore
2005-11-15, 00:39
Hi all,

I installed FileMon on the server PC and set the player running for about an hour or so. Then I powered off the player and left FileMon running throughout the night and the NAS in it's "cycle". Checked FileMon this morning and there were no file/directory accesses of any kind during the night :o(

However, when I stopped SlimServer there it closed a handle to the file that it was playing when it was powered off (via power button on the remote). It makes some sense that SlimServer keeps this handle open for faster resume etc. Anyway, SlimServer has been stopped for about 20 minutes or so and the NAS has been quiet for 10.

So, it seems that SlimServer keeping the handle open is causing the NAS some issues. Question is, is there anyway to make sure the handle gets closed? (I'm guessing there's no server option for this?) First guess is to try a stop prior to powering off.

I'll try this tonight and post my findings.

Thanks,
Andy.

adhawkins
2005-11-15, 03:50
Hi,
In article <akilgore.1yj2cn (AT) no-mx (DOT) forums.slimdevices.com>,
akilgore<akilgore.1yj2cn (AT) no-mx (DOT) forums.slimdevices.com> wrote:
> So, it seems that SlimServer keeping the handle open is causing the NAS
> some issues. Question is, is there anyway to make sure the handle gets
> closed? (I'm guessing there's no server option for this?) First guess
> is to try a stop prior to powering off.

Isn't there an option about whether to enter pause or stop mode when a
player is powered off? If it is in pause mode, presumably it keeps the file
open ready for a fast resume.

If it was in stop mode, this might not be the case. Worth a try?

If you can't find the setting, try hitting 'Stop' before turning the player
off?

Andy

wr4200
2005-11-15, 08:54
You might try playing with "power on resume settings" on the player settings Audio page in the web UI.
Try one of the stop at power off options.

________________________________

From: discuss-bounces (AT) lists (DOT) slimdevices.com on behalf of akilgore
Sent: Mon 11/14/2005 11:39 PM
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] Re: SlimServer keeping my NAS active (noisy)...?




Hi all,

I installed FileMon on the server PC and set the player running for
about an hour or so. Then I powered off the player and left FileMon
running throughout the night and the NAS in it's "cycle". Checked
FileMon this morning and there were no file/directory accesses of any
kind during the night :o(

However, when I stopped SlimServer there it closed a handle to the file
that it was playing when it was powered off (via power button on the
remote). It makes some sense that SlimServer keeps this handle open for
faster resume etc. Anyway, SlimServer has been stopped for about 20
minutes or so and the NAS has been quiet for 10.

So, it seems that SlimServer keeping the handle open is causing the NAS
some issues. Question is, is there anyway to make sure the handle gets
closed? (I'm guessing there's no server option for this?) First guess
is to try a stop prior to powering off.

I'll try this tonight and post my findings.

Thanks,
Andy.


--
akilgore
------------------------------------------------------------------------
akilgore's Profile: http://forums.slimdevices.com/member.php?userid=2305
View this thread: http://forums.slimdevices.com/showthread.php?t=18176

JJZolx
2005-11-15, 09:32
Check Server Settings > Performance > Keep Unswapped Interval and try setting it to 0 for disabled. This is a setting for some sort of attempt at keeping the server from being swapped out to disk. I believe it reloads the main web page of the web UI. Particularly if you use a skin like Fishbone, which displays library content on its homepage, then you'll likely be hitting the files on your NAS each time. Not sure, but it may do the same with other skins as well.

akilgore
2005-11-15, 15:08
You might try playing with "power on resume settings" on the player settings Audio page in the web UI.
Try one of the stop at power off options.

Hi,

I tried this and it seems to have done the trick!

Haven't needed to try anything else regarding album art etc. as I don't run the web browser that frequently (nor do I have any album art!).

Thanks to everyone that helped me with this.

Cheers,
Andy.

Michaelwagner
2005-11-15, 17:29
Thank you. NAS & Slim is still relatively new, and you added to many people's knowledge by asking the question and then testing to find the solution that worked.

CouchPotatoe
2005-11-15, 19:15
Matt E. Alioto wrote:

>You might try playing with "power on resume settings" on the player settings Audio page in the web UI.
>Try one of the stop at power off options.
>
>
>
That's an option I hadn't seen before - but it doesn't seem to work the
way I had expected. If you stop the current track whilst the player is
ON (or have nothing playing) and then turn it OFF and ON again it starts
playing :-( I would have expected it to only do that if something had
been playing at the time the player was turned OFF. Maybe the intent
was different when it was implemented...

K

wr4200
2005-11-16, 12:17
>
>That's an option I hadn't seen before - but it doesn't seem to work the
>way I had expected. If you stop the current track whilst the player is
>ON (or have nothing playing) and then turn it OFF and ON again it starts
>playing :-( I would have expected it to only do that if something had
>been playing at the time the player was turned OFF. Maybe the intent
>was different when it was implemented...


Are you saying that when you set it to "Stop at power off / Remain stopped at power on"
that the SB starts playing automatically when you turn it back on?
Sure you didn't choose the other option to "Stop at power off / restart song at power on"?

If so what sersion of SS are you runing?