PDA

View Full Version : How resource-hungry is SlimServer 6.x compared to 5.4.0?



Oliver Laumann
2005-11-11, 04:58
I have been using a Squeezebox with SlimServer version 5.4.0 for
almost a year. The server is running on an antique notebook computer
with a 366 MHz CPU and 512 MB RAM that is used as the house server for
its low power-consumption. I have an iTunes library with 2000 songs
(iTunes 4.x).

I would rather not change this configuration, because it is working
fine. However, as I'm upgrading to a more recent iTunes version, I
assume I also have to upgrade to SlimServer 6.x, because only this
version can handle the new iTunes library format (the one with
playlist folders). (Please correct me if this isn't true.)

What I'd like to know is if SlimServer 6.2 can efficiently run on a
366 MHz machine or if I need a faster server. With SlimServer 5.4.0,
a database rescan took about two minutes. Will this be roughly the
same with SlimServer 6.2?

Craig, James (IT)
2005-11-11, 05:11
Oliver,
It seems pretty consistent that iTunes rescan times have got worse in
v6.2.
Memory usage should be the same or lower (and 512Mb is more than enough
memory)

However you could install SlimServer 6.2 as well as 5.4 to see how it
performs first - no need to remove your 5.4 installation, just stop it
and do the 6.2 install in a new directory.

(I am not sure that 6.2 is required for iTunes 5+ playlist folder
support)

The only issue I can see is with
A) firmware upgrades/downgrades on your players, so you might want to
keep them powered down until you've investigated the rescan performance.
B) the SlimServer service needing switching between versions if you're
using it.
But these should be easily worked around.

Then if you're happy with 6.2 you can reinstall again, over the 5.4
installation to upgrade all your current preferences.

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

karma
2005-11-11, 05:48
Hi has anyone experienced this phenomenon on a Mac OSX. I have turned off album art but Slimserver behaves itself and then suddenly eats up up to 70% of my cpu power, the only way to stop this is to stop and restart the server. this is driving me nuts, i thought this problem would go away when i switched to mac from windows. i am running all latest and have both a slim1 and slim3 running in my house. (hardware = imac G5 1gig ram). please help!

is there a memory leak or something else happening?