PDA

View Full Version : Slimserver no longer plays .m3u playlist files outsideplaylist folder



Leo Breebaart
2005-11-06, 03:36
[ I mistakenly tried to raise this issue directly on
bugs.slimdevices, but I now understand it's more a design
decision than a bug, so I am bringing it over to this forum
instead. ]


On 6.0.2 I can do "playlist play /path/to/somefile.m3u", either
from within the web interface or by talking to the CLI directly,
and the songs in that playlist file will then be played.

On 6.2.0 (and 6.5b1) this simply does not work anymore. In the
web interface I can browse through the folders to exactly the
same playlist files that work on 6.0.2, but I cannot even add
them to the current squeezebox playlist, let alone play them.
Ditto for the direct CLI interface: exactly the same command that
works in 6.0.2 no longer does in 6.2 and higher.

I have looked at bug reports 1701 and 2408, and from them I think
I understand the reasons for leaving out playlist files when
doing a scan of a directory during building the global SlimServer
database, or when doing from within the UIs an "add all" on a
directory *containing* an .m3u file.

However, is it that wrong of me to expect/desire that when I
*explicitly* click on, or in any way try to play a single
*specific* .m3u file, no matter where it is located, that it
ought to work, just as it did in 6.0.2, as long as the paths
mentioned in it are correct?

I don't want to come across as one of those people who thinks
that just because they have a certain need the whole product
should conform to it, but surely the two behaviours could
co-exist and many other folks would be made happy as well?

I am absolutely not interested in SlimServer's database or how it
adds various types of files to it. But just as I am still able to
play an arbitrarily located music file by saying "playlist play
/absolute/path/to/file.mp3", I'd really, *really* would like to
be able to continue to do the same thing for .m3u files as
well...

--
Leo Breebaart <leo (AT) lspace (DOT) org>