PDA

View Full Version : Lots of missing Genres?



Jim Larson
2005-11-02, 23:15
This past Saturday I did the folowing:

1. Upgrade from slimserver 6.1 to 6.2.1 (and today to 6.5b1 in attempt to resolve Genre issue described below). Complete rescans were done with each upgrade.

2. Used MP3Gain for the 1st time to change about 2000 mp3's to approx. 89db.

3. Used MP3Tag for the 1st time to fix about 25 mp3's with incorrect/missing tags.

It appears that one or more of these 3 actions has now caused a very large number of tracks (not all) to show up in the web interface with absolutely no mention of a Genre (i.e. on the Song Info page the Genre: line is completely missing!). When I choose Browse Genres, and choose say 'Country', it's only listing 12 out of over 200 artists with songs in that genre. I've got about 75-80 unique genres that still show up in the Browse Genre list. Browse Artists is still working just fine.

I went back into MP3Tag(version 2.32a) and verified that every song does indeed have a genre tag assigned. I tried all 4 combinations of the new compilation & band settings, followed with complete rescans - no luck.

Also there are 77 tracks with a genre of "No Genre".

All 2000+ tracks are kept in one large C:\My Music directory, on a brand new WinXP box, with only 1 album in its own subdirectoy. There is also a ShoutcastBrowser_Recently_Played subdirectory containing 1 .m3u file.

I've had my SB2 for a little over 2 weeks now, and I think I would have noticed this problem during the 2 weeks prior, but maybe this has been a problem all along? Nah, I doubt it.

Any ideas? If MP3Tag can still see all the genre tags, shouldn't slimserver also be able to read 'em all?

Jim

Jim Larson
2005-11-03, 00:30
Correction: Browse Artists seems to work fine, until No Album is selected (e.g. Browse Artists > Aerosmith > No Album). It then proceeds to list 978 tracks from 530 different artists.

"Browse Artists > Aerosmith > All Songs" does work correctly, listing only my 7 Aerosmith tracks, some with the album and some without an album.

Mark Lanctot
2005-11-03, 07:51
Did you follow the directions Geoff B gave me on
removing ID3v1 tags and writing only ID3v2 tags in
Mp3tag? Things worked much better for me with
only ID3v2 tags.

Also you may want to rescan your library, this
time selecting the "Clear library before rescan"
option. Or just a normal rescan - I found
yesterday that I now have a "No genre" entry that
has nothing in it. When I do a rescan, suddenly
all my FLACs have no genre. Rescan with "clear
library" and it's back to "No genre" still there
but empty. That I can live with.

Jim Larson wrote:
> Correction: Browse Artists seems to work fine,
until No Album is
> selected (e.g. Browse Artists > Aerosmith > No
Album). It then
> proceeds to list 978 tracks from 530 different
artists.
>
> "Browse Artists > Aerosmith > All Songs" does work
correctly, listing
> only my 7 Aerosmith tracks, some with the album and
some without an
> album.
>
>

--
___________________________________


Mark Lanctot
___________________________________

Dan Sully
2005-11-03, 11:11
* Jim Larson shaped the electrons to say...

>Also there are 77 tracks with a genre of "No Genre".

Jim - can you please send me one of the tracks in question?

dan | at | slimdevices.com

Thanks.

-D
--
It does not do to leave a live Dragon out of your calculations..

Jim Larson
2005-11-03, 12:22
I'm at work right now -- I'll respond to both Mark & Dan's suggestions/requests later tonight. Probably won't get a chance until about 10 or 11pm Central.

Did anything change re. ID3v1 vs. ID3v2 tags going from 6.1 to 6.2.1? I'm seem to vaguely remember a server settings page to select which tag versions to use when I first installed slimserver a few weeks ago. Remembering where to go for all these settings is going to take some time. I honestly never really paid much attention to the tag versions over the past few years while acquiring digital music & using MusicMatch -- it's never been an issue before.

I'll search for the Geoff B. mp3tag directions shortly.

Jim

P.S. I *always* do Clear library before rescan. Only takes a 1 minute or 2 on my PC.

P.P.S. I'm amazed at how good even the older 128kpbs mp3's are sounding on my home theatre system. I'm now using EAC & Lame -aps for the new rips. EAC&Lame + Squeezebox2 + Definitive Technology speakers = total sonic satisfaction. Just need to get the genre thing working right.

random_tox
2005-11-04, 12:23
Yeah, I'm having simalar problems.

Using SlimServer 6.2.1. Files a are all .flac with the Vorbis(?) tags, not id3 tags.

It seems related to the problems users have discribed with playlist. Most tracks I see under my 'New Wave' genre also happen to be in a playlist. But a few tracks show that are not in a playlist that I'm aware of. Most other 'new wave' tracks (several hundred) don't show in the list. Tracks that I know have the genre tag set don't show any genre under the slimserver's details for that file. The tags all show in Tag&Rename and other tag apps.

Changing the 'server Setting, behavior, filter genre' setting either way and doing a full erase/rescan library has no effect. Eliminating or specifying my playlist folder setting then rescanning playlists has no effect.

I don't see this listed in bugs (though I don't quite trust my ability to opperate the search interface) so I'm going to add a bug for this, unless someone has a fix I don't know about.

Jim Larson
2005-11-05, 15:24
Found the Geoff B instructions for cleaning up the tags with mp3tag (leaving just ID3v2 tags). But that didn't work for me -- still having the same symptoms with Browse Genres.

Sent Dan a sample track -- he already has a fix scheduled for tonight's nightly release. Apparently some (most?) of my tracks are not quite following the exact tag standard. Dan said he was able to work around that. I'll try it out tomorrow & report back on the results.

Jim

Jim Larson
2005-11-07, 13:23
Problem fixed! - I had several tracks with the genre tag set to 'country' (with a lower-case C). I changed those to 'Country' (upper-case C) to match all the rest of the tracks in the Country genre. Clear/rescan, and now all my previously missing artists are showing up in "Browse Genres > Country" again!

This had affected the listing of many more artists than just those few with the lower-case genre tag.

Jim
Win XP, SS6.5b1

P.S. The latest nightly release had a fix to my 'No Genre' genre problem. Some tracks had non-standard tags that it is now able to read. Thanks Dan!