PDA

View Full Version : 6.1 to 6.2 performance hit?



sdevans
2005-11-02, 06:00
I've just upgraded my weak server from 6.1 to 6.2 and I'm experiencing some problems, to which I'll explain the background if it helps.

Used 5.4 for ages with the only gripe that I'd get a 1 second dropout every hour when the cpu would spike. I think it was to do with caching the database...

Went to version 6.1 and no longer any dropouts, HURRAH!, then I guess I got greedy and went to 6.2 when I saw that the Various Artists feature had been implemented, and the sox/oggdec problem had been fixed.

However whilst the Various Artists feature works (excellent!), the sox problem playing back ogg files is still a problem, so gone back to oggdec. But now I have regular dropouts every half-hour or so and when ever I interact with the web interface the slim process spikes for about 0.5 to 1.5 seconds.

Any ideas? I tried looking at server performance but nothing shows up.

Stephen

mherger
2005-11-02, 07:23
> But now I have regular dropouts every half-hour or so and when
> ever I interact with the web interface the slim process spikes for
> about 0.5 to 1.5 seconds.

Is it _whenever_ you access the web page or only on some of them? Eg. the
help pages should run fine, while browsing artwork is pretty heavy load
for the server.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

nmizel
2005-11-02, 09:25
I suffered from the same problems and had to step back to 6.1.1, I guess until bugs http://bugs.slimdevices.com/show_bug.cgi?id=2385 and http://bugs.slimdevices.com/show_bug.cgi?id=2416 are adressed.

Regards,
Nicolas

sdevans
2005-11-03, 03:37
Whilst I DO get a significant hit when using the web interface, I still get dropouts when no-one is accessing the server. So I'm not sure if it's a new problem in addition to the previously addressed bug. To be honest I hardly ever use the web interface, so the seemingly random spikes are more of interest to me.

Stephen.

sdevans
2005-12-05, 03:19
Sorry for the delay in responding, been away on holiday. Anyway to clarify, if anyone can help; now using 6.2.2, and I get a pause every 30 minutes, which seems fixed to the time my server boots, i.e if the server comes on at 8:00am then I'll get a pause in music at 8:32, then 9:02, then 9:32 etc. I hardly ever use the web interface much so I don't mind those pauses (i.e browse artwork shafts it big time).

What's it doing every 30 minutes, and can I change the interval?

ceejay
2005-12-05, 04:11
Seems unlikely that this would be the problem... but don't RSS tickers update every 30 minutes?

Ceejay

DrNic
2005-12-05, 04:13
Sorry for the delay in responding, been away on holiday. Anyway to clarify, if anyone can help; now using 6.2.2, and I get a pause every 30 minutes, which seems fixed to the time my server boots, i.e if the server comes on at 8:00am then I'll get a pause in music at 8:32, then 9:02, then 9:32 etc. I hardly ever use the web interface much so I don't mind those pauses (i.e browse artwork shafts it big time).

What's it doing every 30 minutes, and can I change the interval?

I believe it is keeping the server files unswapped. There is a setting in Performance (Keep unswapped interval) that is set as default to 30 minutes. Could this be your culprit? Try changing the value and seeing if it correlates...

Nic

sdevans
2005-12-12, 06:59
Altered the cache settings to 65 minutes and that seems to be the culprit. I'll try altering the cache to something really short and see if it still happens. Thanks for the pointer.

Stephen.

sdevans
2006-01-12, 02:58
I thought I'd bottom out this problem and post my experiences on the forum so that it's there for anyone else. My 30 minute dropout is definitely caused by the "Keep Unswapped Interval" 'feature'.

On my piddly little server the reloading of the main page to keep the server process in main memory causes a 1-3 second dropout on the squeezebox 1 (wired). Setting the value really high for reloading just reduces the frequency of the dropout in music, but it then defeats the purpose (the process gets swapped out anyway). Setting it really low, just causes the dropout in music to happen really often (I was hoping it would just keep everything in main memory).

Therefore my solution at the moment is to disable this reloading (set to 0). The only drawback is whenever I've not used the interface for a time, the process has been swapped out and there is a delay in menu response for a second. But I'd rather live with that, than gaps in the music.

"Keep Unswapped interval

If the server is unused for some time, the operating system puts it into swap space. This setting determines after how many minutes the server reloads its main page to keep the server process in main memory. Set to 0 to disable the reloading"