PDA

View Full Version : Slim 6.2 and Ogg Vorbis



flatop
2005-10-29, 15:26
I hoped this would have been fixed when I upgraded to 6.2, but alas, it is not.

I am running 6.2, on a Gentoo Linux AMD 64 box. Everything is OK, but I am unable to play any .ogg files. I am able to play them using different players on the box, so I think the codecs are all good.

Any ideas?

I have the same setup on a x86 box, and everything is OK, so I think it may have something to do with th AMD 64 chipset.

radish
2005-10-29, 15:46
What happens when you try? Error messages? Weird sound? Nothing?

flatop
2005-10-30, 10:45
Just pure static - its sounds just like when you try to play a data disc in your music CD player.

Dan Sully
2005-10-30, 10:52
* flatop shaped the electrons to say...

>Just pure static - its sounds just like when you try to play a data disc
>in your music CD player.

In your convert.conf file - remove the $-x$ from the lines where 'sox' appears.

-D
--
Adobe Photoshop - When you want the truth. Real bad.

flatop
2005-10-30, 11:06
I modified my convert.conf file like you said, restarted the slimserver daemon, but now I get nothing. The title scrolls across the display, but all levels are zero.

bmilner
2005-10-30, 16:16
I modified my convert.conf file like you said, restarted the slimserver daemon, but now I get nothing. The title scrolls across the display, but all levels are zero.

I was having the same static trouble with ogg. It turns out that sox 12.17.7 ignores the "-x" flag. I manually updated to sox 12.17.8 (compiled it myself) and now ogg no longer does the static thing.

Quoting from the sox site:

Released SoX 12.17.8 on August 22, 2005. Things fixed/added since version 12.17.7:
* "-x" option was being ignored since 12.17.7.

flatop
2005-10-30, 20:19
OK - I'll try that tomorrow.

smc2911
2006-03-20, 04:46
I have been experiencing the same problem. I've upgraded to sox 12.17.9 and still have the same problem (with or without the -x). Any suggestions would be greatly appreciated!

smc2911
2006-03-21, 02:58
Can anyone confirm exactly what convert.conf parameter string they are using to successfully transcode ogg using sox. I have the following:

ogg mp3 * *
[sox] -t ogg $FILE$ -t raw -r 44100 -c 2 -w -s $-x$ - | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ -r - -

and I get nothing but static coming through. I'm using version 12.17.9

Sean.

GroggyZ
2006-03-31, 06:55
had same problem with a hiss playing instead of ogg audio content as i just installed latest slimserver (default command line parameters in convert.conf)


ogg mp3 * *
[sox] -t ogg $FILE$ -t raw -r 44100 -c 2 -w -s $-x$ - | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ -r - -


upgraded sox (apt-get install sox) from 12.17.7-2 to 12.17.9-1. following libraries also got upgraded: libogg0 libvorbis0a libvorbisenc2 libvorbisfile3.

seemed to solve the problem.

pinkunicorn
2006-05-23, 07:41
upgraded sox (apt-get install sox) from 12.17.7-2 to 12.17.9-1. following libraries also got upgraded: libogg0 libvorbis0a libvorbisenc2 libvorbisfile3.

seemed to solve the problem.

Unfortunately, Ubuntu (Breezy Badger) doesn't have any later version than 12.17.7...

Guess I'll wait until Dapper Drake comes out. I don't have that many ogg files, so I can live with this a few weeks more.

verbatone
2006-05-23, 09:23
Pinkunicorn, I didn't realize you were on ubuntu from the other thread you had posted in.

I don't know why endian would makes a difference between windows and ubuntu, but it does, here are my configurations for a few oggs in convert.conf

#added -x to lame
ogg mp3 * *
[sox] -t ogg $FILE$ -t raw -r 44100 -c 2 -w -s $-x$ - | [lame] --resample 44100 -x --silent -q $QUALITY$ --abr $BITRATE$ -r - -

#changed from endian big to endian little in flac
ogg flc * *
[sox] -t ogg $FILE$ -t raw -r 44100 -c 2 -w -s $-x$ - | [flac] -cs --compression-level-0 --totally-silent --endian little --channel 2 --bps 16 --sample-rate 44100 --sign signed -

These work for me on my ubuntu system, and I think these are the only ones that are functioning on my system, meaning I only use the transcoding to mp3 or decode to FLAC. These worked with my breezy default install of sox.

GlennBooth
2006-05-27, 04:41
Hi,



upgraded sox (apt-get install sox) from 12.17.7-2 to 12.17.9-1. following libraries also got upgraded: libogg0 libvorbis0a libvorbisenc2 libvorbisfile3.

seemed to solve the problem.

I have this problem too. I'm running on Ubuntu 5.10, and
apt-get only seems to offer 12.17.7-2. Anyone know where
I can find a deb or source for the newer sox?

Thanks,

Glenn.

GlennBooth
2006-05-27, 05:55
I got the deb of the 12.17.9 sox version from the Debian web site and installed it with dpkg -i. Problem solved! Oggs now play perfectly.

Thanks for the pointers.

Regards,

Glenn.