PDA

View Full Version : Is it me or is MusicMagic broken in 6.2.1?



MeSue
2005-10-29, 06:36
I can't get a mix either in the Web UI or from the remote.
SlimServer Version: 6.2.1 - 4926 - Windows XP - EN - cp1252

Simon Still
2005-11-19, 10:23
On 10/29/05, MeSue <MeSue.1xo1on (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> I can't get a mix either in the Web UI or from the remote.
> SlimServer Version: 6.2.1 - 4926 - Windows XP - EN - cp1252


I see that no-one replied to this. No, i can't see any way to use MM in
6.2.1 either. Are we the only people trying?

lostboy
2005-11-19, 10:57
I'm not having any problems. 6.2.1 - 5194 - Windows 2000 - EN - cp1252.

I think people will need a little more info to help track down the issue.

Chris

Simon Still
2005-11-19, 11:30
On 11/19/05, lostboy <lostboy.1yr9pz (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> I'm not having any problems. 6.2.1 - 5194 - Windows 2000 - EN -
> cp1252.
>
> I think people will need a little more info to help track down the
> issue.
>
>
Using 6.2.1 production release (not nightly). The mm menu appears in the
server settings but i don't get the 'mm' icons next to any songs either
through the web interface or on SB2 players.

What else can i tell you?

netim3
2005-11-19, 12:05
Running SlimServer & MusicMagic on a Mac, I needed to stop SlimServer, Stop the MusicMagic services, restart the MM services, then restart SlimServer in order to get it working again. Now seems fine.

lostboy
2005-11-20, 03:07
Simon,

simple stuff first, and apologies if you've checked all these already. Just say so if you have and we'll move on.

a)Have you got a licence key into your MM app - integration with slimserver doesn't work until you have entered a trial licence key or full one. In MM check 'File' - 'Customize Options' - 'Server' and ensure that the API service is selected and running. Check the port number that is used for the API service, as slimserver will need to know what it is (default is 10002).

b)MM must be started with the API service running before you start slimserver to be recognised and integrated. Maybe as insurance restart slimserver with MM already running after you've checked the settings below.

c)slimdevices settings - firstly check that the music magic plugin is selected in 'Server Settings' - 'Plugins'. Restart slimserver if necessary - the 'server settings' - 'music magic' page should then become available - check this to ensure that the port number for the MM API service is the same. At the bottom of the main (first) 'server settings' - 'server settings' page - ensure that you have the radio button to use music magic selected (I didn't spot this one at first because I thought that enabling the plugin was sufficient).

d)Slimdevices interface skin - I know that MM integrates OK with fishbone and default, but I haven't tested any others.

Let us know how you get on.

Chris

Simon Still
2005-11-20, 13:45
On 11/20/05, lostboy <lostboy.1ysimn (AT) no-mx (DOT) forums.slimdevices.com> wrote:

> c)slimdevices settings - firstly check that the music magic plugin is
> selected in 'Server Settings' - 'Plugins'. Restart slimserver if
> necessary - the 'server settings' - 'music magic' page should then
> become available - check this to ensure that the port number for the MM
> API service is the same. At the bottom of the main (first) 'server
> settings' - 'server settings' page - ensure that you have the radio
> button to use music magic selected (I didn't spot this one at first
> because I thought that enabling the plugin was sufficient).


that's it. it was previously enough to select the plugin - i'm not sure what
this radio button achieves?

thanks.

ezkcdude
2006-01-02, 15:41
I'm also having problems with Music Magic. I tried re-starting both apps, and all the other advice here, with no luck. Any other suggestions?

ngomong
2006-01-11, 21:25
Hmmm... I seem to be having the exact same problem.

Music Magic:
* I am using a trial version of MusicMagic. I asked for a trial license key, and when I start it up, it tells me how many days I have remaining.

* I went into the Preferences and started the API service on port 10002

SlimServer:
* The MusicMagic plugin is checked in the server settings, and the MusicMagic menu item is available.

* I have ensured that SlimServer is looking for the APIs on port 10002

* On the Server Settings page, I ensured that the radio button is selected to use MusicMagic

So... I'm not quite sure what to do from here. I've tried several combinations of starting and stopping both MusicMagic and SlimServer. I have yet to see the little "mm" icon on either the server or player.

Any more ideas?

Ben Sandee
2006-01-11, 21:51
On 1/11/06, ngomong <ngomong.21i880 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> Hmmm... I seem to be having the exact same problem.
>
> Music Magic:
> * I am using a trial version of MusicMagic. I asked for a trial
> license key, and when I start it up, it tells me how many days I have
> remaining.
>
> * I went into the Preferences and started the API service on port
> 10002
>
> SlimServer:
> * The MusicMagic plugin is checked in the server settings, and the
> MusicMagic menu item is available.
>
> * I have ensured that SlimServer is looking for the APIs on port 10002
>
> * On the Server Settings page, I ensured that the radio button is
> selected to use MusicMagic
>
> So... I'm not quite sure what to do from here. I've tried several
> combinations of starting and stopping both MusicMagic and SlimServer.
> I have yet to see the little "mm" icon on either the server or player.
>
> Any more ideas?


Try this sequence to get a good MM scan:

- Make sure MM is fully enabled in SlimServer preferences
- Stop SlimServer, MusicMagic
- Start MusicMagic, verify API services are started
- Start SlimServer
- Do a FULL rescan (clear library and rescan)

It's only after SlimServer does a scan of the MM database that the mm icon
will appear for mixable tracks/albums.

Ben

treble
2006-01-11, 21:54
Maybe they are not finding each other...

In MusicMagic: do you see in the 'Slimserver' in Preferences -> Send To? If not... try starting Musicmagic with the -slim option (change your shortcut (on Windows) to something like:
"C:\Program Files\Predixis\MusicMagic Mixer\MusicMagicMixer.exe" -slim ).

Try this in the following order:
Start Slimserver
Start MusicMagic
Restart Slimserver

It works for me, using MusicMagic 1.5 and Slimserver 6.2.1

kdf
2006-01-11, 23:16
On 11-Jan-06, at 8:51 PM, Ben Sandee wrote:

>
> It's only after SlimServer does a scan of the MM database that the mm
> icon will appear for mixable tracks/albums.
>
and only after MMM has completed validating all songs.

-kdf

ngomong
2006-01-12, 10:00
- Do a FULL rescan (clear library and rescan)

It's only after SlimServer does a scan of the MM database that the mm icon
will appear for mixable tracks/albums.

Ben

THAT was the answer. Thanks!

It seems pretty obvious now. As usual, I just tried all the complicated stuff first. :)