View Full Version : HELP PLEASE - SB2 Will not connect to my network anymore

Mark Gillespie
2005-10-27, 02:22
Hi Everyone,

Can someone please help me? My SB2 will no longer attach to my network. This all started when I tried setting up my SB2 with my new WAP. After an hour or so I decided to give up on the new WAP and set the SB2 to point back at the old one. Now it wont connect to that either. I am using WPA encrytion and the SB2 will actually connect to the WAP within about 5 seconds according to the countdown timer on the SB. When trying to obtain the IP address the countdown timer gets down to 2 or 3 and I keep getting an IP of 169.254.xxx.xxx when my IP range is 192.168.0.xxx

The only thing that I can think that has changed since I tried setting up the networking on my SB last is that I have upgraded to SlimServer 6.2 which obviously has upgraded the firmware on the SB2 to v26.

I have another SB2 on my network that I have not messed with yet and that is still working. At the minute I dont want to try and go through the network setup just incase the same thing happens

Has anyone got any ideas how I can get this working?



2005-10-27, 02:55

Some thoughts:

Are both AP running at the same time? If so, and they are being used as DHCP servers to get the IP address for the SB this might cause the 169.254.xxx.xxx problem.

Try turning off the old AP and see if that helps.

Make sure you reset the SB by holding the power button down for a few seconds until it restarts

If the new AP still gives the 169.254.xxx.xxx IP address check that it is configured for the 192.168 range that you want.

As encouragement I am using 6.2 on WINXP and saw your message just after I had revised my AP to use WPA instead of WEP. All worked OK on my 3 SB2's so I am sure your problem can be solved.


Mark Gillespie
2005-10-27, 03:15
Thanks for the reply David,

I have just got my SB2 working with my old WAP now. The reason that wasnt working was because the password for the new WAP was longer than the old one and I had put spaces in after it instead of deleting the remaining characters. So the major panic is over as I can still listen to music :)

It is slightly annoying though because the SB2 actually said it had connected to the WAP which it obviously hadn't, is this a bug?

I still cant get my SB2 to work with my new WAP though even with the password as 12345678 so I know I'm not typing it wrong. I will have a go later tonight as I am having to work now (boring).

Due to the 169.254.xxx.xxx appearing when I had the password wrong for my old WAP and it not connecting I am going to assume that for some reason the SB2 isnt connecting to my new WAP(Netgear WG302) correctly and therefore will have a play with some of the settings.

And just incase anyone else has any ideas my WAP isnt being used as a DHCP server as my seperate firewall/router is. So this rules out the chance of wrong DHCP stuff coming through.

I will let you know how things go just incase it happens to anyone else in the future. If anyone else has any ideas I would still be happy to hear from you :)



2005-10-27, 03:38

Glad you've got your music back especially as your having to work. Luckily I am on a few days holiday.

With regard to the SB apparently connecting I did notice that when I rebooted mine it did try to connect as soon as I choose the network name. It obviously could not have done this as it had not asked me for the WPA passphrase so I just hit the left arrow to go back and entered that.

I would have thought that the setup routine should have gone to ask for the passphrase after choosing the network name so this may be a bug. Perhaps there is another way to reboot the SB back to factory settings other than holding the power button?


Mark Gillespie
2005-10-27, 03:49

It did ask me for my password after I had selected the WAP. I entered it incorrectly,on for my old WAP as it had lots of spaces after it, but then the SB2 said it was connecting to the WAP and after about 5 seconds it actually said that it was connected. Obviously there is absolutely no way it could have been connected as the password was incorrect. I did try setting the SB to WPA2 encryption just incase I was selecting the wrong type...when the SB tried to conenct using WPA2 it actually timed out and said that it could not connect to the WAP which is what I would have expected from the SB when I tried to connect to my old WAP with the wrong password. Everytime it connected with the wrong password I got the 169.254.xxx.xxx IP address which is what I am getting when I try and connect to my new WAP which is why I am assuming that for some reason it just isnt making the connection to the new WAP.

Although I am meant to be working I have set the new WAP password to be the same as the password on my old WAP therefore I only have to change the WAP that I want to access on my SB. I have tried turning off the old WAP so there is no inteference but it still doesnt work. I know the new WAP works as I am using it to connect to this PC that I am writing this message on. I have also successfully added my laptop to it too.

More ideas will be greatfully received as I am quickly running out of ideas. No dount it is something I am doing wrong, I just can't see it at the minute!

Thanks again


2005-10-27, 04:30

it seems the real problem now is that, for some reason, the SB is fixated on the 169.254 address.

I dont know if the following is possible, as I do not use my router as a DHCP server. I run a full domain setup with WIN SBS 2003. The router and server PC have fixed IP's issued by the SBS DHCP server but all other clients get dynamic IP's.

Can you with your router, even though it is acting as a DHCP server, allocate a fixed IP address (sometimes called a 'reserved' address) of say If so reboot the SB and go through the network setup but choosing a fixed IP instead of DHCP just to see if it will work. If it does, reboot and go back to using DHCP, hopefully, this series of acctions will have made the SB forget all about 169.254.

Best I can thing of for now otherwise an email to SD support containing a copy of these messages may get you some more help.

Good luck. I assume you work from home as I do - I find it hopeless trying to work when I have one of the type problems on my mind. I just have to deal with it first!


Mark Gillespie
2005-10-27, 10:13
OK a little update on my 'day at work'!
I tried the fixed IP thing and it did not work.
I then tried connecting my SB2 to my new WAP without any encryption at all an 'open system' hey presto it worked. So I then tried it with 128bit WEP encryption and yet again that worked. So I finally tried WPA-PSK TKIP encryption and it no longer works. Does anyone have any ideas why my SB2 wont work with WPA encryption with my Netgear WG302 WAP yet it will work with a cheap D-Link DI-624 Router WAP combination thing.

I would just like to add that the D-Link Router/WAP really has only ever been used AS a WAP as it was connected to the same Netgear FVS114 Firewall that I am using with the Netgear WAP.

Have I found an incompatible WAP for the SB2?

I woudl have thought the Netgear WAP should have excelled in comparison to the D-Link WAP. It has done when it comes to my PC's that are connected. They are working so much better with a much better signal. Yet the SB2 will not attach using WPA.

If anyone has any ideas I would really appreciate them



2005-10-27, 10:35
I saw this behavior myself when working to configure a new SB2 in a WPA network. The device would claim that it was connected, but it would continuously select the default private IP (169...).

I backed off all of my security constraints of my host network (WPA2,AES/TKP -> WPA,AES -> WPA,TKIP). It was this final change that made the difference.

With WPA, TKIP, the sb2 would connect to the network (like it said it did), and properly request and receive a DHCP ID. There is a seperate thread specific to SB2 / WPA /AES which I've also commented on.

SB2, firmware 26.
Linksys wrt54g


2005-11-09, 00:38
Hi, i have a similar problem with my Dad's SB2 and his Compex N28G router. He cannot log in using WEP or WPA. If no encryption is selected, everything is fine. I also got that 169.xxx.xxx IP problem with WPA

When I brought my Linksys WRT54G to troubleshoot, no problems encountered, SB2 can login whether WEP or WPA.

It appears that some routers WEP/WPA are not compatible