PDA

View Full Version : Forum/List Attachments



geoffb
2005-10-20, 10:59
Hi All,

I read several of the forums via the mail gateway (using GMail),
purely due to personal preference.
WITHOUT starting the forum vs mailing list debate again, I wanted to
find out (presumably from Slim Devices) whether it is possible to get
the forums altered to handle a few improvements:

- It would be good to have a link in the mail version of each message
back to the forum version, so that it would be easy to get to the full
web version from the mail version, for example to view inline images.
It would also simplify referring to other threads when replying to a
message.

- The mail version of each message only includes the link for ONE
attachment, even if there are more. It would be good if all
attachments were listed. This link works correctly (for me).
Here's one example: The online version of the message is:
http://forums.slimdevices.com/showpost.php?p=58607
What I get in the mail version is:
+-------------------------------------------------------------------+
|Filename: sb_case_2_with_speaker_box_sm.jpg |
|Download: http://forums.slimdevices.com/attachment.php?attachmentid=414|
+-------------------------------------------------------------------+

- The attachments in the web versions of messages don't work (for me).
I understand that this is due to the fact that I use IE, and that I
may be able to fix this by changing to another browser such as
Firefox. It would be good if this could be improved; I've
participated in several forums and attachments work there - why can't
they work here? This was fixed on another vBulletin site as per this
thread:
http://www.vbulletin.org/forum/showthread.php?t=63146&page=6&pp=15
So presumably it's solvable as an admin solution rather than a
you-must-change-your-browser solution.

Does anyone else get affected by this? If I'm the only one that this
all applies to, I'll shut up :)

Thanks
Geoff

JJZolx
2005-10-20, 11:59
- It would be good to have a link in the mail version of each message
back to the forum version, so that it would be easy to get to the full
web version from the mail version, for example to view inline images.
It would also simplify referring to other threads when replying to a
message.
I think this is a good suggestion. I'm no longer on the mailing list, but I was for a month or two after the forums went live and I wondered why there was no link to the forum thread. I imagine, though, that this wouldn't be possible for messages posted via the mailing list.


- The attachments in the web versions of messages don't work (for me).
I understand that this is due to the fact that I use IE, and that I
may be able to fix this by changing to another browser such as
Firefox. It would be good if this could be improved; I've
participated in several forums and attachments work there - why can't
they work here? This was fixed on another vBulletin site as per this
thread:
http://www.vbulletin.org/forum/showthread.php?t=63146&page=6&pp=15
So presumably it's solvable as an admin solution rather than a
you-must-change-your-browser solution.

Does anyone else get affected by this? If I'm the only one that this
all applies to, I'll shut up :)
I use IE and don't have a problem with attachments. In the case of image attachments I get a dialog box asking if I wish to save or open the file. What behavior do you see?

geoffb
2005-10-20, 12:29
I use IE and don't have a problem with attachments. In the case of image attachments I get a dialog box asking if I wish to save or open the file. What behavior do you see?

I see the same behaviour, and if I select 'open', I get a corrupt file. If I click 'save', then open an explorer window, navigate to the file and open it then it works ok. Then the file needs to be deleted. It seems that this is more work that should be needed for an image view.

Cheers
Geoff